Iris Garage Door Controller: No open?

Installed the Iris Garage Door Controller tonight. Followed instructions, cycled the door open and close. The tilt sensor works great and reports correctly. However when I hit the Open or Close buttons, the controller beeps and never opens. The manual suggests miswiring or obstruction. I triple checked the wiring, and nada. Anyone else have this problem?

My guess would be miswiring or incomplete contact at one of the terminals. What sort of garage opener do you have it installed on? Also could you post a picture of the terminals on the opener?

I thought of that as well. I ripped out the two wires and ONLY wired in the Iris, same thing. I put them both back in after twisting together the push button and Iris wires. You can see the doubled up contacts in the first image. The Red and White terminal block are the same ones used for my push button. I also dug out the manual for the opener and confirmed those are the correct terminals. I also switched the wires around for the Iris just in case, but nada.

@NotSoSimple I assume that the garage opener works fine with the wall switch? My only other suggestion would involve a volt meter. Hook up the leads from Iris to the positive/negative terminals on the volt meter. Activate Iris (should beep/flash) for about 5 seconds and the relay should switch on. You should see some voltage spike on the meter when this happens. (This is a low voltage system)

I can disconnect mine when I get home and can report back with the exact voltage figures.

It may as well be a faulty/loose wire within the Iris module itself.

Hope this helps.

Yes, wall switch unit works great every time. I will have to use the multimeter tonight and do some testing then, thanks.

I couldn’t find in the thread what garage door opener you have.
It’s not one of these is it ?

Luckily (or unluckily) mine is not listed. It is a 4000 series from 2009.

4000 series …what make ? Mostly curious and might help if someone else has same opener.

Also I really can’t tell from your photo how this is wired. Just saying

Found the issue I think. There is a constant 14v-15v on the two wires. I assume this is because my opener wall switch has a backlit LCD, temp display, as well as time. This means that my unit does not have a hard wired button, but the ‘wall switch’ is actually a wireless remote or uses drop resistance :slight_smile: Here is the unit: Explains a lot now. Some minor probing on the wall switch shows that there are two micro switches. Voltage across the switches until they are pressed, then no voltage. So no, the Iris (linear) GD00Z will not work for my unit without a bit more engineering.

Part Number on my unit: 139.53918D. Die Hard, red, w/ battery backup. It was before they sold units with any sort of internet connectivity.

1 Like

Makes sense. Basically if shorting the terminals doesn’t open the door the GD00Z will not work.

You opener has a button which is actually a remote as you mentioned.

Sigh, disappointing. Not sure I want to buy a spare remote and solder into it though. I would have to worry about the battery in that unit. Do not want to replace the opener either. Catch-22.

Yes, too bad. I don’t really understand why garage door openers don’t always have the ability to use a momentary switch for the inside control. Makes very little sense. Only reason I can see is so they can sell you their overpriced switch.

As long as you are hacking the thing, solder in a power adapter also :smile:

1 Like

I was able to find two contacts/solder points on my control panel. They are normally closed (Voltage running through) and when the button is pressed it opens that up which triggers the garage door. Unfortunately I could not get the Iris controller to play nice with it. Not all hope is lost though. Since I have figured out and soldered new leads onto the control panel I just need to find a Z-Wave relay to connect and I should be good to go. I already have an Enerwave tilt sensor so I can see status of the door.

Or just use a regular relay and have the Iris trip it to break the contact.

Just an update on this. I picked up a GoControl (Linear) FS20Z-1. With the custom soldering I did on my garage control panel, I hooked this up and it works. A little delayed (1-2 seconds) but good enough.

I ran into a similar problem with a gate opener I have. I installed a Linear garage door setup, but couldn’t get it to reliably open/close the gate. I narrowed it down to a ground loop problem, between the gate opener motherboard and the Linear unit. Even though my gate opener operates via a standard two wire push button, when I hook up the Linear unit it is hit and miss. I tried 3 different Linear boxes. My solution: took an old Genie remote and soldered the Linear two wires to it’s button. This isolates the two units, but does mean I have a battery to replace. I also had to solder the tilt sensor to the open/close gate switch to report the “state”. Overall, a kludge of a setup…there are a number of other ways I could have approached this, had I known in advance.

Can you elaborate on the tilt sensor state? Reason I ask is I have a mimilite coming soon to be used on my driveway gate. I want to try and find a way to report the state.Unfortunately there is not a good spot to place any sort of sensor.

My driveway gate has a limit switch built in, to stop the gate at the proper open location and close location. Since it is just an open/close switch, I tied it’s two wires to the two wire hookup inside the Linear tilt switch, then positioned the tilt sensor to “normally open”. Now my gate limit switch open/closes the circuit on the tilt sensor. Hope that makes sense.

If your driveway gate has a limit switch with two wires, it’s likely open/close. You could rig an Ecolink open/close door sensor (which has a built in two wire hookup) to it to report “state”.

I’m in the exact same boat NotSoSimple was in back in January. Can anyone post a picture showing which points I need to solder on the PCB of the wall control?

Are you trying to use the Iris/GoControl/Linear garage door opener? It did not work for me. I had to go with this:

Let me see if I can find a pic of where I soldered.