Intermittent Device Issues


(Guy) #1

I am using a SmartThings hub with a variety of Z-Wave devices. This technology is, of course, far superior to the X10 system I’ve used in the past. However, I still experience “issues” with some devices from time to time.

For example, I use a Jasco/GE dimmer wall switch to control and dim my outdoor coach lights. Recently, it simply stopped working. I can manually control the lights and dim them at the switch but I have no control via the SmartThings iOS app (awful) nor my handheld controller.

Today, my Schlage lock stopped working in the same manner. The lock works fine at the lock but not remotely. I’ve tried resetting the hub with no positive results. Most of the other Z-Wave devices, mostly lighting controls, seem to be functioning properly.

I know these devices are wireless and consequently a bit flaky. Nonetheless, it’s frustrating. Any suggestions and/or advice would be appreciated.


(Bruce) #2

Unfortunately, those Jasco/GE dimmers are flaky sometimes. You should try pulling the breaker it’s on, and resetting it, and see if that helps. Also, the problem with your lock could be related to the dimmer, because the lock could perhaps be trying to communicate to the hub via a route supplied by the dimmer. Dimmer fails, lock fails, etc.

One thing you can do is run a z-wave network repair. If the dimmer has dropped off the network, the repair can rebuild the network to a healthy state without it.


(Guy) #3

Thank you, Bruce. Your thoughts make sense. I’m currently trying the network repair but the wheel spins endlessly. I may try the repair through the website rather than my iPad. I appreciate you taking the time to help.


(Bruce) #4

The logging of z-wave repairs is marginal at best. Use the IDE, and have another tab open with Live Logging, you can see the log entries in there. If your network is healthy there will only be Start and End log entries for the repair, nothing else.


(Guy) #5

Hey Bruce. I’m not clear on the steps. I found IDE which appears to be a simulator? I’m unclear as to how to use it. I don’t want to take up a lot of your time. What does IDE accomplish? Does it interact with my modules, switches, etc.?

If I figure out how to run IDE, do I run it from the hub manager on their website or from the iOS app?

Again, thanks for your help. Sorry U’m not a bit more familiar with SmartThings.

Guy


#6

Support@smartthings.com is generally very helpful.

The IDE is the “integrated development environment,” the technical name for the website that lets you see your account and network details. You can get there by clicking on Developers in the top right of this screen.

You can also do the zwave repair from the SmartThings mobile app, it’s just that you see a few more details from the IDE view.

I agree with @bravenel that it’s likely the switch going offline is what caused loss of communication to the lock, but support can tell more from their side.


(Andy Rawson) #7

I have had those Jasco/GE dimmers do that before and usually the only thing that works is pulling out the air gap switch at the bottom or like Bruce said, cycle the breaker that the switch is on. It did the same thing on my old Homeseer setup too so it seems to be the switches. It can be months or years before it needs it again (sometimes a power outage due to a storm is a good thing :stuck_out_tongue_winking_eye:)


(Guy) #8

Thanks, Andy! I’ll give your solutions a try. I appreciate your help.


(Ray) #9

I make a habit of turning off the power to the hub for about 10 mins once a month now. Seem to fix a lot of weird problem for me.


(Guy) #10

Thanks, Ray! I’d not heard of a 10 minute reset but why not? I’ll give that a try shortly. I appreciate your help.


(Ray) #11

10 mins is just something I do but @JDRoberts did say something about 15 mins for zigbee mesh repair. I know this is a z-wave problem.