Intermatic PE653 Pool Control System

@jsumpter This is odd, I have never seen it before. I think I would redo step 2 after resetting the 953 controller. First use option #1 on the Learn mode screen (above). This should put the 953 back to 34P. At that point you should still see the 2-Remove Device, 3-Include Device options. Following this, go into the ST IDE and remove the 953 device if it shows up there (not the 653 - leave that there). Then do step 2 again: Put the ST hub in “find devices” mode, then on the CNTRL CONFIG menu of the 953, select the 2-RECV NET ONLY. Then see if you still lose the 2 & 3 options to include. If so let me know and I’ll try to reproduce it here. If you do get the 3-Include option, then just go on to step #3 and include the 653 into the 953.

Hi All, long time no see. Ive been using this pool controller for some years now, but just in the last few days ive been having some issues with smartthings. It was initially the fact that my Alexa voice control broke that keyed me into it.

It looks like I’m on a version from 2016, so its probably time to update the DTH. Ive been on the new app for some time, but for whatever reason the functionality has only recently degraded.

If i just want to update my DTH, do i simply just need to copy/paste the new code into the existing DTH? The reason I ask is because it did take me some time previously to get everything setup correctly.

Also, I just noticed that my livelogging is spamming this multiple times a minute. I imagine this has something to do with the DTH being out of date. Please see below. Thanks!

9a22a5ee-5f4e-4917-82e6-db8d7571503b 5:10:18 PM: debug <<<<< dly:500/500
<<<<< Dev resp: ThermostatSetpointSupportedGet() → 4304

9a22a5ee-5f4e-4917-82e6-db8d7571503b 5:10:18 PM: debug >>>>> ThermostatSetpointSupportedReport(dryAir: null, autoChangeover: null, cooling: null, furnace: null, heating: null, none: null, moistAir: null) - description:zw device: 0E, command: 4305, payload: 41

9a22a5ee-5f4e-4917-82e6-db8d7571503b 5:10:15 PM: debug <<<<< dly:500/500
<<<<< Dev resp: ThermostatSetpointSupportedGet() → 4304

9a22a5ee-5f4e-4917-82e6-db8d7571503b 5:10:15 PM: debug >>>>> ThermostatSetpointSupportedReport(dryAir: null, autoChangeover: null, cooling: null, furnace: null, heating: null, none: null, moistAir: null) - description:zw device: 0E, command: 4305, payload: 41

@KeithR

Nice progress on the new DH. I just opened my pool today, and update to the latest version and this is what it shows on my Pool Controller in SmartThings. FYI, all child switches are showing up. Is there a way to get this to populate correctly? Thanks!

@KeithR

I am able to manual turn on all but the heating switch using the child switches, but unable to control the heater and main controller does not populate or work execpt for creating child devices.

@KeithR Anything I can provide to help?

My PE953 display quit working but I am able to turn the pool and pool light on and off with it.
The programming to autostart the pool at 9am and turn off at 5 pm is no longer working.
Yes I changed the batteries and completely took it apart and cleaned it w. alcohol-I have never left it outside so there was no corrosion.
(it is 10 years old) and I was hoping to find some way to setup scheduling just for my pool on the PE653 without having to buy a new $200 PE953.
I am sure this 10 yr old PE653 has a very old firmware version…
Intermatic said if I bought a new controller PE953 I would have to send it to them to make it work with my old PE653.
I had thought about getting a Smart Things Hub instead of a new PE953-but it sounds like I would still have to change the firmware on the PE653 using a Z-Stick based on everything I have read here.

Followed Keiths advice to create a new Device Handler in Smartthings but there is nothing at his URL:
Does anyone have a new URL for it?
https://raw.githubusercontent.com/KeithR26/SmartThingsPublic/master/devicetypes/keithr26/intermatic-pe653-pool-control-system.src/intermatic-pe653-pool-control-system.groovy

He deleted the files in 2020, didn’t say why. Perhaps they no longer work with ST?
[Commits · KeithR26/Intermatic-PE653 · GitHub]

If you look at the tree before the deletes, you can still find the original files:
[Intermatic-PE653/devicetypes at 8f0da36e50562082ad31bac1452b1580937f7a95 · KeithR26/Intermatic-PE653 · GitHub]

I too use the PE653/PE953 for my pool. I have two of them, as my original PE653 caught fire due to rain intrusion. I bought the second set used on eBay, you may try there to see if anyone has any older ones. If we could figure out what version you need, I have the 2nd handheld controller that might help you program your setup. And I have their USB stick to update the firmware which I used on my original set once way back when. Let me know if I can assist.

Keith has code to do the programming in SmartThings, but I was never able to make it work. My PE653 is on Hubitat now so I don’t have a way of testing the ST dth.

Did you have to do a firmware upgrade on your PE653?
If so what version was it before the upgrade and what stick did you use?
I am trying to find out if I can use the newer Zwave stick.

I ordered the Aeotec ZW090-A Z-Stick Gen5-Z-Wave USB Stick and Antenna New In Box on Ebay for $32. Hoping that after I set it up on my laptop and hold it really close to the P653 that will work.I have been able to remove and include the P953 to the P653 even though there is no display as it is just a matter of button pushing. So will give that a try first using the instructions from the Intermatic site: MultiWave Downloads
Thanks for the offer to loan me another PE953 and stick-hopefully I won’t need it. If anyone out there has ever done this firmware upgrade with a newer zstick instead of the old CA8700 let me know. I am pretty sure this old PE653 has 3.0 Firmware because the sticker inside the PE953 says 3.0

If you want to borrow either the spare 953 or the Intermatic USB stick please let me know.

I seem to remember that when I upgraded the 953 that went with the 653 that burned up, it went to V3.4 - I would have updated it to the latest. MultiWave Downloads And when turning it on I seem to remember it said “34” in the corner.

The second 953/653 that I bought as a replacement are still running whatever they had when I bought them used. They came paired and I didn’t bother to swap anything. That 953 has a SOFTWARE VERSION REV 3.4 sticker on the back.

I’ve not tried to integrate the 953/653 with ST as of yet but its on my list of things to try this year once the pool is open. The 653 is pretty far away from the house so zwave signals will be a challenge.

The cheapest new PE953 I could find on ebay was $180 but it will have the newer 3.4 so I would end up having to upgrade my PE653 firmware to get it to work. Since I only need it to setup my pool pump to go on and off I am hoping that after I do the firmware upgrade I can just use smartthings to setup the schedule. I just can’t justify paying $200 for a remote control that I rarely use. Yes I have seen old used ones on ebay for sale but they are still wanting $200 and up for them.

There may be a difference between the 653 software, but I can say that I never did any direct firmware upgrade on it. When I updated my original 953 years ago to V3.4, no changes were required to the 653. It just worked. Those units were purchased in 2011. YMMV. Intermatic seemed to indicate to you there was some difference (saying you’d need to send your units back to them) but maybe that was just so your programming could be copied over to a new unit? My tech interactions with Intermatic over the PE653 didn’t impress me much - it seemed like it was an externally developed product that no one at Intermatic support knew much about. They’d have to ask “the one person” who knew anything and get back to me. That was in 2013-2014 era I think.

I asked AOTEC and this is what they said:
Ticket: https://help.aeotec.com/helpdesk/tickets/1463535

The Z-Stick Gen5 is backward compatible with older products, so it should be able to pair without problems, but you’ll need to ensure that the software you’re using with Z-Stick Gen5 is compatible with the intermatic PE653 assuming that the Intermatic conforms to Z-Wave standards.

Apart from that, I can’t tell you much about how well it’ll work or if it was setup in any special way that may block communications with it

Cheers,
Chris Cheng
Field Application Engineer
Aeotec Inc.

Notice a couple things:

  • The documentation from Intermatic doesn’t say anything about upgrading the PE653. You do the upgrade on the 953 only.
  • They don’t mention any incompatibilities with revisions of the 653 at all. No warnings to not update your 953 if you have such and such version of 653.

My guess is the 653 is a really dumb slave Zwave device, just performing simple BASIC SET and the temperature reports and the scheduled events as synced by the controller.

Most of the logic that would even need an upgrade is in the 953 as a zwave primary controller/scene scheduler, etc.

No, mine came (back in 2014) with v3.4.

:slight_smile: The man in charge of the project was Frank Pomeroy. He was the only one who knew anything about it and he retired several years ago. The support site for the PE653 was even askfrank.com. I had his cell phone but it must have been the property of Intermatic because it didn’t work when I tried it a couple of years ago.

I would not send my unit back to them for upgrading because I have zero confidence that anyone there (Wisconsin Intermatic) has the slightest idea of the product. It is an orphan.

1 Like

Well the stick will get here on the 15th so will let you know how it goes.
I’m just going to follow all of Keiths directions and see what happens.

I have the Firmware update loaded on my Windows 10 computer but even though I am telling it which port this Gen5 Z-Stick is in - it does not recognize it.
Even tried to see if the Z-stick would sync w. the 953 and 653-nope.
Loaded Domoticz and was able to ad it as a controller.
The only thing I have not tried yet is dragging out an old XP computer to try it on.
Will try that in the next few days.
A.

1 Like

@KeithR Been using the handler and love it. My only miniscule problem is the Sensors are not exposed to Alexa because the are part of the main switch. Is it possible to edit the Handler to Make Temp Sensors child devices?