Intermatic PE653 Pool Control System

@gt1gt1, that would be very easy. I’m out of town right now but returning home tomorrow. Should be able to knock that out quickly.

Charles, for my setup, this literally indicates that the PE653 has detected that the water temp sensor is reporting a temperature below the setpoint, and has turned on the heater (electric heat pump) by closing a relay that I have wired to the heater. I am not familiar with the solar setup. Does the PE653 actuate the “valve” you mentioned? If so, is there any indication of this on your PE963 remote? If so, I may be able to add something for that.

@kenfeyl, the DTH makes no heat on/off decisions itself (deadband), this all happens in the PE653. Any deadband would be implemented there. From my own observations my heater seems to come on as soon as the temp is even 1 degree below the setpoint.

This is strictly for a laugh from everyone. I guess it’s a bit hot in the northeast. First pic is after I turned the system on, second is a few mins later. :grin:

My PE653 failed to turn my Chlorine Pump twice this week. It worked fine for weeks. The schedule is still there.

I have remove the link to that circuit being a “cleaner” with pump at required speed. All I can think of is some times it reads the speed wrong and thinks it can’t run the cleaner. So I removed that dependency. Making a change like that clears all schedules. I put them in again and worked. But won’t know for weeks if it’s more reliable.

@gt1gt1, I just published version 3.0.6 of the DTH that makes the temperature change events visible. There are three separate events (Water, Freeze, Solar). You should be able to subscribe to these in a SmartApp or include them in CoRE pistons. Here it is:

@KeithR, Installed and published, now just need to wait for temp changes :-). I also installed Simple Event Logger ( ) to capture the events. Can you let me know if that should be ok? Also, just so you are aware, I am still getting an OutOfBounds Error in the logger (see below). One thing to note, last version I had installed (3.04), it was at line 799, now its at 806.

6:27:40 PM: error java.lang.ArrayIndexOutOfBoundsException: 32 @line 806 (zwaveEventManufacturerProprietary)

6:27:40 PM: debug ManufacturerProprietary event, [1]:40 [4]:87 payload: 05 40 02 02 87 00 01 02 00 00 00 07 00 00 00 00 00 10 04 00 00 00 00 00 12 1B 01 01 00 00 20 00 00 00 00 00 00 00 00 00


@CAL7, bumping this question. Any insights would be appreciated. Will probably do some work on the DTH this weekend.

Hi, Keith. I’m sorry, but I’ve been out of the country for awhile and won’t be able to experiment for about another week.

But, yes, the PE653 controls the solar valve based upon temperature. The PE953 shows a hearing status when the valve is actuated. It’s on the bottom right of the screen (you can see it in the PE953 pictures I sent you a couple of months ago).

I must be missing something really obvious. I’ve spent the last few hours (and several attempts over the last few months) trying various ways to pair the PE653 with ST, but nothing seems to work. I have the PE653, PE935 and ST hub all within 2 feet of each other. The ST is hardwired to internet. My PE953 is firmware 34P, and the PE653 is 34 (top right of controller states 34-34P).

I add device in ST, it just searches and searches. If I push the INCLUDE button on PE653 control unit, it just flashes 3 times and stops. If I go through P/S+ENTER setup on PE953 and hit 3 ADD DEVICE, it also searches and times out after a while, never finding a device.

AHA I had to RESET the PE953 and PE653 both back to factory defaults/unpair them. Then ST was able to add the PE653. In case anyone else runs across this and misses that step.

@KeithR Thanks for creating this device handler. I have installed and works perfectly. I have used M1-M3 to create various scenarios of spa temperature, lights etc. I have set my lights up as one of the switches and they appear as a child device that I can control through Routines, Scenes, Alexa connection etc. Is there any way to also control spa temperature in a similar fashion?

Good evening… I am a new spa owner and was researching automation with ST for it. I apologize if I dont want to read for 13 days and 736 replies but is there a more updated (there is 6 years of content here) guide for this?
Has anyone put together a hardware list with directions for installation that is the current working set per sae? With these long threads its tough to find whats current etc.
thank you folks

1 Like

I have the same question.

Can we set PE653 Clock with this DTH?

This DTH is for the Intermatic PE653. If you have one, then I have to say that this is the best integration of it into a home automation system that I’ve seen (I previously tried on Vera with limited success). If you don’t currently have a PE653, you should check out the product page to get an idea of what it does and what installation entails (it needs to be wired into the 110/220v lines that supply your pool/spa equipment):

Required equipment is just a ST hub and a PE653. I’d also recommend the PE953 remote so that you always have a way to control the system locally. Otherwise, you may need additional equipment if you want to control valves, lights, heater, blower, etc.

The hardest part of the DTH install is getting ST and the Intermatic equipment talking. Post #238 in this thread lays out the procedure - just follow it step by step.

The instructions to install the DTH are in KeithR26’s GitHub:

1 Like

Good morning, all,

Been enjoying this for nearly a year now, and the progress has been incredible. Kudos to @KeithR and all involved!

Minor issue I could use some help with: I’ve noticed that since I upgraded to the newest code, I can’t reliably delete my unused child devices. Specifically, Switches 2 and 5 are unused in my setup, and I used to delete them from my things list, just to keep the clutter down. I remember seeing this in the instructions somewhere, that you could safely delete any unused devices, and indeed I used to. Perhaps that was with the old version only?

Now, when I delete them, my switches still work, but it seems they work slower, and they do not report their status. For example, clicking “Pool Light” (switch 4) when it’s off will turn the actual pool light on, maybe a bit slower than before, but the button will stay on “Turning on” and inside the device, the tile still says off. --And shows as being off inside the controller app. Clicking it again from the things list will change it to “turning on,” but the actual status of the device is never correct.

The only fix I’ve found is to go into the settings of the main pool controller app and save the settings, which re-generates the child devices for switch 2 and 5, and everything works again, but my unwanted child devices are back in my things list…

Any workaround for this? At the end of the day, it’s a minor gripe to have unused devices in my things list, but if there’s a way to get rid of them, I’d love to.

Thanks again,

@philh30 @KeithR Been a long time since I have been on the community. I have been using the older version of KeithR code, but this season my PE953 was dead so I had to start over. I was super excited to read about the enhancements, particularly Pool/Spa mode direct control.
However, when I try to do my instructions from #238 I am getting stuck. I choose to Add Device, Auto-detect, and press Include on the PE653, and it insists on finding Z-Wave Switch Device. :I can change the Type to Intermatic PE653 Pool Controller, but that doesn’t get me the DTH. I am still using the same ST hub as before but the Android app has changed quite a bit. How do I get it to detect the intermatic DTH, or is there something else I am missing?

Which app are you using? It sounds like you’re using the new one, and this DTH is only working with the Classic app at this point.

Ah, that is helpful. I discovered the classic app was showing the DTH after I had reset everything and reconnected the PE953 as primary. The fun part is I spent a couple of days failing to get the classic app to connect to the ST hub (v2). I bought a v3 and couldn’t connect to it, so deleted the classic app and found the new one. On a hunch I swapped back to the v2 and the new app was able to connect, it was just random that I noticed the classic app and found it had miraculously worked as a result. #NeverEasy So this evening I will have another go at it. I am guessing that starting with the Z-Wave Switch Device and changing type is not an issue, is this correct?

Before I packed it in, I tried to connect the PE953 as secondary and had no luck. Given that the PE953 is brand new, is there any chance the procedure has changed? It still claims 3.4 but I saw in @KeithR 's release notes there are variations in 3.4.

You should be able to swap device type after joining. You then just need to go into the device settings in the app since that’s what kicks off the routine to set up all the child devices.

Intermatic hasn’t updated the firmware in years. I doubt anything has changed. Give it another try and make sure you follow the steps exactly. I know the 653/953 are really finicky about range though, so try to get the ST hub, 653 and 953 within a few inches of each other. When I did mine, I temporarily wired the 653 onto an old computer power cord so I could work on it inside.

Yeah, basically my plan. I do it standing next to the 653 in my pump room.