SmartThings Community

Integration with Two Arlo accounts


(DANIEL) #21

After some additional tinkering, had wrong virtual device selected, simulated motion sensor works, I was able to replicate yout success! Thank you for your help! Can you assist in using webcore to turn cameras off and on? Your piston screenshots were extremely helpful. Thank you.


(Jean May Jr) #22

It’s the same idea as motion sensor except we’re sending the camera on/off from Home to Home2. The piston in Home should look something like:


(DANIEL) #23

I appreciate your patience. I’ll admit I’m new to WebCoRE and it’s a bit tricky for me but, am enjoying it. Could you show a screen shot of Home2’s piston for on/off? thanks


(Jean May Jr) #24

It should look something like:


(DANIEL) #25

I had the dynamic set wrong, corrected, but still not triggering on/off state. Which virtual device did you use? Thanks.


(Jean May Jr) #26

Both sides should actually be using physical cameras for this one as we’re mimicking the on/off states.


(DanielP) #27

This has helped me alot. My use is simply to turn on/off more than the 5 Arlo cameras I have on the first account. I need a way to Activate my 6th and 7th Arlo when I am gone vs deactivate them when I am home. Here’s what I did and it worked.

I wasn’t clear at the beginning how to do it so if I may explain my approach using what you guys discussed above.

  1. Set up a new location in the IDE by choosing My Location -> New Location -> I called mine “Virtual Home”

  2. Add WecCore to the 2nd account via ie. wiki.webcore.co/GitHub_Install

  3. I added Arlo in the Smartthings Mobile app via MarketPlace | Cameras | Netgear Arlo | Connect Now

  4. Create 2 new WebCore Pistons in “Virtual Home” <- this is important, you should see no Piston at the beginning as this is not the “Home” Piston page.

a) With
Arlo Camera
Do
Turn On
End Do

b) With
Arlo Camera
Do
Turn Off
End Do

  1. I saved and then note down the URL.

For each piston you see this. External URL: [(click to open/execute)]

URL 1: graph-na02-useast1.api.smartthings. /api/token/111…
URL 2: graph-na02-useast1.api.smartthings. /api/token/222…

  1. Next back in to “Home” and find the Piston you want to activate the camera and do something like this

If
SHM is Away
Do
Make a Web Request. -> URL (use the URL that turns on camera) -> POST -> JSON
End Do

If
SHM is Home
Do
Make a Web Request. -> URL (use the URL that turns off camera) -> POST -> JSON
End Do

And this worked perfectly for me. Thanks alot


(DANIEL) #28

Jean, had some time to play with this weekend. My big issue was I renamed the cameras so I had to remove and re-add. It seemed to work great after that. However, for some reason I can’t get Home2 to turn on the Arlo Cameras only off. I looked at you code and everything mirrors exact so not sure if there is another setting somewhere I am missing. Thanks.


(Jean May Jr) #29

Quickest way to debug would probably be to add a Log info for the CameraOnOff / CameraState variable on both the sending and receiving piston to see what is being sent/received on both ends.