Integration Solutions using MQTT

I don’t see anything wrong with the way you have it configured.

Is the broker connected ok and the device showing it is subscribed?

You can use a mosquitto utility to monitor all messages to confirm what’s being sent. For example:

mosquitto_sub -t 'smartthings/#' -v -h <broker IP> -u <username> -P <password>

I would avoid using spaces in a topic. Can you instead use:

smartthings/switch/HallwayLight/state

In my case the dimmer level value is sufficient.

Thanks for the help!!!

1 Like

yeah it connected and subscribed , i ran mosquitto_sub -t ‘smartthings/#’ -v -h -u -P on my pi and its receiving the messages from smartthings but they are not getting to tasmota ,i can use mqtt explorer and send
topic- cmnd/smartthings/xmas/tree/Power

on

and it works

Thanks but unfortunately that didn’t work the switch won’t show up in home assistant,
It connects to the broker and I even used MQTT explorer and saw the device in there and I was able to see the switch turning it off and on in there. However no devices show up in home assistant, so I think everything is working from smartthings I’m just have a problem with these devices showing up in home assistant.

@Robert_Singh @montyfert

Guys- make sure that you don’t have networking issues. VPNs, firewalls, VMs, containers, etc can block traffic. Best thing to do is make sure all the relevant devices, including your MQTT broker, are all on the same subnet.

1 Like

hi is there a way to send a message from mosquitto (on my pi) to smartthings to topic xmas_tree .
thanks
martin

Absolutely. If all you are needing is just a simple switch, for example, I’d recommend trying my HTTP Devices driver. You can configure whatever topic and message data you need for switch ‘on’ and switch ‘off’ messages.

thanks ,
when i send http://192.168.0.86/cm?cmnd=Power%20On from a browser it works but not from the http switch does it need to be a specific thing for smartthings to send it .
thanks martin

hi i have got the mqtt working i created an mqtt switch gave it a topic etc and restarted the mosquitto brokeon the pi and it works great.
thanks
martin

hi please would it be posible to have an option for temperature in the mqtt device creator if you get a minute.
thanks again for all the help
martin

Yes, I’ll try to get that added sometime this week.

1 Like

Thank you your a star
Martin

has anyone got this working with home assistant? is there a smartthings add on you need? or does it just show in the mosquito integration?

MQTT is MQTT. It doesn’t matter who or what is publishing messages or subscribing to topics. You just have to know the specific topic to use. If HA is only looking for specific topics then you just need to make sure that topic is configured for the SmartThings MQTT device that is publishing messages… and vice versa

1 Like

Omg @TAustin you are the smartthings goat! I got it working in home assistant! I made a simple Mqtt switch to turn on a light and it’s instant! I even now added it to HomeKit through home assistant! It’s lightning fast! It’s way faster than opening up the slow smartthings app! This opens a world of possibilities!

1 Like

Nice! Glad you got it working :+1:t3:

Just want to say - this is AMAZING! I have some issue with my aqara P1 motion sensor (couldn’t update the detection interval in the ST app with the only edge driver that supports it at the moment) and started to learn all the zigbee/mqtt stuff. I was able to pair & set the detection interval via the zigbee2mqtt/mosquitto setup and now with MQTT Devices driver I’m now able to add the sensor back to my automatinos!

2 Likes

I have updated the MQTT Devices driver:

  • Added a switch to the dimmer device. This will enable the device to be used by both Alexa and SmartLighting automations
  • Added separate publish action values for lock device. This will allow configuring lock and unlock publish ‘action’ messages that are different from the configured received ‘state’ values.

Note that new devices will need to be created to use these new features. Existing dimmer or lock devices will continue to operate as they were.


Driver Version: 2022-12-17T00:45:50.022631669

2 Likes

Thanks for this update! I just redid my lock device to ring alarm lock via ring-Mqtt and this is just perfect for the two way communication!!

1 Like