Integration of ZWN-SC7 with SmartHub

I am am trying to get a Enerwave ZWN-SC7 working with a Smarthub.

I have followed Enerwave instructions and as far as I can tell the Button device has been recognized by the SmartThings App (on Android). That is: it appears on the list of devices as “ZWN-SC7 Button Controller” at my one “location” and in the one “room” I am setting up. I can tap on the device and I get a screen with a logo and and “on” and “off” buttons, which respond to a tap, (though don’t appear to do anything).

I have installed both the Smart App from Matt Frank, which is on the Enerwave site, and the Eric M App which is published on this community web site.

Both appear under My Apps, but when I open the App, I get an error message “You can’t currently add this”. This occurs with both Apps.

There don’t appear to be any topics associated with this problem. Maybe I have missed a step, but I have checked several times. Any suggestions or help with further diagnostic would be very welcome.

Unfortunately, Enerwave don’t respond to support requests.

Thanks in advance

Peter P

You’re going to be using this device in a way different than that which the manufacturer intended. That’s so you can take advantage of smartthings multiplatform features. You’ll even be able to use this device to control zig be devices, change modes, etc.

So to get this to work with SmartThings, you will need to follow the instructions in this forum and use some community created code. It’s a very popular device in the community, and there will be a number of people who can help you if you run into any problems. :sunglasses:

Start by reading the FAQ on custom code. That will give you the overview of what you’re going to do. It’s pretty simple, you’re just going to copy and paste the custom device type handler and the smartapp into your own account. It sounds as if you may have used only one or the other, not both. Or maybe mixed them from different sources.

After you read that, go to the forum thread on this particular device and follow the instructions there. That should get things straightened out.

If you have any follow-up questions, just ask in the device thread.

Looks like there may be a problem today installing new smartapps. :disappointed_relieved:

Thank you for a quick reply. Thoughts:

Maybe some problems today, but the fact is that I have tried to make it work more than once over the last many days. Today, I ran through the entire sequence again carefully, before writing my email.

What you say is exactly correct: You have to load a device handler, and an App. The two sets of code for that is here: I completed those installations exactly as directed, and they appear to have installed correctly. The problem I am hitting and described in my first email occurs after that.

I have an error message, with no explanation or diagnostics. It is not even clear which app is generating it - the SmartThings app or the device specific App. Oddly, Google search doesn’t find the error massage anywhere. That’s often a good way to find solutions, but not this time.

Not quite sure I understand your comment about using the device in a way that the manufacturer intended. Enerwave’s site describes it as ZWN-SC7—7-BUTTON SCENE CONTROLLER, which is exactly my application. (Actually, of course, it is not a scene controller. It is an event generator, which a scene control app can use to build the scenes. But that is a different story.)

Thanks again.


The manufacturer intended it to be used only with other zwave devices by communicating directly to them.

Instead, in a smartthings installation it is used as what smart things calls a “button controller” where it reports to the hub what button has been pressed and then the hub communicates To the other device. Consequently the other device can be using any protocol: Z wave, zigbee, LAN, a cloud service, etc.

Just as an example, once the device is set up with SmartThings, you can press a single button and turn on a ceiling fixture controlled by an in wall zwave micro and two hue bulbs, which use zigbee. :sunglasses:

Enerwave is very happy to have their device used in this way, but it’s not what they designed it for.

Enerwave’s device is certified as a “scene controller” by the third-party Z wave alliance. That’s a technical designation and describes how the device communicates with other certified zwave devices. It’s just that that is not how we use it with SmartThings. You may reach a similar end result, but technically it is not being used as a “Z wave scene controller.”

I’m sure it’s very frustrating. Glancing at the device thread that I linked to above, it appears that the specific error message that you ran into has been encountered by other people and the community has made a number of suggestions for resolving it. Since the people in that thread do have this device installed successfully, it would probably be helpful to talk to them. You’ll also be able to find the most up-to-date copies of the code there, and can verify that the manufacturer’s copy is the same version. Smartthings has made a lot of platform changes over the last year, and not all external sites have kept up.

Thanks for your patience and energy helping out a neophyte in this subject area. But I am still not connecting with what is going on.

When you say “third-party Z wave alliance”, just who is that? Is it I am not finding the zwn-sc7 anywhere on the site, and certainly not in a category called “scene controller”. It’s pretty hard to track though all the data, so please respond with the link if you have it

The manufacturer says it connects with a “master controller”, Anyone’s guess it to what that is?

  1. A master controller establishes the zwave network. It is the device that assigns the network IDs to the other devices as they join the network. In a smartthings account, the SmartThings hub is the master controller. In English, this is usually referred to as “the primary controller.”

  2. Yes, the Zwave Alliance is what I was referring to. They certify devices made by many different manufacturers, including SmartThings and control the use of the Z wave and Z wave plus logos. Part of that certification process is the issuing of a “conformance statement” which describes the device and lists the specific Z wave “command sets” that it both “supports” (can receive) and “controls” (can send directly to devices other than the primary controller).

  3. If you go to the zwave alliance products catalog on the official site you can then usually look up the conformance statement for any certified zwave product. Occasionally an older device will not have its conformance statement listed. That usually means the company has submitted a new model and it is in the process of being recertified. But you can write to the company and ask for a copy of their conformance statement if you can’t find it on the site.

In this particular case, we can tell from the zwave command sets listed in the manual that this device is a “scene controller” (technical zwave meaning of the term).

Also, I know we’re getting really technical here, but you’ve been asking technical questions so I assume you’re interested in that level of detail… :wink:

“Scene controller” is a “device class,” not a category. Usually they’ll be listed under the category “lighting accessories” on the Z wave alliance site.

Hmm. “Very frustrating” is the understatement of the month!

Yes, the specific error message occurs a small number of posts, after a search. I had established that before I posted anything. None to do with the ZWN-SC7. I guess I therefore infer it is a message generated by the SmartThings generic Smart App. That would seem to be confirmed by the fact that the same message appears in two distinct apps, though of course they may be using the same code, though are they likely to be equally out of date. But what kind of organization puts out apps with no explanation of error messages?

It is near impossible to find something like the latest version in these threads. One thread very helpfully advised me it would only take 113 minutes to read it! Great!

There is unfortunately a flaw in your thought that there may be help in the threads you reference. Because nobody has the problem with the SC7, nobody offers a solution. For them, that step just worked, apparently!

I take away your comment that I should see if I can find the latest version of the code.

This ecosystem is so primitive, in terms of organization and knowing what is what. Samsung/SmartThings deserve to be castigated for the overall sloppiness and lack of curation and consolidation of information… It is being sold as a consumer product, after all.

I appreciate you are doing your best to help, though specifics - here’s the solution somebody found - is so much more useful than “it must be somewhere”.

I think my point was, in answer to both your posts, that it is not there! Or are we using different data sets?

But thanks for all your clarifications. Who is “we” BTW?

I am unusually technical, but my intention was never to have to understand the entire z-wave infrastructure in order to install a scene controller…

1 Like

I agree, the forums can be really hard to use and the official knowledgebase has only minimal information.

That said, I promise you if I give you a link and I tell you that people there have seen exactly the same error message that you reported with the same device that you reported, they did.

Start with the following post. The next 15 posts or so, I don’t remember exactly how many, discuss that specific error message with regards to installing the SC7

It is a pretty generic message, and I’m not saying that those people ran into exactly the same problem that you did. But I am saying, as I’ve said before, that if you just go to that thread and ask your question there, those are the people who are most likely to be able to help you. They have the device, they have it working, and at least some of them have seen the same error message that you have just reported.

So that said, I’m going to leave you in their capable hands. :sunglasses:

By convention in these forums, the author of the code discussed in a release thread should put the link to the most current version in the first post of the thread. If it doesn’t appear to be there, just add a reply to that thread and ask where the newest version is and someone will tell you. It may be that it’s quite an old piece of code but still useful and the author no longer participates in the forums.

you did everything right. There is a glitch in the Samsung Smartthing App so if you could use an Ipad or Iphone to add the smart app to the device then it should be working.

1 Like