SmartThings Community

Integration of z-Wave /danfoss thermostatw

(John Denoon) #506

I found I had to use the official DH to set the wake-up time then revert back to the custom one. Never tried to go lower than 5mins though

1 Like
(Mark C) #507

ref the below thread that DH runs both POP and danfoss, supports alex/google voice and the wake interval changeing works (take a full cycle ie 5min) under the cog icon

(Tom) #508

I remember now that the quick on/off temperatures where from a previous version that allowed it to behave like a switch… but somewhere along the way the switch behaviour changed. Now ‘off’ is 4C and ‘on’ reverts to the previously set temperature.

Also the wake period setting needs some work. I forgot that it was ‘sleepy’ device so the setting only works when the device is awake. It should really save the setting and then send the setting when it wakes up :frowning:

(Piotr Taraś) #509

Hi @tommysqueak. It would be nice to add supported supportedThermostatModes API key to your DTH. Without this it will not work in Home Assistant Smartthings component. I have added below code and works well in ST and in Home Assistant. Just suggesting improvement. It may be usefull to some guys thinking about integrating with HA with built in component.

def sTM = device.currentValue('supportedThermostatModes')
if ((sTM != null) && (sTM != 'none')) {
    	sendEvent(name: "supportedThermostatModes", value: ["off", "heat"], descriptionText: "Supported thermostat modes are set to OFF and HEAT small caps")
} else {
    eventList << createEvent(name: "supportedThermostatModes", value: ["off", "heat"], descriptionText: "Supported thermostat modes are set to OFF and HEAT small caps")
(Tom) #510

Nice :slight_smile:

I don’t have an HA, so I’m not able to test it but as it’s an attribute it doesn’t look like it will do any harm. Can you create pull request and I can bring it into the code? Or maybe it’s something to add to the README as it’s optional thing for HA users. Up to you :slight_smile: