Integration of z-Wave /danfoss thermostatw

Hi,

ScheduleTstatZones can also use temp sensors and motion sensors (to see if the room is occupied or not) to adjust the setpoints…

You can even use an outdoor temp sensor to define some more/less heat thresholds.

And, many more features (ex. alternative cooling, can change your fan settings at the main thermostat based on some outdoor or indoor conditions, etc.)

Hi Tommy, I am using your DH. Its great - thank you. I do however miss the report from the device. I am not sure if my LC13’s do wake up every 15 mins as i have told them to. I have had problems with the messing up before.
Do you know how i can check the wake up interval? Thanks!

Danny

Hey @tommysqueak. Thank you for your hard work to date, I have been driving x15 of these radiator valves with your driver for a while now.

I am curious if you have tried the official driver now available from smartthings for the Danfoss Living Connect valve and what you think of it compared to your driver? I haven’t myself, and would only want to move if people thought there was a significant upside.

Thanks

Paul

Hi Danny,

I remember having issues myself with the wake-up interval. It always seemed to be stuck at 30 or 60mins. I can’t remember how I eventually fixed. This might help https://github.com/codersaur/SmartThings/tree/master/devices/zwave-tweaker I haven’t used it myself but I bookmarked it a while ago as a useful tool to interrogate devices.

I also think there’s a bug with the handler, in that because it’s a sleepy device the configuration changes don’t get sent when you save them, unless it’s awake. You can try waking the device manually and then immediately saving the a new wake-up interval from the config screen.

Hope that helps :slight_smile:

Great to hear the handler’s working about :muscle:

I haven’t heard of the official driver! Do you know where the code is or any other info? Be good to check it out and see how with inside knowledge how they approached it. With the lack of documentation, mine was based on a lot of sitting next to the radiator with trial and error. :slight_smile:

haha… very grateful to your trial and error @tommysqueak.

Yeh, it is an official Thing now. So you will find it listed under:

smartthings app/marketplace/things/home environment/Danfoss Living Connect

It would be great to get your views on it.

Cheers

Paul

Hi,

I have just bought a Danfoss valve but I’m not able to pair it into the Smartthings. When I click into add new thing I can’t see Danfoss valve, could you please help me on that?

Thanks.
Regards.
Javier.

Hi all, firstly this is a brilliant thread! Been really helpful in planning the move into controlling my rads.

This morning 14 Danfoss TRVs arrived at my door. I managed to pick up the 014G0012 ones with software 2.51 (according to the battery cover). The one I’ve got on a trial radiator was recognised immediately by smartthings as the LC-13 (happy days).

I can see that Brumster has successfully used these TRVs, I was wondering if the default handler is best to run them or if the DTH mentioned in this thread is more reliable or offers any benefit?

Many thanks

Louis

Hi guys!

I just joined the community and, well, I’m a total newbie in ST (received my 2nd gen hub today)

I’ve managed to connect the Danfoss Living Connect to my hub and I’ve downloaded the follow device handler:
tommysqueak : Danfoss Living Connect Radiator Thermostat LC-13 v3.01

My problem is that when ever I try to switch the Connect off via the SmartThings app, it doesn’t work. How come? What I’m I doing wrong?

  • I’ve tried to read through the entire thread, but it’s really difficult to find any answers to my issue.

Thanks in advance! :wink:

// Mads

@MrRhubarb its a battery device. It therefore polls at a regular interval to pick up its config (and any SetPoint changes). Have a look at the setting of the device and it there should be a refresh time. Check the log for the device and you should see it wake and update.

@Louage with regard to the DTH. I have;t tried the default handler. I installed mine before ST started supporting the TRV. I’m still using @tommysqueak 's handler. That allows me to set an ON temp and an OFF temp, fits my use case perfectly.

Good places to start are the logs at https://graph-eu01-euwest1.api.smartthings.com/ide/logs To see if the sleepy (battery powered) device is checking in, the app sets it to 5mins but I think the default is 30mins, so it might be checking in at 30min intervals. If you press a button on the actual thermostat, it will checkin and you can see some action in the logs.

Thank you so much for the quick reply :slight_smile:

I’ve just checked the log and it update perfectly:

Maybe I’m just having difficulties understanding the following parameters:
image

On the app I’ve set it to 28 celsius (also on the the Connect itself) to test if the Connect starts turning up the heat, but when ever I press turn off, it does not respond. I’m kinda curious if the manual setting on the Connect interferes with ST?

  • Sorry for the lack of terminology… I guess it will come late :smiley:

I was able to check out the official handler at the weekend and took some screenshots of the differences.

I had my eye saver app on, so apologies for the pink tinge in the screenies.

Luka’s radiator is using my handler.

The custom handler supports more capabilities. Like the ability to behave like a thermostat. So widening the range of smartapps you can use to interact with this, as if it was a thermostat eg Google Assstant. Also the switch capability allows smartapps to treat it as a switch and turn on/off. eg routines can turn the radiator off.

Thanks for the answer :slight_smile:

It looks like it’s checking in if I go to the device itself (the screenshot from my first post) - I might be mistaken
This is what I’m shown via the log link:

I’m using your handler from GitHub (which looks awesome), but how come I’m not shown the same “Current States” when looking at the device through the web GUI?

I might have missed a point, but what I basically did were to:

  • Install the Connect
  • Find it via the “Add a Thing” button
  • Published your handler using “From Code” to my hub
  • Open my Connect via the ST app and tried to controll it

If you added the device before publishing the custom device handler, your hub will assign the default handler to the device automatically. You can change the handler associated with the device from the IDE to the custom handler.

Quick note.

The ability to turn the rad On and Off (thanks @tommysqueak) works perfectly for me and my use case. I’ve got a number of rooms with rads on a zone that are used infrequently. Being able to turn those rad on and off is perfect.

Hi, you know that there is an app that can automatically turn on/off your TRVs and set your setpoints based on the concept of zones. You configure your rooms/zones/schedules and it will take care of the rest for you.

Regards.

Thanks Yves, we know :slight_smile:

Looks like you have the correct handler (my custom one), from what I can see from your screenshot.

It’s hard to tell, especially with devices that only check in occasionally like these battery devices. Here’s something to try, whilst near the radiator:

  1. Open the logs at https://graph-eu01-euwest1.api.smartthings.com/ide/logs Refresh if you already have it open, it stops showing logs after 10mins or so.
  2. Open the Smartthings app on the phone/tablet, open the handler and go to it’s settings screen. Wake up interval should be 5mins or set it to what you’d like.
  3. Wake up the Connect by pressing ones of it’s physical buttons.
  4. Back in the Smarthgin app. Save the settings on the phone/tablet (whilst the Connect is awake)
  5. Check the logs back in the browser (no need to refresh) at and see what it says, maybe share them here if there’s no notable difference.

Hi again,

Just tried to follow your steps, but still no luck. The live log doesn’t say anything after waking up the Connect and saving the wake up interval.

  • Really strange