Integration of z-Wave /danfoss thermostatw

Ditto. Not good. Come on ST, comment please @duncan???

If you have this problem please raise a ticket with ST support: support@smartthings.co.uk

Also raise a support issue here: https://support.smartthings.com/hc/en-us/requests/new?ticket_form_id=110843

1 Like

Don’t ST staff generally refuse to help troubleshoot community-developed device handlers?

Support won;t your right, but development might take some notice if enough of us whine.

Any news on this? All of my thermostats (7) now have E5 status… :confused: I also have two Danfoss room thermostats, which I used a modified version of the device handler for the LC13s, which are showing the same behavior with no heatingSetpoint getting sent. So basically I’ve lost all ability to control our heat.

It seems Likely that this is related to a bug that the community developers have identified. Smartthings staff are currently looking into it as well. If you’re interested in the technical details, you can follow them in the following thread:

If you’re a coder with a broken DTH, definitely check that thread as there is a workaround posted.

If you’re not a coder and you are using someone else’s DTH and they are aware of that thread, then there’s not a lot you can do right now except wait for the bug to get fixed.

2 Likes

@struna any possibility of you updating/branching (temporarily) the handler based on this possible fix?

1 Like

I got five of these LC 13 and using them in Germany (UK v2)
I already have the e5 Error (lost connection) and my set points can’t be change via smartthings.

Thank you guys for the information about this bug!
Smartthings was informed by myself too about the troubles.

Hope the ST programmers can fix it, because at the moment I got 300€ useless plastic plugs on my heaters :smiley:

1 Like

Some information for the DTH writers of the the thread.

In the post linked below @meavydev provides information in how to work around this issue. As and when you get 5 minutes perhaps you could have a look and see if it resolves your issues and then feedback.

Thanks all

@tommysqueak

I see from the link below that a fix is expected today / tomorrow for this, so maybe not worth developing a workaround at this stage;

https://community.smartthings.com/t/recent-platform-update-broke-parse-method-response-result-april-2017/85529/39?u=rjsm

1 Like

I’ve tested the workaround, thanks @JDRoberts for the links to the threads where the problem is discussed, with my non functioning LC13 valves and can confirm it does solve the problem with the Danfoss LC13. The valves had gone into E5 error and after updating the DTH i then had to re-FIX the valves to get them working again. They may have worked all on their own if i had more patience :slight_smile:

I see there is an expected fix due but if like me you cant wait and want your heating working again let me know and i’ll post the update to the DTH (Tom Philip’s “Danfoss Living Connect Radiator Thermostat LC-13 v3” original) to work around the issue. I created a new DTH and swapped over to it so i can swap back easily to the original once its all confirmed working.

3 Likes

Can you post please?

@brumster here ya go:

NOTE: For anyone finding this in the future this DTH was just a TEMP workaround to a firmware issue in April 2017 and (hopefully) will be fixed post 25th April. Smarterm Devs do say there is no harm in using the workaround code but i would still scroll up and find the original instead.

Edit: temporary device handler removed 25th April now the fix has been applied and tested working.

3 Likes

Thanks Paul. Just caught up on this thread. Looks like there’s a temporary fix from @Richard_Woodward (great work btw).

I’m not home at the moment, in order to be able to look into this but it also looks like it’s going to get fixed by smarthings themselves, so perhaps nothing to fix at the mo.

If they don’t fix it. @Richard_Woodward - can you open a pull request with the fix and I can merge it into the DTH?

2 Likes

@tommysqueak sorry i wouldn’t have a clue how to :blush: not a git hub user, maybe that’s something i should look into soon. The change is easy enough, it’s in the wake-up v2 notification zwaveevent and I’ve commented the start and end of code and commented out a single line of your original so it’ll easy for you to find and update if Samsung don’t deliver on the promised fix. Hopefully by tomorrow no one will need it anyway and we can see if someone can delete my post to avoid future confusion with others looking for a handler.

1 Like

Ah, excellent, I found your fix now :slight_smile: Thanks.

I’ll wait a day or 2 and check back in and see if they’ve fixed it. Looks like they will soon :pray:

1 Like

If it wasn’t for the sudden temp drop in the UK today i probably would never have noticed it not working, thought the house was a little chilly when i got home from work today and found valves in E5. Quick community search soon located the workaround and i had a warm house again :grinning:

This community rocks

1 Like

Yep. I owe @meavydev a beer. His quick fix has my SAF rating protected :wink:

2 Likes

Applied your update and radiators responding again, thanks! I see on the other chain that the hotfix has been released too. Hopefully nothing new introduced!

2 Likes

I’ve seen the e5 problem over the weekend, but as of today it seems to have resolved itself without me modifying the dth. Does anyone know if smartthings have updated the hub?