Integration of Z-Wave Danfoss Thermostat

What’s the name of that in the list of default DH? There’s only 1 Danfoss DH, and that doesn’t seem to work for me. Can you share the code?

Thanks in advance.

can it really be that no one has a nice DTH for Danfoss LC13? I’m having issues with the official DTH that always the E5 error shows-up. So looking for a reliable DTH - any help out there?

There is a new edge “z wave thermostat” driver which seems to work fine and I don’t see E5 errors anymore and it works fine with Google home too as radiator thermostat. Read more about edge drivers in smartthings how to install it.

is it this one you mean [ST EDGE] Z-wave Thermostat beta driver issues ?
or do you have a specific link?

Yes, that is the one. After I installed it and rejoined all my Danfoss Zwave termostats again, I no longer have isssues with E5 error showing on any of them.

Sorry, maybe you can help me as a newbee - how do I install this driver? I’m used to install a regular DTH - but that does not work here with this driver.

You can install them by using this link
https://api.smartthings.com/invitation-web/accept?id=450930c1-02a6-43d8-adaa-4cbc51027956

After installation, wait some time till they download to your hub. Later unpair your Danfoss TRV from smartthings and pair it by using “Scan for nerby devices”.

Before pairing make sure you don’t have any custom groovy DTH for Danfoss TRVs installed as it would take precedence over edge driver.

For more info check here

I am curious about how you people control the boiler in ST.
Im searching for an opentherm device to start the boiler/heatpump

I would like to have a zigbee or zwave opentherm device without a extra hub of something

Hi - also a newbee here… dont get it.
Did you manage to make it work?

Nope, still facing the same issues. Sometimes it works sometimes don’t

1 Like

I have living connect thermostats but after installing this driver ST is pairing the device as Z-wave thing and by default gives it Z-wave switch driver. I’m unable to switch to Z-wave thermostat driver. It doesn’t provide it as an option even though I have checked from the Hub drivers that it is installed. What could be wrong here?

Welcome

To assist you, could you please provide the exact model of the thermostat you have?

Go to My.smartthings.com/advanced and find the manufacture and model number and then post this in the correct forum with the Manufacturer Code and Model number and kindly ask @Mariano_Colmenarejo for assistance with adding to to his Zwave Thermostat MC driver.

Post it in the forum below.

See below information you need to provide.

1 Like

Thank you for your reply. Thermostat I have is Model: 8005-0002, Manufacture code: 0002-8005-0002

I will post it to the on the forum you linked.

1 Like

Hi, have same problem, have you already solved it?

I have 11 of these and had this happen on a few of them, the fix for me was to factory reset and repair. Sometimes a few times until it was paired as a z-wave thermostat that let me change the driver correctly.

thanks, tried several times, and still not working.

I’m new in the ST topic, but I:

  • istalled " Z-Wave Thermostat" EDGE driver
  • make exclusion for thermostat via Aeothec hub
  • add it to my hub

still cannot change driver / see it as switcher

It shouldn’t matter but try factory resetting the LC-13

  1. Remove 1 battery
  2. Then hold the center button while at the same time reinserting the battery.
  3. This will cause the valve to refit itself.
  4. When it has finished fitting press the center button to start the pairing process again. The display should flash.

Do this until SmartThings detects it as a z-wave thermostat. I has to do this up to 5 times before it worked. :confused:

done it also:/