Integration not working with Simple Control's Simple Sync App


(Gary Luton) #1

I use Simple Control Remote in my house to control all my devices from our tablets and phones specifically those that need IR commands. It works well.

I had set up the Smartthings hub to switch of things like air-conditioning connected to Simple Sync if doors or windows were left open using the Smartthings open/close sensor. Until recently this also worked well.

Yesterday there was an update to the Simple Sync App that runs on the Mac - since then I have noticed the Smartthings Trigger SmartApp cannot seem to get all the activities from Simple Sync App. It only picks up one that I don’t think I ever created called Home:poweroff. Needless to say, the integration to the other activities such as switch off air-conditioning no longer works.

I would normally jump at blaming the Simple Control Simple Sync App OSX update although I have tried an earlier version of the App and that doesn’t seem to work either. Has anyone else seen this problem?

I am using the latest code and instructions from Simple Control


(Gary Luton) #2

A quick update from me is that I solved the problem by uninstalling and reinstalling the Simple Sync App on the iPhone and Simple Sync App on the Mac. The problem seemed to be the configuration on the Simple Sync App that receives triggers from Smartthings was not being populated with the full configuration of my remote. It’s all working now and it works great!


(Automation Guru) #3

Thank you Gary. Is your configuration still working. I am keen to work with Simple control as it appears to have all the relevant intergrations for IP, IR and Zwave devices.


#4

I’m trying to get this to work the other way around. I would like to trigger 1 smart things device from simple control.

I can see SmartThings available as a device to add to my project in simple control, but the commands available within that device don’t make any sense. All I see is:

.DOOR LOCK
.DOOR UNLOCK
.LIGHT BRIGHTNESS
.LIGHT OFF
.LIGHT ON
.SONOS SPEAK
+WAKE ON LAN

I’m not sure what that’s supposed to mean and can’t get them to do anything.

Has anybody had any luck with controlling an ST device from SimpleRemote?


#5

I would like the answer to the above question as well. I can trigger Simple Control from SmartThings, but how to we trigger a SmartThings thing from Simple Control?


#6

I have 2 of these working but I can’t remember how I did it. They still work, but when I try to look “into” them in my SmartThings smartapps, I get to the first screen, where you choose your version of simple sync, then I click next and I get a white screen. Somehow or another this broke since I set them up, though as I said they still work. I don’t know how you’d setup a new one though given the blank screen.

Do you have the right smartapps:

roomieremote-roomieconnect: Simple Control
roomieremote-ratrigger: Simple Sync Trigger


#7

It’s the other way around that’s giving me trouble. How do I trigger a routine (for example) or trigger a virtual switch from Simple Control app on my iPad? Going the other direction, I can trigger Simple Control command from a Smartthings switch (for example).


#8

You should be able to add smartthings as a device in Simplecontrol. It’s
under Add Devices -> Cloud Services along with Ecobee, Honeywell, Nest,
Insteon… and Smartthings Automation.

Once the device is added and you pair the accounts, you can add smartthings
commands to your simplecontrol activities like any other device. The
command set is a bit limited and shows up as a somewhat oddly formatted
list:

.DOOR LOCK
.DOOR UNLOCK
.LIGHT BRIGTNESS
.LIGHT OFF
.LIGHT ON
.SONOS SPEAK
+WAKEONLAN

Once you select a command you should see your ST devices under Available
Devices.

Hmm… it looks like the blank screen issue that I’m experiencing is known:

Are you following the instructions for the 2015 ST integration here:

http://www.simplecontrol.com/wp-content/uploads/2015/12/SmartThings-Simple-Control-12-2015.zip

I’m trying to remember how this works. It looks like there are two smart
appsa and also a Device Handler:

roomieremote-agent Simple Sync

Do you have all 3?


#9

I get this part…

DOOR LOCK
.DOOR UNLOCK
.LIGHT BRIGTNESS
.LIGHT OFF
.LIGHT ON
.SONOS SPEAK
+WAKEONLAN

But when I select a command I do not see my ST devices under Available Devices. I do see an area to insert a Device ID which is blank.

I have everything installed right. I think. I mean, I can see my simple control activities in SmartThings. I just can’t see it the other way around if I want to access virtual buttons in smartthings via simple control. I even tried copying a devices id from the IDE and inserting it in the blank spot, but it didn’t work.


#10

I had this same issue back in May and Simple Control support provided this fix:
Just add this line at line 14 of Simple-Sync-DeviceType.groovy (inside the definition block) and republish the app for yourself:

command “getAllActivities”

The latest code can be downloaded from here which incorporates that fix:
https://www.simplecontrol.com/wp-content/uploads/2017/05/SmartThings-Simple-Control-05-2017.zip


#11

I have this updated file. I want to make sure I am explaining this correctly. I can get the Simple Control activities INTO SmartThings (which I believe this groovy file accomplishes correctly). It’s the other way around that is the issue. I cannot get the SmartThings ‘things’ into Simple Control and as such cannot add a button command within the Simple Control client on my iPad to trigger a SmartThings event, like to run a routine or turn on or off a switch…

I have a ticket I am opening at Simple Control.


#12

I never did see the actual device names listed. You have to choose a command from the first list (typically a .light on/.light off) then paste or type the device ID (from your Smartthings IDE device list) in the next screen. (See screenshots)

If there was ever an actual list of devices beyond this, I’m not aware of it and I’ve been using the app combo since March.


#13

Suddenly got this working my trying to create some remotes and the fields got populated. Seems to work now.


#14

I just updated the DH and smart apps to the 2017-05-14 code above.

I still have 2 roomie to ST integrations that show up in the ST app, but when I click on them I get a blank white page. I spent several hours messing with this in late 2016 and had integrations both directions working, then at some point out of nowhere it broke out from under me.

I keep getting an error “deviceNeworkId must be unique” and I can’t save any of my integrations.

Roomie are some lazy, scatterbrained sh*t coders man. I’ve always been sort of disgusted by the cluttered madness of their app. Stuff kind of works, but not in any concise, predictable, or sane way. It’s like they grew up on php and think rube goldberg messes are “engineering”. Get back on the adderall and clean up your code losers.


#15

I have been messing with this today in fact. I ran into the error “deviceNeworkId must be unique” as well. My fix was to delete the Simple Control SmartApp from the ST app on my phone, and then delete the SmartThings device from Simple Control and re-add it to Simple Control from scratch. When you re-add it to Simple Control, it makes you provide the username and password credentials for ST again, and then you get presented with the authentication page where you select the ST hub and go down the entire list adding devices. Once you do that, the Simple Control SmartApp will appear within your ST app and all will be well.

Speaking of Simple Control, you are correct that the coding is, to put it nicely, a bit unpolished. But what I have found is that the ST device link to ST is nice, but you can avoid cloud based lag by adding local devices to Simple Control directly. In my case, I added my Hue hub and Lutron Pro bridge as devices into Simple Control directly, and I programmed buttons to my Simple Control pages for these local devices. For the Lutron Pro bridge, you need to follow these directions to get the Lutron integration report e-mailed to you so you can get the device IDs:

For the Hue hub, you need to follow this link to get Hue device / Scene IDs:

https://www.developers.meethue.com/documentation/getting-started

With a little patience, you will be programming buttons with instant response time and no lag. It makes me wish that ST could find a way to have more local device control and only use the cloud when necessary (or in parallel).

If you have any questions on Simple Control integration, I have been pretty knee deep lately so ask away before I delete my brain’s memory cache to start working on learning WebCoRe.


#16

Well I guess I’ll have to try deleting my simple sync connect integrations. I’ve wanted to avoid this because they work, and I barely remember why I set them up and what they do, but I guess I’ll have to figure it out and redo them.

I just got a new tv and for unknown reasons my ST/Simple Control integration has decided that it is going to turn it on every time I come home.

I honestly believe the issue with Simple Control, and why I get angry about it, is not one of intelligence or coding skill, but a lack of conscientiousness about their work and its impact on their customers. I paid $50 for this functionality and it doesn’t work and they seem to have little interest in making it work, though they took my money. This behavior is something I’m unwilling to excuse, the way I would forgive a simple bug or coding oversight.

Thanks for the tip.


#18

Well, ok i’ve reinstalled all the SC apps, and a new trigger, which seems to work

All of my SC -> ST integrations have been lost however. I can add a new command, selecting the Smarthings automation device, choose the command like .LIGHT ON, but my Device ID list doesn’t seem to be getting populated. Any thoughts?


#19

yeah. When this happened to me, I got it to populate by going to the device in Simple Control, i.e., the actual Smartthings Cloud “device” you added, and look around for the “test remote” button, click that, and let it open the ‘test remote’ page and let it sit there for a minute or so. This ended up populating the ‘test remote’ page with my SmartThings devices, and then I saved it, and when I went back to programming buttons, etc., my devices showed up there as well.


#20

Well sweet. I’ve got everything working again like it used to. Thanks for your help!

Now if only I can get their dumb alexa skill working again. I have 3 ios devices that never seem to stay synced to the simple hub. One or the other one is always falling out of sync. Another ahem… “product” that I paid Simple Home $50 for that has zero pages of documentation.


#21

I don’t suppose you know anything about Simple Control and Alexa integration? I had it working but now its telling me that it can’t find any of my activities.

I can’t make heads or tails out of “simple hub”. It is a black box of woe which I also paid those guys $50 for. I have it running on a mac on my network, and I have 2 ios devices that are supposed to be kept in sync by it, but it never works. My devices are always out of sync, or activities become un-editable, or alexa can’t find them, or its complaining that its unlicensed, or that I have a simple sync license not a simple hub license. None of those things are true. I’ve given them plenty of money, but I can’t keep track of their ever shifting product names. They rename the same product more often than a mattress manufacturer…

Of course you can’t do anything with simple hub but reset it…

Ok well update: I’ve got my simple hub alexa integration working. The key is that aside from the “simple hub” running on my mac, I have to turn the “simple hub” switch on my iphone simple control client as well. This makes me wonder what “simple hub” really means. Why do I even need the mac “simple hub” then?