Integrating Sonoff Mini with ST. My findings

I have one more thing to try. I think the child devices are spawned based on the tasmota module configuration. You have already activated the mini template. I would delete the current parent device, go to the tasmota interface and change the module back to generic or basic and save. Then go back and recreate the device in the ide, add the ip address and hope it spawns a child device. Then you can reapply the mini module. Good luck.

Moddy, I added the mini template which updated gpio4 to 9, yes.

Hawks, that screen shot is not cutoff. Nothing about child device below that. I forced a new ip address via my router. Works fine from web interface. Ip address looks ok from the ST app (updated ip addr is there). Lastly, rebooted hub - unplugged and pulled the batteries. No change. I also update the mini template and re-activated. No change. All really good suggestions. Thanks.

I opened a case with smartthing because I noticed I could no longer delete Brett’s tasmota-power device handler. It says “devicetype is still in use by devices” but it is not. So I think I may have a problem with the power device handler on the backend (samsung world). Also, bought a few more mini’s. Thinking if I try one with a different mac address, i may see different results.

Again, I can’t thank you enough. I really appreciate the help.

I had that happen once. You should be able to delete the parent device from the ST app. Then delete the device handler in ide. Good luck.

I’m annoyed that you can’t get the Tasmotized Sonoff Mini to work and I can. I will attempt to talk through what I did, 9 times last night and we’ll see if something stands out that you didn’t do, like I didn’t do until Hawks_nest mentioned I didn’t have the 2nd device handler in place that I needed, then change the preference to the needed ip address as I know you already have.
I also had largely learned from this website, a very thorough experience flashing Tasmota to a mini, until I the 2nd device handler was shared.

1 open the Sonoff Mini and place the jumper off the bat.
2 connect ac power per schematic
3 having used windows 10, I created a hot spot with login and password sonoffDiy and 20170618sn and waited for it to show it had connected to the hotspot. I know when it connects because it shows one device out of 8, also including it’s ip address.
4 Open this program tool_01DIY85(3.3.0).exe, from this website after the mini onnects to the hotspot.
5 When the program opened, it showed the mini that had connected to my hotspot and was able to select it and test it, on and off, with the subsequent message that is referenced in the link to the 3 part process that I shared before my steps.
6 It is finicky, but once I learned what it’s preference was, it was consistent with flashing subsequent minis.
a)select “firmware flash” on the right
b)select “import firmware” then select the sonoff-basic.bin the 3 step process talks about.
c) when you select “Flash device list” just select what is already selected in the drop down, weird.
d) Then select “ok”
e) within a couple seconds the progress bar began, then when it finished I selected “yes” then closed all windows including the program.
7 When the new firmware was on, I found it hit and miss for it reconnecting, then show up as a sonoff-7425 or 3567, it’s a random number sonoff - xxxx network available as a broadcasting wifi network. Connect to it.
8 The first instruction on page two of the tutorial I filled in sonoffDiy for the login, then 20170618sn as the password again.
This was my technique for seeing it connect to my hotspot again that I already had setup.
You can change this to your network login and password later. I was at another location so I didn’t need to put that in if I wanted to continue to have it connect to my laptop As soon as possible.
9 When it connected the next time, windows 10 shows the ip address in the wifi hotspot. If it doesn’t open a browser for you with the sonoff basic toggle page, you can put the ip address on the hotspot page, in a browser.
At this point, I change the gpio 4 to switch 1 (9) - you might not have to do that has you have already done it-
10 Upgrade the firmware. I chose the OTA method and had better success than the author of the tutorial. (EDIT After flashing nine minis with the OTA method, with sonoff basic.bin, was not the right file to upgrade the firmware to where I could get it to be recognized in ST. tasmota.bin is what finally worked when I upgraded to that firmware. When it completes, I no longer had a need to keep the sonoffDiy and 20170618sn login and password and changed it to my home network and password because I unplugged main power, pulled the jumper, then reestablished power to see the new ip address assigned (at least I think it changed the ip address after I pulled the jumper then rebooted)
And you’re right, I had to change my wifi hotspot to match my home network after I changed the login and password so it would connect the final time to a wifi network to not only see that it would, but reveal the ip address of that specific mini.
yes, it’s worth it. Tiring from the push but worth it.

1 Like

Having recently flashed the 10 Sonoff mini devices with Tasmota, I’d like to run this by someone who knows better what they’re looking at. The first device I flashed was with a Tasmota.bin file and the information page on the Sonoff toggle page looks like this. Tasmota flash Sonoff mini tasmota dot bin

By the time I as able to get this far from when I started, I found some instructions for download the file Tasmota file from here, then selected this file to flash to the mini.
When I entered the ip address in the preferences in one of the 2 device handlers necessary for integrating it to ST, it worked. It made a parent and child device and I have toggle capabilities.
The other 9 mini’s were flashed OTA as a matter of just doing it differently and the information came out like this.
Tasmota flash Sonoff mini sonoff basic dot bin
What is the opinion of the version? I don’t know which one is newer/preferred. If you would let me know, I would appreciate it. mod

One difference, though I do not believe it really matters, with the Tasmota.bin, the blue light slowly blink on an off of the powered mini, the sonoff-basic.bin blink about 8 times, then no longer blinks when powered.
With it being covered, I am indifferent to whether it blinks or not. Just an observation.

I’d like to take this opportunity to answer my own flea bitten question. It’s probably taken me an additional two hours of hassle in figuring out the first mini I flashed with tasmota.bin from this website
Was the only one I was able to get to work out of the other 9 minis until this moment.
The answer to my last query is, the version that I was able to get a child and parent device is with the which come from uploading the tasmota.bin file, instead of updating the sonoff OTA from this link
Now, you may be able to use 6.6.0(release-basic) but I am not that cool, but was able to quite quickly download the tasmota.bin and updgrade wireless without an issue, then the 2 previously established DTH’s will work. So, 8 other minis to change to tasmota.bin, sheesh.

See my “Sonoff mini flashing station” post for a $10 setup to flash mini without the DIY Tool. Worked great and easy to make. I don’t know how to pull the link for the post into here.

I don’t really mind the OTA method, especially since I’m not going to make 75 of these things, but finding the right files has been a special obstacle for me since I started anything to do with programming about 5 weeks ago.

Hi there, back again. The Samsung backend people cleared my tasmota-power device handler problem. I deleted the mini, and the two device drives and started from scratch. Re-added the device handlers, and published them for me. Re-added the mini, set the ip address via preferences - same results (no child device). Tried to simulate the Tasmota device handlers as Hawks had suggested before on the IDE page. Same result. Works fine from the web interface, just can’t get it to take advantage of the tasmota-power device handler with ST.

I upgraded Tasmota to 8.1.0 on the mini with the url. I noticed it loaded 8.1.0 not as Moddy’s picture showed. I think I used the same file you suggested.


I doubt the minor “.” release is causing my issue. I purchased a few more mini’s, should get them by Tuesday. I want to try with a different mac add/device id.

Again, thanks for your help. Glenn

Should I be pulling the DiY jumper off the mini once Tasmota is loaded? I just reread your post Moddy. Also, which Smartthings hub are you using v2 or v3?

I pulled the jumper per instructions from the three-step webpage because once tasmota is on it, the DIY jumper becomes irrelevant.
My model is an sth eth 250.
Good luck with getting these operational and properly incorporated to ST. I had a lot of failure but re-reading all of the instructions making sure I didn’t miss anything, coupled with the recent post of all the steps I went through should drive it home.

Should GPIO4 be set to "switch(1)?

Yes. That enables the function of the switch contact as it was originally designed with eWelink firmware.
Have you seen DrZzs YouTube video for Sonoff Mini Tasmota flash. It’s about 5 months old, it could be helpful for you. That is covered in there.

If you go into the console on the mini (main menu), and just type ipaddress ? . What comes back? See below, for mine you’ll see a (IP unset) and then the IP address. Is this normal? I am wondering if this isn’t a result that Brett’s driver is expecting. I tried to figure it out; it’s a bit over my head.

19:56:24 HTP: Console
19:56:27 WIF: Checking connection…
19:56:29 CMD: ipaddress ?
19:56:29 SRC: WebConsole from
19:56:29 CMD: Group 0, Index 1, Command “IPADDRESS”, Data “?”
19:56:29 RSL: stat/sonoff/RESULT = {“IPAddress1”:"(IP unset) ("}

I never touched the webconsole in tasmota and I won’t while it’s working because I’m afraid to mess it up.

I looked at the tasmota commands and found how to set you ip. Maybe it might help you.

Set networking IP ( XXX.XXX.XXX.XXX ) addresses
IPAddress1 = set device IP address

  • = use dynamic IP address (DHCP)
  • XXX.XXX.XXX.XXX = set static IP address
    IPAddress2 = set gateway IP address
    IPAddress3 = set subnet mask
    IPAddress4 = set DNS server IP address

follow IPAddress commands with restart 1 to apply changes

I found this here

Sorry, the command is


The is missing in above post

It’s missing here to. It is missing the parameter input. IPAddress(x)

The brackets are actually “greater than” x “less than”. The post will not allow it. Check the link above for the command list for the command s

The child devices finally show. It is asking for “power channel” and “gpoi” in settings. I put in 12 for relay gpio, still didn’t work. Now I can’t erase the 12. What do I put in these? Only numermic input, pressing on/off doesn’t activate the Mini, can toggle in web interface.

I started this road 5 weeks ago and working from ground zero without any Sonoff minis or even a SmartThings account, to flashing tasmota to a sonoff mini and just installed my first sonoff mini behind my first light switch in my house yesterday.
With the help of several videos and Googling hundreds of terms and not really wanting to have to understand mqtt for using home assistant (though inevitably, I understand HASS is far superior and more in depth than ST.) I have not been successful in being able to use it in the SmartThings app. So far, I had only been able to use the IP address toggle page on the web.
It wasn’t until Hawks_nest mentioned I might not have the necessary device handler to make the parent and child device appear in SmartThings.
That was the last piece of information I needed, I had already done everything else.
My efforts in helping you because I was helped here, don’t be distracted by things I did not recognize as part of my process for getting this done.
Follow the links in the previous post of instructions for flashing tasmota to sonoff mini like I did.
Install the device handlers Hawks_nest told me to install and it should appear on your phone as a parent and child device.
Fair warning in this endeavor, this process is very new, that even some of the greats have to put up with it not being perfect to get it recognized by ST.

Under Power channel mine is set to 1. Gpio is blank