Insteon Local Control!

Help!! I cant find the directions to this anymore. I have insteon running on my SmartThings hub but it’s just through http post commands. I would love to have switches that return state but am struggling in getting this installed. Does this still work? I signed up for an insteon Dev account in the meantime and am waiting for their reply. If they deny it I’ll call support as I really would like to have state switches and control over my dimmers. I would much rather not have to rip my insteon system out and start over as I’ve dropped a bit of cash in it lol. Someone please point me in the right direction.

@idealerror, thank you for your great work! I got an outdoor on off switch working with ST thanks to your code. I’m not sure if you are still checking in here. I need help trouble shooting the refresh section. I used your latest code where you fixed the background freshing. However, the code is always detecting the switch as ON at 8% regardless if the switch is on or off. Otherwise the on off command works perfectly! Any input is appreciated! Thanks again!

I see we have DTH for a switch, a dimmer & I/OLinc, but Has anyone been able to create a DTH for a leak sensor? I would think it would be fairly easy, but I am very new to this and I am just learning. Any help or direction would be greatly appreciated.

Does the code work with the original hub? 2242-222

I’ve had the ISY interface running for a few months but it doesn’t find my ISY any more. The ISY works fine so I’ll keep it for the auto scenes I have setup.

Thinking perhaps I’ll pick up a cheap Insteon hub off eBay if that’ll get my devices back to being controllable through ST.

Picked up a Hub 2.0 off eBay - code works great, thanks!

Just one thing … my dimmers show at 8% when off. Known issue?

Use this device handler instead: [RELEASE] Insteon Hub 2244 and 2245 Dimmer and On/Off Plugs/Switches/Bulbs

1 Like

Thanks! Fastest ‘fix’ ever!

Edit:

I spoke too soon. Now everything reports ‘Off’ regardless of the state! I’ve a light here that’s reporting by the UD Admin Console as being at 50%. In the SmartThings log I get this:

4:53:13 PM: debug Device is off…
4:53:13 PM: debug Level: 0
4:53:13 PM: debug Status: 01
4:53:13 PM: debug Response is for correct device: 1DE140
4:53:13 PM: debug ParsedBuffer: 02621DE1400F19010602501DE14033B849200301
4:53:13 PM: debug Buffer: 02621DE1400F19010602501DE14033B849200301000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000028
4:53:10 PM: debug [uri:http://xxxxxx:xxxxxxx@xxxxxxxx:25105/3?02621DE1400F1901=I=3]
4:53:10 PM: debug Polling…

Following other thread …

Can anyone help me setup controlling insteon devices using 2245 hub? I tried just about all the solutions in the thread without luck.

has anyone found a solution to the blacklist error?

Tim,

I tried using this to control an Insteon switch and did not have any luck. One thing I noticed is the “OffPath” preference is a bool type, but it is requesting a string path. After changing the code to to be a string, it still did not work.

My final solution to the problem was to use Alexa routines being triggered by a virtual switch.

Best regards,
Bill