Insteon Local Control!

Is this still working? I followed the instructions, but cannot get my 2 switches or LED bulb to work.

Thanks!

I am a current Vera user w/ a very Insteon centric HA setup. I am not overly happy w/ Vera and would love to try Smartthings. Can anyone confirm that this works w/ a PLM and the Smartthings hub 2.0?

1 Like

So am I to understand with your statement that the SamrtThings HUB will ONLY control the Insteon devices for ON/OFF only, no dimming?

FYI: I have the ISY-994IR Pro with the Insteon PowerLinc (2413S)

K

Questions here… please bear in mind - I do not currently have ST - but considering getting a v2.

So - With this, how will Insteon devices appear in ST? I.e. Are they accessible/controllable as normal devices as if they were 1st party - or available or through scenes? Also, is dimming support? What about items like Keypadlincs?

Thanks

I’ve actually been modding a ton of Insteon device types people have made to include dimming, auto refreshing, etc. Essentially making them apart of SmartThings. So far I’ve gotten my SwitchLinks to be controlled through SmartThings with little to no problems with full support.

ALTHOUGH - The refreshing is a bit, inaccurate. If two devices try and refresh at the same time, the hub will only spit back a response from 1 device, not two. So it’s a bit tricky, need to figure out a way to refresh randomly rather than a calculated manor.

The API does have functions to allow for Groups/Discovery, although it’s a bit tricky to program it. We’d have to create a SmartApp called Insteon Hub as a service type and associate child devices.

Here’s an excerpt from the manual ( http://cache.insteon.com/developer/2242-222dev-062013-en.pdf )

Example of turning on device 0E7986 to Full On
Send:
http://172.16.1.34/3?02620E79860F11FF=I=3

The Buffer will have
02620E79860F11FF0602500E798609D6822B11FF 

026101110106 Echo of your Command: Turn group 1 On
026101110115 Response if you tried to turn on an empty group
025009316B09D682611101 Ack from a device (Clean-up)
09316B ID of a device in your group
09D682 ID of the Hub
61 Flags byte 20 = Ack + 40 = Group + 1 = Hop count

025806 Group command completed Ok
025815 Group command quit early Ok

I do not remember what Insteon calls it - but does it support the instant signalling of insteon when an action is taken?

Will this allow the ST hub to support FanLinc? I really need FanLinc in my life… I’m still shocked no one has designed a Z-Wave/ZigBee equivalent…

It’s not instant, there’s a refresher that has to run to pull the status. Similar to how the SONOS/HUE API works. It doesn’t directly trigger what happens, the actual devicetype has to pull it’s own status.

This is the problem right now because if two devices have actions at the same time, the buffer may or may not spit out what the actual status is.

In development.

I’m looking deeper into FanLinc. I see it has Light On / Light Off / High / Medium / Low / Off . Unfortunately I don’t own one yet so developing a devicetype for this may be a little tricky.

1 Like

I’d buy you one but at $60 and I don’t even have an Insteon hub myself, it’s a little a little bit out of my reach at the moment :pensive:

I was wondering if it works with the older Insteon hub (2242). I tried adding a device with the Insteon Switch (LOCAL) but it is not working when I try to turn it on… Thanks

yes I am using the 2422 hub and it works fine.

Thanks a lot. Then I wonder what I am doing wrong. I tried 2 different insteon devices and filled out all the items in preference the way it was described but no luck. Any idea? (the devices turn on/off fine from the insteon app …) Thanks

I tried on and off on a lamp (I like the idea of dimming in the future) but no luck. And yes I made sure of the hub forward for port 25105

Anything in your logs on the IDE?

maybe something like

java.net.ConnectException: Connection refused @ line 77

error java.lang.SecurityException: Endpoint http://xxxxx //3?026226B13D0F1900=I=3 is blacklisted. @ line 76
Any idea?

Is there by chance a space in your URL or you added http? For the URL you don’t need to put http as well, just the IP.

http://x.x.x.x(space)/?3…etc.

Also I just noticed I added an extra slash in the code. Go to line 76 and remove the extra / before the /3. That shouldn’t cause the problem though.

Still not working.
I erased the extra / and still no luck.
It is really http://email:pass@localIP:25105/3?026226B13D0F11FF=I=3 is blacklisted. @ line 76

Strange.

Never seen that message before. I’ll look into it. I’m not getting that.