Inovelli switch with bathroom fan


#1

Currently in the SmartThings Classic app, the switch is stuck “on” even though the physical switch is off and operates normal. I tried refreshing the app. Only way to fix it is to go out and flip the breaker off then on again. This has happened numerous times and seems to happen after I run my “good night” routine.

Other than this, the switch usually operates normally both physically and remotely.

This is the only switch in the house that has this problem and the only switch on a ventilation fan.

Anyone have any suggestions?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Contact Inovelli Support.

They are very helpful.


#3

I have been back and forth for awhile with them.

They are trying to figure it out.

I was just curious if anyone else was experiencing the same issue.


#4

As it turns out, the root cause of loosing control of the switch via the Classic app is this :

When there are a large number of switches being turned off by a routine including the switch with the fan, I loose control of that particular switch via the app. Physical control of the switch remains operational.

When I tested the same routine with only 2 switches including the fan, it works fine and I still have control through the app after the routine is carried out.

I’m assuming this is a glitch with the app. Maybe someone has an idea.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #5

How many is “a large number”? Have you tried using a Scene instead of a Routine?

There have been rumors that issuing too many Z-Wave commands on the network at once could cause a Z-Wave mesh glitch or whatnot; but if there error is occuring in the App it won’t be fixed. If it’s the SmartThings Cloud, then you can bring a reproducible case to SmartThings Support.

What do you see in Live Logging? https://account.SmartThings.com