Inovelli dual channel outlet issues

I started having a similar issue yesterday with all of my Inovelli 2 channel plugs. Yesterday, they all quit responding to my Amazon Echoes. When I opened the Alexa app and clicked on any of the switches, I got the message “Device is unresponsive”. When I opened the SmartThings apps, all of them had the red dot next to them and said “unavailable”. If I turn off the “device health” option, the dots go away and I can power them on and off within the SmartThings app, but I can’t control them with Alexa.

I have removed all of the plugs from SmartThings and done device exclusions on them within Z-Wave Utilities. I have then re-paired them with my SmartThings hub and they work properly again for an hour or so and then the issue returns. I’ve also rebooted the SmartThings hub and my router.

I’m hoping that Eric is right and that this is an issue on Samsung’s end and that it will be sorted out soon.

1 Like

Thanks. Could a platform outage affect a single device which is the case in my setup?

That’s my question as well. All of my other 25+ devices, including an Inovelli single plug dimmer outlet, are working just fine.

@fenerli and @darthclem – I honestly don’t know the answer to this question. Trust me when I say I completely understand the frustration this must be causing for you and I’m sincerely sorry. We haven’t received any similar complaints until two days ago when SmartThings went down and not everyone is experiencing this.

The only thing I can possibly think of for the explanation as to why only our plugs are effected is because we are using a custom handler (that we published via SmartThings).

What happens when you remove the device and then re-include it?

If you can hang with me through this outage, I would sincerely appreciate it. If it continues to give you issues, of course I’m happy to replace it! It’s just really hard to determine right now what’s causing the issues since myself, my engineers and the rest of my team are not experiencing this on their end, so it’s hard to replicate.

Obviously I want to help – I’m just not sure what to do until SmartThings fixes the issues.

I am having the same problem as of a few days ago: all 3 of my inovelli indoor outlets are showing status inactive, with the red dot. When I tried excluding and re-adding one, it is back online but the outlet on/off status isn’t being reflected back into the iPhone app even though the switch controls are working. None of my other devices attached to SmartThings are having any problems. Thanks in advance!

Hey everyone,

Ok, after talking to an ST engineer, we’ve found the issue and it explains why only Inovelli 2-Channel devices are affected.

Long story short, the calls to the child devices aren’t working properly.

In other words, the call to, “childDevice.sendEvent” is not returning anything and they have confirmed they are still having cloud issues (as you all know our custom handler operates in the cloud – vs locally – because it’s a custom handler)

For more info about the childDevice.sendEvent issues, please see here:

So, while I know this doesn’t help things work – it does explain why it’s not working (while your other non-multi-channel devices are).

Hang in there guys, we’ll all get through it together!

-Eric

5 Likes

So I’ve just jumped headfirst in to SmartThings with a bunch of new devices and a Hub. I went with Inovelli for my controlled outlets, and I’ve been trying to go the custom handler route to get 3 separate controls. I followed Eric’s instructions here: https://inovelli.com/nzw37-setup/smartthings/device-handler-installation/ and ended up with the exact same behavior - 1 master device with 2 sub devices. When I delete them in the IDE then use sprocket/save to re-add, they just come back as child devices. I also switched my custom handler setting to use “self-published” rather than published, but still, same behavior of 1 master with 2 child devices.

I had been using the “factory” provided handler, but I am having the same issue with that one as was described by some earlier posts, but I get the “device unresponsive” and the red dot so I figured I’d switch completely to the custom handler.

I will mention, the custom handler has done one thing better - in Alexa, the Ch1/Ch2 showed up as “My-custom-device-name (CH1)” rather than just “Inovelli… (CH1)”, so at least I can figure out which is which. This is with self-published custom code from erocm123.

I’ll also mention that the “status” of the Inovelli seems to get “stuck” in the app. That is, if I use the master to turn everything on, it sticks at “TURNINGON”, or to turn things off, it sticks at “TURNINGOFF”

Good afternoon @brillat,

Thanks a ton for your support - you certainly picked a great week to jump head first into SmartThings haha! I promise, it’s normally a fantastic HUB and everyone on our team uses ST in their personal home.

Alright, now to figure out what’s going on - if you don’t mind, I’d like to recap what you said, so I can make sure I understand.

  1. You installed the handler made by @erocm1231
  2. However, you still aren’t seeing the child handlers, even after you deleted them in IDE and then re-engaged them via ST (and selected the correct handler)

Is the above correct?

Now, as for the unresponsiveness and incorrect state, yes, this is unfortunately due to the problem in my comment above, “childDevice.sendEvent” not working right now due to cloud issues. We’ll have to stay tuned on this one as the engineers I’ve talked to said they are working around the clock to fix it.

I’m hoping we can at least figure out the top part while we wait for the second part to be fixed.

Thanks for your patience!

Yes, that’s all correct. Custom handlers via copy paste from GitHub, just like your instructions, and I still get the default behavior. I even unenrolled and re-enrolled the device, but it keeps reappearing with child devices.

Also an item that is probably related to the “unresponsive” problem, no history shows up for these devices in the app, that is, it doesn’t show anything at all on the “recently” tab.

Note that even though it shows up as “unresponsive” it still actually works.

Hey @brillat, try this link and see if it works. I had another user have the same issue as you and when he installed this one, it seemed to work.

If so, let me know and I’ll update the link in the NZW37 setup instructions.

https://raw.githubusercontent.com/erocm123/SmartThingsPublic/master/devicetypes/erocm123/inovelli-2-channel-smart-plug-alternate.src/inovelli-2-channel-smart-plug-alternate.groovy

As for the latter half of the message, yes, I think you’re right in that the two are related. If I had to take a guess (and I’m out of my league here when it comes to coding) I would say since the call to the endpoints is not working, that would explain why nothing is showing up.

However, I do find it interesting that you’re able to control via Alexa. I’ll pass that on to ST.

So, not only is this working now with all 3 “things” listed, but also, the “unavailable” problem has gone away as well, so good news all around!

The only thing I changed also was the NAME of both apps in the code. I wanted to be sure I knew exactly which version of both the parent and child controllers was being selected, so I stuck a date at the end of the name. Note that this also means I’m not overlapping with the SmartThings existing “factory” controller apps as well, so if this fixes it for anyone else than perhaps there’s some bug in having overlapping script names.

Awesome, that’s great news!

Let me pass this along to others that are affected and see if it helps them. Please keep me posted on the unavailable status. As you can imagine our Amazon page has taken a hit, so I’d like to stop the bleeding!

Anyway, thanks for posting and I’ll look forward to seeing if this works for others.

Eric

Mine 3 outdoor showed “offline”, but were working great.
Just now I changed the handler to “Inovelli 2-Channel Smart Plug (Alternate)” and status is changed to “online” and seems to work perfectly.

This is fantastic news – looks promising! Thanks for reporting in :slight_smile:

Hey all – I’ve written some basic instructions on how to install this handler while we wait for ST to fix a few things.

It would be super helpful if you could report back if this works!

https://inovelli.com/smartthings-device-handlers/#NZW37Alt

1 Like

Just popped in to investigate the same issue being reported here. Glad to see an active discussion going on, good stuff!

I don’t physically control my outlets at all, both my dual channels are operated by WebCoRE, which continues to operate them fine. I was just concerned by the behaviour in the ST app, so I’ll keep an eye here and read that link above.

Thanks!

Installed the Alternate device handler. The device in Smartthings app under My Home shows up with the parent and Channel 1 and Channel 2 as Child Devices under the parent. In the IDE the device handler shows the child devices as Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2). When I want to include the device in a SmartApp they show up as Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2). Alexa shows the parent as well as the child devices Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2).

Hope that is not too confusing but should the child devices in My Home also be Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2)?

Are you saying that you don’t see the parent (main) device along with the child channels in the “My Home” section of the app after installing the alternate handler?

If that’s the case, what worked for me was going into the IDE and clicking on the device. I then clicked on both child devices (one at a time) and deleted them. I then clicked “Edit” again, made sure the type was still set to the alternate DTH, and clicked update. This recreated the child devices and they appeared in the “My Home” section of the app after a refresh. Hope that helps!

I figured my explanation was a bit confusing. The parent does show up in ‘My Home’. The child devices are named Channel 1 and Channel 2 and are behind the parent. Everywhere else the child devices are named Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2).

I was hopeful on the alternate device handler, and while it is better (definitely have 3 devices shown), but the “unavailable” problem still happens SOMETIMES. For example, an hour ago, it was unavailable. But right now, everything looks totally fine. I’ll also note that the “turningon” and “turningoff” statuses stay around for quite a long time (minutes) after changing state.