Inovelli Dimmer Device Handler Preferences Do Not Work

smartlighting

(Jeff Lagana) #1

I have installed quite a few Inovelli NZW31 dimmers and configured the device handler using the code/instructions located here: https://inovelli.com/smartthings-device-handlers/#NZW31

All of the preferences that are enabled by the device handler do not work on any dimmer. I’ve tried the minimum level, dimming step size, led indicator, default levels, etc. They are all applied to each switch, but don’t actually do anything.

Has anybody run into this issue and have you been able to resolve it?


#2

Tagging @Eric_Inovelli


(INOVELLI.COM FOUNDER) #3

Hey @jeff.lagana,

Let me take a look into this and get back with you shortly. I know we were working with ST the other day around some new issues that arose from their latest update, but I’ll ask our VP of Tech and have him weigh in here.

Do you have all variables filled in? From what I recall from reading through the convo was that now all the fields need to be filled in otherwise the parameters will not stick (where they used to).

Even if you have to put a zero in any of the ones you aren’t using, try that.

Anyway, tagging @erocm1231 so he can help!

Hang in there, we’ll figure this out :slight_smile:


#4

What Eric described here worked for me and I just got done installed 10 Dimmers with scenes this weekend.


(Jeff Lagana) #5

Eric:

Do you have all variables filled in? From what I recall from reading through the convo was that now all the fields need to be filled in otherwise the parameters will not stick (where they used to).

Thank you, this fixed my issues!

Maybe I missed it, but to avoid this with others, perhaps you could include in the Device Handler comments that all variables need to be filled out in order for the preferences to take effect; or maybe just add that to your device handler instructions on the website. I’m not sure if it’s possible, but maybe you can set all of the preferences to predefined defaults or mark them as required if they need to be filled in for the others to work.

Thanks for a great product


(INOVELLI.COM FOUNDER) #6

Yeah, great point. We’re updating the site right now (going to be completely revamped) and we’ll add that comment.

It’s really strange bc it was a bug that just came up that I believe Eric was working on with ST, as we were testing a new handler and noticed that the parameters weren’t sticking.

Anyway, glad it’s solved and you’re enjoying it :slight_smile:

Have a great day!


(Eric M) #7

Hey Jeff, I spoke with some members of the SmartThings team at the end of last week. They had identified the issue and it seemed like it was something they were working to resolve (it was a cloud issue with some “caching that was recently added”).

Like Ron and Eric H mentioned, a workaround for the moment is to make sure that certain preferences are not left “blank”. I believe it is actually just the “drop down” type options (Invert Switch, LED Indicator, etc., but setting them all won’t hurt).


(Jeff Lagana) #8

Eric, thanks for responding. That’s exactly what I’m seeing, numerical variables don’t matter, but failure to set a drop-down causes all preferences not to apply. Thanks for the workaround!