Initial State Intergration Probelm - Authorization Error

Has anyone else had issues authorizing Initial State with Smart Things? I’ve been trying the past couple days to get things connected and I keep getting the following error. I’ve emailed support but haven’t heard anything back yet.

UK or USA?

It very likely will not work in UK.

US - My initial thought was it was it may be related to the OAuth problems the platform has been experiencing. I have other OAuth access tokens that are working find though.

At least one device had its box checked, right? (The screenshot is cutoff, but all the devices in view are unchecked)

Yes, there are several checked down lower… I’ve played around with the selected devices a bit, but always get the same error.

Do other SmartApps which use OAuth work? (eg. SharpTools for Android or SmartTiles for Web)

1 Like

Yes, no problems with the others… namely SmartTiles.

1 Like

Tagging the Initial State founder @jrbail01 for his thoughts…

I just went in and removed the installed Initial State app and deleted the associated data stream in Initial State. After that, I went back trough the integration process and it worked. Something must have gotten corrupted with the previous instance.


That’s not uncommon.

@Bryan_Fleming. You did exactly what we would have suggested to do. I am glad you got it working again.

1 Like

I’ve tried everything suggested to get this working!

I noticed a couple of comments about UK users in particular! Is it actually the case that UK users can’t integrate Smarthings with Initial State?

If it is do we know why and do if or indeed when we might get a fix?

For the avoidance of doubt I am a UK user…