Initial hub setup not working

Hi - just received my starter pack. (UK).

a) I have the hub connected to my router, batteries installed and power connected.
b) There is a green light on the router.
c) I have installed the SmartThings app on my Android phone, and have created an account.

However, setup fails when trying to set up the hub. I just get the message:

‘Please wait - Please do not unplug your hub during the setup process. This screen will confirm when your hub is ready and you are OK to proceed. Then tap ‘Next’.’

but the screen just shows a blue, spinning circle and doesn’t get any further.

I have sent an email to support, in the meantime does anyone else have any suggestions?

You’ve done everything correct, so at this point you’ll have to wait for support or try going into the IDE and see if any hubs got added to your account. You can then look at your hub’s event logs to see what is going on. The initial process may take a while. How long have you waited to let the process complete?

Waited 2 hours so far…and I’ve checked the IDE, no hubs added.

Wow, yeah 2 hours isn’t good. Obviously your network is working otherwise you wouldn’t be replying, so if you’re courageous, you could try pulling the batteries and unplugging your hub to see if that helps restart stuff (closing the app as well). I’ve not experienced your particular issue, so I can’t ensure you that will work or even brick your hub until support can reach out.

Is the online chat feature available via the app?

To access live chat within the mobile app:

  • Tap the menu in the upper right
  • Tap Support
  • Tap Chat With Support

Right now, is the hub’s light green or blinking purple?

Hub light is steady green. I don’t want to try powering the hub down or resetting it, because of the message in the app which says you shouldn’t do it, unless it’s authorized by support. I have also logged a second support request from my Android phone.

Here’s a discussion that may help if support hasn’t contacted you yet:

Thanks for the link. Looks like I’m not the only one with this problem…
I’m currently in email dialogue with UK support, no resolution yet, I’ll report back if/when it’s sorted…

1 Like

Support has confirmed that there are a batch of hubs that were sent out with a mis-match between hub and welcome codes on their database. As they can only be activated once, this means they are effectively ‘bricked’. New hub is on its way…

The hub is not bricked as far as i know, it can be reset at the server end and support will be able to send you a new code.
Whats probably happened, as happen to me is your default location has been set as as USA but you are based in the UK. The Hub has activated but its currently in limbo.
Support will need to move your account over to the UK servers. If that’s indeed whats happened. A friend of mine also changed his email account to an email address that ends with .email and Oh dear his account is locked out.

Same happened here. Support fixed my issue in under 10 minutes

Support tried to fix it at the weekend, and my hub vanished from the hub list at My Hubs, however, when I tried to activate it again, I got a message saying that the welcome code had already been used and the hub could not be activated.
Support have told me that they can’t fix it and that they will be sending me a new hub. Soon, I hope!

Have a look at it may be they have moved it across to the UK sever. Login with the same credentials you set your original account with.
The one time code is just that a one use. If you take a picture of the sticker on the bottom of the hub and send it to support they should be able to sort it. Unless the hub is actually faulty

@greenalien not to violate customer-agent confidentiality, but your problem was (probably) different and unique than some of the other issues on the forum (e.g., @ghesp’s) . I’ll follow up with you 1-1.

Replacement hub due tomorrow. Looking forward to trying it out, hope this one works!

1 Like