Important Changes to SmartThings Classic Login System


(jkp) #221

When you migrated, did you use the same password for both the old ST account and the new Samsung account? If yes, consider changing your Samsung password in the ST Classic app. Then login to IDE with the new password and see if it resolves the issue.


(Brad) #222

Are you using a password manager like LastPass, Dashlane, or 1Password? I will try to take better note so we can file a bug report but I do think I have seen that issue a few times.


(JIm) #223

No. I always enter my pw manually.


(David) #224

To be honest I don’t remember what it said.


#225

I was prompted to migrate to a Samsung account today and had a major fail (partly my fault, partly not).

I went through the process and started to create my new Samsung account but was told that I already had a Samsung account so I should just login. I did not know that I had a Samsung account and thought maybe I created one a long time ago for something else and requested a password reset. I got the email and reset my password and proceeded with the migration.

Afterwards, I logged into my Samsung account and found that the account associated with my email address was actually created by someone else (apparently using my email address) in a completely different country.

This is where I guess my mistakes started to happen:
I decided the best way to remedy the situation was to delete my Samsung account and then re-create it using the same email address but with the correct information (mine).

After doing this I have lost access to my hub and devices and cannot even login using my old Smartthings account on the IDE site. Please help! I’m hoping you can re-push the migration from my old account to my newly created account.

Again, I was not aware that the Samsung account associated with my email address was created by someone in a completely different country with different name and all so it’s partly not my fault.

Thanks in advance.


(jkp) #226

You should contact ST support at https://support.smartthings.com

1-800 SAMSUNG
(1-800-726-7864)


#227

Thanks, I did but they are closed for the day it appears.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #228

Please let us know what happens.

Wish you luck… :crossed_fingers:


(Paul) #229

It’s weird that someone else has an account using your email address - when I created my account last week I think I had to click an activation link in an email they sent. Maybe they added the email confirmation step recently?


(Hendre) #230

I got the update notice over the weekend and have been postponing the upgrade because it makes me very nervous to read all the horror stories on here.
So I eventually gave in a clicked on the dreaded button.
My fears were not unfounded. I received a “Something went wrong” notice after about 3 minutes.
I logged into my old Smartthings account and EVERYTHING is gone. Logged into the new Samsung account and there is only a Smart TV which I added some months ago in the new app.
I’ll contact support, but I am very worried at the moment.
EDIT: I panicked to soon. It looks like the migration completed successfully, despite the initial warning. After logging in again after about 15 minutes, it appeared that everything is as it should be. I now have 3 locations - the 2 I had in my Smartthings Account, plus a third location which appears to represent the single device (Samsung TV) I had previously add in the new Smartthings app when I purchased the TV.
This was a stressful experience. Good luck to those who still have to go through this.


(jkp) #231

Login to IDE at https://account.smartthings.com and look to see how many locations you have.


(Jimmy) #232

Yup. Multiple locations. Go to the menu and switch locations.


#233

Select the location which has all of your devices and there should be an option on the right of it to edit it and make it default.
Than select the new location and delete it.


(Jay) #234

I’ve had the same thoughts and then the same problem. my TV that I tried to add and couldn’t previously has just appeared as a new location with no hub… oh and my TV just switched itself on too which was not what I wanted at the time. I also can’t manage users, as my wife can’t get into the app and I can’t invite her as the function to add users has disappeared from the hub location but of course it’s there on the other location that has no Hub. what a shamble.


(William Mann) #235

Agree. Leave the new app alone. I mistakenly played with it, deleting the phantom locations (actually all locations)…not a good idea. Deleted hubs synced with classic app and everything was gone. Spent the last 2 days rebuilding my system from scratch. Overall working, but cannot add back my Samsung cameras and one GE switch.


#236

The Contacts can not be added at this time as Samsung SmartThings removed this feature.


(Hendre) #237

Same happened to me. What made this especially annoying for me, is that the TV is at my holiday home, 500 miles away. I only realised this after reading your post and checked the security cameras. Fortunately I could turn the TV off via the Harmony hub, as the TV is not shown as a device in ST anymore. The third location (without a hub and which initially contained the TV) was removed from my account, presumably by Support.


(Jeremy) #238

I seem to have two “HOME” locations now. Anyone else have this? Tried to delete the fake one in the classic app, but no dice.


#239

You have to log into the IDE, select the “correct” home location and make it default. Then you should be able to delete the fake location.


(Jeremy) #240

IDE shows correctly my HOME and other location. Smartthings classic app shows HOME, HOME, and other location.