Important Changes to SmartThings Classic Login System


(Joel W) #201

This is a real bummer! Samsung has really screwed the pooch!


#202

i had similar issue on an Android phone (it was opening unsupported Edge browser) and had to go to settings - Default apps and select Chrome as a default browser (had no browser selected there). After that it went through without a problem.


(Joel W) #203

I don’t think there is such a setting in the Fire HD settings. If I am wrong maybe someone will tell me where the setting is.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #204

It is impossible to install any recent version of the SmartThings App (neither Classic nor Samsung) on Fire OS, due to the inability to change the “default browser” on Fire OS and SmartThings App’s insistence that Silk is Incompatible for login.

SmartThings’s CTO is aware of this for over a year. No intention to fix it has been expressed.

Sure… It makes ActionTiles a little attractive; but we’d prefer that folks can flip into the SmartThings App whenever desired to perform the many critical functions outside the scope of ActionTiles.


(Joel W) #205

I always have ActionTiles open, but that doesn’t help us when we need to access out tools for Z-Wave repair or hub status. Shame that SmartThings knows this and doesn’t do anything about it.


(Joel W) #206

I noticed today all my WebCoRE pistons are no longer working. Will wait a few days on the chance it is a fluke.


#207

Hi @joelw135,
I am on th phone call with SmartThings support and they can’t make heads or tails of what is going on.

The guy put me on hold 3 time now.


(Joel W) #208

Hope you get it sorted out.


#209

That was a Painful phone call. He had me go through all of the steps which I went through, short of Excluding and than re-including the GoControler and even building a Test routine to fire of a Cree bulb when a button is pushed. He was nice and all, but I think that the fault is at the engeniering level. I was told that they will get back to me in a few days. LOL.

All of my GoControllers are down,
My WebCore is no longer functional,
My Routines are all in manual mode until this is fixed,
My Custom device handlers are missing in action,
My Notifications and text alerts are not working,
Heck, My Dome Siren will probably not go off if someone breaks into my house.

Thank you Samsung SmartThings for making my day! :face_with_symbols_over_mouth::sweat:


(Joel W) #210

My WebCoRe pistons have started to function, I am holding my breath. A few show they fired, but the corresponding push notifications didn’t happen. I am going to wait and see what happens.


(Greg) #211

Well I finally got the banner yesterday. I held my breath and made a samsung account today. Other than the app kicking me out multiple times during the process (basically anytime I clicked on a “?” to see what the opt in items were about) I believe it worked ok.

I’m logged in on the classic app and the IDE on my shiny new samsung account. I am still able to log into the IDE with my ST account as well :man_shrugging:

I was ready for this to be more painful - but so far so good.


(Dave N) #212

I just got the banner but I’m too chicken to migrate. Too many pistons and custom DTH’s.
It’s a long weekend here in Canada so I don’t want to ruin it :frowning:


(Jason) #213

You can, and should use the classic app after you migrate your account log in. The account/login migration is separate from the app migration.


#214

Update Gus and Girls!

As of 7:30 AM EDT I can confirm that all of my automation are working correctly.
In my educated opinion, this is due to the migration process taking a long time to complete.

You should defiantly stick with the Classic ST app since I couldn’t get much to work there and a lot of things were missing i.e., Scene(s) tab was not prescient and the few scenes present were not functional.

On the bright side, my Samsung Smart TV automatically tried and failed to join my newly migrated account. LOL! Tried is the operative word. :smile:

@vlad. This Migration is funny. Pass it onto the Level 3 engineering squad. They may not survive working in finance area with this type of performance migration. A tech on my team got canned for a FAIL like this one. Just saying. Think twice and Cut Once is how it should be done.

Wife Approval did not suffer much since she is now used to ST Failures…Every 6 month.


Please help: changed to Samsung account, now app doesn't work
(David) #215

So I got the banner and confirmed the new log in. Should I take the jump to the new app or wait?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #216

Wait.

The last message of the Account (login) migration process clearly says “Continue to use the Classic App”, doesn’t it???


(JIm) #217

I migrated my account a week or so ago. Now when I go to log into the IDE I have to do it twice. When I enter my username and password it takes me to another screen that says it is invalid. I then have to enter it again along with a security code. Then all is fine.
It does this every time. Kinda annoying to have to log in twice.

Should note that on the initial login it no longer gives me the option to select Smartthings or Samsung. It defaults to Samsung.


(Bob) #218

Seeing the same thing.
Put in username and password.
Go to another window that says username /password not recognised.
Hit back button on browser and I go back to the screen with my username and password filled in. Hit submit and I log in OK.
Very weird.


(jkp) #219

Try clearing any browser cookies you may have for that url


(JIm) #220

Didn’t work. I deleted all cookies that had either Samsung, Smartthings, or ide, etc. Still same login issue.