Important Changes to SmartThings Classic Login System

@xdreamwalker: Just tried to re-enable the contact book by IDE. But w/o luck. How did you do this? Just got a contact overview w/o any contacts in it, but no way to add any contacts on the IDE? Did I anything wrong?
I did it the same way, I did before with the old login.

I did it the same way. I was logged into the IDE using my Samsung account, swapped out “account/show” for “contact.” Now, what I can’t remember is what was there the first time I did it. Today it only shows my name and ID with the only option to delete it. Like you, I am not seeing an option to add any contacts.
My Contact Book in the classic app shows me with my email, uuid for push, and phone.

I wonder if Samsung has stopped people from adding new contacts to this finally. I originally was using it so that my partner wouldn’t get all of the push notifications that I wanted to get. Their account hasn’t been migrated yet so I’ve been sending sms via webcore to their phone. When their account gets migrated I wonder what I’ll be able to do…

So you don’t have any other users added to your account? Only your partner and yourself.
I don’t see my own address in the contracts in IDE. I can’t do anything if I adjust the URL. That’s strange. Did they stop now using the contracts?

There is a not zero chance that Samsung finally cut us all off from adding contacts to the unsupported contact book. In the SmartThings Classic app are you able to add a contact there?

Currently I wasn’t able to enable the contact book. I don’t see it in the Smarththings classic app.

If I go through all the steps to activate the contracts, changing the URL, it ends up seeing the contact site without any contacts. But there is no button to add or import contacts. And the contact book isn’t available in the app. Do I miss something?

What I noticed, under manage users I see my main email address two times as owner. Is that usual?

I too see my email address as owner. I think that is normal after the account migration.

You might just be out of luck with the contact book though. You could try asking in this thread to see if someone has more insight:

Do you see your name and address two times?

In the Classic app, ‘Manage Users’ I see myself twice as Owner, then my partner as a shared user.

ok, I see the same here. Will play around with the contacts, if I get it to work I will let you know.

I’ve just got a ‘we are updating our login systems, you must take action to keep your account active’ notification in my ST classic app - Does this mean I now have to make the transition to the new ST app? Or is this merely a login credential thing?

I’ve got to say I’m massively worried about making this transfer… I have 70+ devices that are all working ok now, but many use custom DTH’s, am I likely to have issues here? I would really appreciate hearing from anyone that has made the jump in a similar situation with a fairly established ST ecosystem…

FYI I have an existing Samsung account, but I’ve never started the ‘new’ ST app on my Galaxy S7 and inputted the credentials as I wanted to avoid the infamous ‘2 location’ scenario.

What’s the current advice on this notification for people like me? Do I ignore it? Or is now the time to face the music… :confused:

login credential only


Great - thanks for letting me know!

1 Like

Does anyone know how long we have to do it? I’m about to go on vacation next week and really not fond of making any changes. Also that it’s working well though, would probably prefer to hold out as long as possible.


So I updated my account to a Samsung account supposedly successfully, I then logged out of smartthings classic and tried to login with my Samsung password, but it did not work - only my old password allowed me back into the classic app and I’ve been greeted with the 'we are updating our login systems, you must take action to keep your account active’ again.

I knew this wasn’t going to be simple - any ideas what I should do? Will going through the process again mess everything up?

Call the support phone number and talk to their IT support directly.

1 Like

To update, it seems it just needs a bit of time to register, 20mins later everything worked as expected


The same thing happened to me. I was waiting for noon to call support and it started working just before they opened.

1 Like

I was prompted to do the upgrade (primary user) but the rest of my family haven’t received anything (3 other devices). So I proceeded with the upgrade and got the Samsung account and initially everything seemed to function normally. But the contacts featured disappeared and I was unable to get it back…had to redo my device handlers and smart apps to resolve notification issues. Also, I noticed two same email’s under my account on the SmartThings IDE? I removed the one that didn’t have any Hub’s associated under it…not sure what it was for??

I had the exact same issues. Support said the second owner was a carry over from the old login. It won’t effect anything whether it was there or not. I also had to redo automations to get notifications working again.

@oldcomputerwiz and @kamran were you able to re-enable the contacts book again? All seems to work fine for me after the login upgrade. I wasn’t able to get my contacts back :slightly_frowning_face: After the upgrade I also do have two owner and I’m not sure if I can delete one of them.