Ikea Tradfri Wireless control outlet kit and button now working with SmartThings (July 2019)

Sorry to bump an old thread but I’m looking for some help with this. I just picked up a 5 button remote and can’t seem to get either classic or new app to see it. I’ve tried holding down the pairing button for 10 seconds, I’ve tried pressing the button 4 times so the red light flashes while the apps are searching, I’ve tried the 4 click reset/battery out & back/4 clicks again but the apps constantly report they can’t see the button.

Am I missing something obvious here? I tried standing next to the hub as well but it made no difference.

Appreciate any pointers you can give me!

I had the same issue.
Your need to do the pairing with the Classic app first.
Then after it’s done adding all the buttons (it may take a few moments )
You can go back to the new app and do the automation assignments.

I can’t get the middle button to work at all though.

hey, thanks for the reply. I finally managed to get it to pair after about a hour of trying. I used the new app and just kept trying the 4-button press and then it suddenly saw it on about the 20th attempt. Once it paired I can see all the buttons and map automations to them. It gets really flaky if you create an automation then try and edit it with a different action - it just kept throwing a NETWORK ERROR message, but it seems if you totally delete the action and create a new one. Execution after a button press is a tiny bit sluggish, and doesn’t always work the first time, but overall it’s pretty good!

Has anyone gotten the 5 button or 2 button remotes to work on the ADT SmartThings hub?

I bought both along with the smart outlet but for some reason, I’m able to pair the remotes and see it in the new app but button presses doesn’t register.

I can assign functions to the device, smart lighting and custom automation but it’s not triggering when pressing the buttons.

I thought it was just a bad battery since it’s registering weird percentages instead of the usual 100% from a fresh battery.
So I bought new batteries and it’s still not registering the button presses.

The only activity I can see in the history is the original handshake from the pairing.

I plan to go back to IKEA this weekend and need to decide if want to exchange (if I have a DOA) or just return/refund if it’s incompatible with my hub.

TIA

I had this in active use without smartthings integration but then it died recently, apparently it was the battery. All pairing was lost and I thought to integrate it into my ST setup.

It paired easily and all the buttons showed up BUT, nothing happens when buttons are pressed or held, even though I have done all the “automations” and tried it with different lights and actions, toggle on/off etc.

Also, nothing shows up on the activity history except for the first few minutes. Kind of like this;

What can be wrong?

I’m struggling to pair my 5 button remote with smartthings. i’ve tried both apps but neither work. is there a step by step guide at all to the process. so far i’ve gone into the new app, clicked add, ikea, driver and then held the button down while it searches on the app… but to no avail!!

i can however pair this fine with the ikea hub for both buttons and bulbs that i have!

@mark_harding we just fixed an issue affecting device join in the EU region so if you live there that could have been the problem.

https://status.smartthings.com/incidents/t7q3zbcdsmwn

1 Like

HI, thanks for that, just tried it again and its found the button, i’m in the UK. when i try to set any routines up thou the app just crashes now. it’s late here thou so will have another play in the morning.

I believe that’s a known android issue.

That’s true but it will be fixed in the next release of the app

1 Like

so is there anyway of getting around it at the min?

or just sit back and wait, does it work on ios etc?

Works on iOS. I think it also works fine wir you use Smart Lighting under automations.

@BillNutz did you ever find a solution to the problem? It’s pretty much identical to mine.

Although I know mine is not DOA since I’ve been using it a while on its own. It might be incompatible but I don’t see a reason why.

ive paired the button ok and set up a routine in smartthings but using the IOS version on an iphone. however nothing happens when i press it… don’t think this was meant to be for me!!

Same here. I think it doesn’t matter if it’s iOS or Android. It just not sending anything to the SmartThings hub.

No, I haven’t gotten it to work.
I can pair it without issues but it’s not registering the button presses for both the 5 button and 2 button remotes. Went through several fresh batteries and still no go.

However, the smart outlet works perfectly… got it to work in first try.

I will hold on to these devices for now in hopes they work in future updates to SmartThings.

I have the same issue as well - 2-button remote pairs without any issues, but there are no events sent when I press the button.

I’m using SmartThings Link as a hub, and I wouldn’t be surprised if that was the reason I can’t get it to work.

Sometimes when I press any of the buttons I see one of these in the live logs view (but not in device event history view; maybe because they’re debug events?)
Parsing message from device: 'read attr - raw: 271F010001082100203C, dni: 271F, endpoint: 01, cluster: 0001, size: 08, attrId: 0021, encoding: 20, value: 3c'

or

Parsing message from device: 'read attr - raw: 271F010001082100204A, dni: 271F, endpoint: 01, cluster: 0001, size: 08, attrId: 0021, encoding: 20, value: 4a'

Also I have one event with value 1c and also one with a longer value 1d2000204a

Mine is a SmartThings Link as well, attached to a Nvidia Shield TV.
FWIW.

Hi, did you find any solution for 5 button remote? Mine is shown just battery too

Continuing the discussion from Ikea Tradfri Wireless control outlet kit and button now working with SmartThings (July 2019):

Which device handler are you using…?
I have ST hub version 2…

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.