Ikea Tradfri Button (square)

Same problem here.
All my IKEA buttons are blank. Will not update on IDE.

Namings are inconsistent between IDE (Classic) and the new app. That is a known bug.

@Benjamin_Ginders, there are more people with the buttons issue.

I find changes to device labels in the IDE are reflected immediately in the new app, though I have experience issues with Classic app to new app in the past. This is something different though.

If I edit a device in the IDE, change the device name, and update, the new device name should take effect in the IDE. I do it all the time as it is the easiest way of breaking the new app’s presentation cache.

This currently isn’t working for the buttons (I don’t have any other devices using the same device handler), but it does work for other devices. If I have the device name ‘IKEA Remote Control’ and edit it to e.g. ‘IKEA Tradfri Wireless Dimmer’, then update, I get a message saying the device has been updated, but the device name is still ‘IKEA Remote Control’.

So issues with the buttons are being seen in the IDE, Classic app, and new app.

I’m having the same issue (blank page) in the new Connect App for two IKEA Tradfri Remotes.
Seems like it’s a bug affecting multiple types of IKEA Zigbee Devices.The functionality it’s still there, I still receive an annoying notification that my battery is too low for one of them.

Thanks,
Vlad

Yep I still cannot see the details for the Ikea Tradfri devices…
I even tried:

  • removing the buttons/switches from
    SmartThings and adding them back in …

  • Copying the DTH with a new name

  • Changing the names of the devices

  • Changing/updating the child devices

I also cannot create new button actions for ikea Tradfri buttons/switches…

What is going on with the switch capabilities?
Is there something we need to update in the DTH?
Have the SmartThings staff made changes which has affected the compatibility?

These devices worked perfectly until the outage and it just seems strange how a load of users have got the ‘transfer to the new app’ banner today…

@Lars @jody.albritton @Brad_ST @SmartThings @nayelyz
Is there anything you can do to support with getting this issue fixed before our families rip our smart systems out for being stupid :smile:

The SmartThings team is aware of the issue. It is unrelated to the recent outage, the DTH, capabilities, or Classic app transition. It is also unlikely that it is related to the app update either. We believe it is due to a change in the plugin the new app uses to display the device.

The devices we’ve identified as being impacted thus far include the Ikea button remote, Aeon Minimote, and Aeotec NanoMote Quad. The commonality across these devices is that they are multi component remote controllers.

You mention switches being impacted. Are you using the term broadly to include the remote/button controllers or is there a specific on/off switch device also impacted?

2 Likes

Hi @Brad_ST,

Thanks for looking into this, and for the explanation.

The device affected for me is the 5 button steering wheel remote and the 2 button square remote which identifies as an on/off switch due to the ‘I’/‘O’ function/labelled buttons.

Please see the below images which show the devices I am referring to.

Thanks again,
Ben

1 Like

I have the Tràdfri white (square) switch. Classic app gives battery status in Right Now tab and switching events history under the Recently tab

New app shows only the device name and nothing else

I get the same blank screen in both Apps!!

I’m running 31.04 software on V3 hub. You?

SmartThings WiFi Hub, Firmware 000.029.00009

I’m running 31.04 on the V3 hub also.

Same for me,

Got the 5 button control (E1810) today and added it to the hub, blank screen on the latest smartthings app.

V2 UK Hub running 31.00004

1 Like

Why is SmartThings support not aware? I submitted a ticket through the app yesterday for my minimote and received the usual uninstall/reinstall instructions instead of them acknowledging it’s a known issue.

Although that seems more than reasonable, I note that I am also unable to change the device name of all my IKEA buttons in the IDE. They report the device has been updated but the name remains unchanged.

Other device types can be renamed just fine.

OK…I thought only I am having this issue till I read this. Yes, I am getting blank screen, it was working when I paired it about 4-5 days back. Now it is just a blank screen. Hope to get this fixed soon. Thank you.

My button is rapidly running out of battery. Anyone know if changing the battery result in having to set it up again or add it again as a new device and if so will I be able to configure it with the current problem?

Same here. Started a few days ago…

Hi @Brad_ST, has there been any progress on this?

When I create a dud device using the IDE with the IKEA Button DTH I can see all of the tiles within the device page but as soon as I try setting up an actual device via the app I just get the blank screen.

I understand this is a 3rd party device so not Samsungs issue but the main reason most people use SmartThings is for its ability to use sensors and remotes/buttons.

If there is anything I can do as a user please do let me know.

The IDE and Classic app don’t use the device plugin that the new app does. The appropriate team within ST is working to get their fix out to users. Unfortunately I don’t have insight into the timing of the release. Thank you for your patience and offer to assist where possible!