IKEA Styrbar 4 button remote

Hi Tim.

Probably not you. Fluke of the system. Remove and reinstall usually does it.

Hi,
Remove the DH or the thing (button) in the smartthingsapp.

Btw, do you know what the problem is of ikea buttons loosing connecties and drown battery?

Thanx in advance.

Hi, I have the same problem as Tim makes me configure button 1 (only pressed and held, double press doesn’t work) and always gives me the battery to zero (the batteries are new). I did as you advised I remove it and set it up again but it doesn’t work. What can I do? Thanks

Are we talking about the IKEA styrbar 4 buttons remote or something else?

That’s right Ikea Styrbar 4 buttons

I confirm that with the Ikea Styrbar button (4 buttons) the first one works well, very responsive. If I enter a command on the second button even if it seems that I have not saved it (nothing appears) in reality if at the second button (the one at the bottom) it works. I can’t get the two arrow buttons to work. For the sake of completeness I tell you that I tried to restart the hub and I have more removed and reassociated the Styrbar. Do you have any advice for me? Thanks

I added the remote to my setup, using add device, selected an ikea button device. My device was found, the four child buttons were created. Each button had press, double press and long press. I programmed each press with an action and all worked as planned.
Best friend in this case, is to look at the logs on graph.api.smartthings.com, for that specific device. It will look something like this:

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:14 AM: info Button 4 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:14 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0005 01 01 0000 00 A3DB 01 01 117C 07 00 00010D00

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:13 AM: info Button 3 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:13 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0005 01 01 0000 00 A3DB 01 01 117C 07 00 01010D00

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:11 AM: info Button 2 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:11 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0006 01 01 0000 00 A3DB 01 00 0000 00 00

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:10 AM: info Button 1 pushed

1a974d1d-1c59-49b0-bf11-a45de94fc746 10:46:10 AM: debug IKEA Styrbar remote parsing: catchall: 0104 0006 01 01 0000 00 A3DB 01 00 0000 01 00

If you go on the same interface, and click on your device under “My devices”, it should show four child devices like this:


If that is not the case, I would delete the device. It is the simplest way.

Sleepy end devices like buttons only wake up to send events/statuses like battery level or button presses so unless they are configured to communicate very frequently, they should last a long time. But anytime the zigbee network is reconfigured, it tends to be super expensive in battery lives.
You can check in the logs to see how often the device sends events, if configured to log.
Also check the next hop and ensure it is stable on the network.

In the meantime, thank you for your prompt reply! I have already eliminated the Ikea pilsante several times but the result is always the same. I have verified that as in the image you sent me it created 4 child buttons, but the behavior is different. Button no. 1 in the head I can save an event, if I try to save it on n. 2 (which appears to be the one below) does not save the event even if it then executes it. So even if it didn’t save the routine if I press button two it executes it. Only buttons 1 and 2 work even if button 2 does not save the routine. I hope these pointers remind you of how to get me to fix the problem. Can it make sense to clear the DH and re-enter it? Thanks for your time.

I add that if I go to the “List Events” I see that it registers the pressure of each button so I imagine that the problem lies in the fact that it is not possible to save the routines to be executed. Do you think I can insert the routines from the IDE? Thanks

An update, I deleted absolutely everything: Ikea’s Device Handlers and Styrbar Button. Then I loaded the DH again and reconfigured the Styrbar. Unfortunately the result has not changed

I am getting the same results as you now in regards to linking actions to buttons. I’ll have to investigate further but it looked like the issue is maybe with the application. Not sure. This is my first device handler

OK thank you! I stay tuned for any updates that you can do !!!

Here’s something funny: what I set for action doesn’t show up in the app but is still active.

that’s right, it has the same behavior as me. Is the battery at zero?

No, I’m at 50%. Rechargeable batteries run at lower voltages, and that is basically how devices report the battery level, just based on voltages. Maybe that’s the case for you ?

Do you have any IKEA Outlets around that the button could be routing through? They have been known to eat battery configuration commands. Power cycling the outlet and pairing the button again can help.

I have similar “problem” with older Trådfri buttons. I’m just waiting for Edge drivers to take over and solve these problems.

In my case I’m using Ikea batteries but not rechargeable

I tried to look for the old Ikea button (the one with five keys) but apparently it is no longer in production, they don’t sell it online and in the store closest to where I live it is no longer for sale