Ikea 5 button remote killing batteries

No I don’t.

OK, Have you updated their firmware in the last 2 months? Ever? How old are they?
We can figure out what firmware they likely have based on that…

In theory the Zigbee “3.0” firmware that is available for these buttons now should solve this problem, but that has not been the user experience. But clearly the new Driver is polling these things way less… I wonder if the new driver coupled with the most current firmware could finally get these working again… .

I looked in the CLI and it does not list the firmware. And the IDE does not provide any info. for Edge devises.
I purchased the button with a plug on Oct. 1, 2021, and I have not knowingly done any firmware updates.
It sat for about 2 months with not batteries after it burned through 2 set of batteries in the first few days. In early Dec. I put in new batteries and paired with with an Edge Driver, and have been using it since.

I still havn’t gotten around to buy new batteries but hopefully today. Have also located my never used Trådfri hub to try and check firmware version and update if needed. As I mentioned, I have two versions (at least by looking at the back plate) of this button. The one on the right (oldest one) marked 19972 have never been a problem. The ones marked 21633 ar all having the battery issue.

In the IDE the older one report this under the firmware section

  • Current Version: 0x14018610
  • Target Version: 0x14018610

The last report on one of the battery draining buttons (not operating but still listed in the IDE):

  • Current Version: 0x22010631
  • Target Version: 0x22010631
  • Last Checked: 2021-09-11 9:44 AM CEST

The current version for the buttons is 2.3.079, which dates from 27th October 2021.

I think 2.2.010 was the release before that, and that dates from 10th September 2020.

1 Like

I can report the same experience. I have 3 of these same IKEA buttons. The two I have that labeled 19972 work just fine. No battery drain issues. The one I have labeled 21633 does have the battery drain issue.

Same issue here, but with the IKEA on/off button, it suddenly just started draining my batteries like crazy. I haven’t done any updates or changed anything in webCore. Tried adding it again with the SmartThings wizard, but it already stopped working after less than a week and the app says 16% battery, not reacting to my presses at all. I am using IKEA batteries, I read that they sometimes come with 2.7 V instead of the 3.2 V. I’m going to try another battery. Also read that some were having this issue because of a bad contact with the metal plates, and solved it by putting in some cardboard. Others also wrote that they got the issue solved by simply getting a new button.

Kinda forgot about this thread but giving a quick update on my above post:

After I managed to force my ikea devices into a different zigbee route, the battery drain problem never appeared again on ANY of the affected devices.

I have one like @Paul_Oliver showed the image, with 2 button and just changed the battery.
Tried with dth and battery was 100%.
Now changed to Edge driver and first read 30%. Now, about 45 minutes later, it shows 37%…
Let’s wait and see…

So, started my TRÅDFRI hub and connected one of the buttons. Waited for the update from 2.2.010 to 2.3.079 to finish. Removed and reset from the TRÅDFRI hub. Measured the voltage to 2.96 with a cheap multimeter. Installed in Smartthings using the Edge-driver. First it reported 0% but now it reports 37% battery just as andre_petinga says. So something is off on the Edge driver reporting. But I don’t care as long as the battery last for more than a couple of days. Lets see

1 Like

It seems to be happening with all the IKEA devices. I vaguely remember looking into it and concluding that IKEA are returning values based in multiple of a whole unit when it should be half units.

I upgraded the button firmware quite a while back and also installed the Edge driver when it appeared. It doesn’t help.

1/15/2022: The last battery (Panasonic) in my Ikea 2 Button Remote (Tradfri Type E1743, Code 19972) only lasted 4 days using an Edge Driver.
The battery stated out at around 3.25 V and was at 2.47 V when it stopped working. The battery level indicator read 44% the entire time.

UPDATE 1/17/2022: Another new battery died in 2 days. Voltage on removal was 2.29 V. The button has been put in the junk drawer until a solution is found.

Well. Despite the new firmware, no difference. This morning button was dead, last report was 6% and battery measured to 2.42v.

This is totally ridiculous

If there was another button option easily available with the same price / look /features as the IKEA buttons I would have binned these by now. But I haven’t found a descent option. Any ideas?

And by the way Samsung (aotec), what is the meaning of this list? Green=certified? Is 12 hrs battery life a part of this certification?

1 Like

My button still shows 37% in the app…
When I press the buttons, nothing happens!!!
Going to the IDE, it shows as ONLINE.
I don’t understand…
Just oppened the case and pressed the pair button and… No red light (pair mode). So battery is dead.
IDE says:
Last Activity At - 2022-01-15 7:31 AM WET

So yeah, 1 day looking at this Last actitivy log

I’m giving it one last shot. Now that the button has the latest FW I uninstalled the edge driver and try out the DTH again. Battery report works correctly, 100% on a new battery. Let’s see where this goes.

Tomorrow I will check the other two buttons against the TRÅDFRI hub to see which FW they have but I don’t think any of my three newer buttons have had the latest FW

1 Like

Concluding monitoring of the Edge drivers - whilst initial battery level readings showed some promise, the battery was soon depleted in 22 days from 2.627 volts - 1.718 volt (using 2x AA IKEA rechargeable 2450 maAh).

Not idea, but least I know I have to recharge the batteries every ~20 days…

Side note: Edge button driver showed as 8% battery the entire time (even when it was dead).

I can report that the new firmware on my blinds is no better than the old firmware on the binds… One is already reporting low bat after only 3 weeks… they are supposed to last 6 months.

what is the fw version you have?

Was really hoping it was version related, but I have various all on different versions, all with battery drain problems. IKEA buttons a few alternatives exist (definitely not on price in AUS at least), but I couldn’t really find ST compatible physical dimmers.

So reaching my limit of going through batteries…and not wanting to stop using my dimmer…I just hardwired it…:pensive:

Well it was fun for a few days. Battery kept 100%, I checked the IDE once a day and saw that the button was connected directly to the hub. Then yesterday I checked the app, battery level 16% (button still working) and the IDE showed that the button has updated and now routed through my TRÅDFRI LED driver. This morning the button was totally dead.

Now I will waste another battery, add and keep the button near the router and see if that keeps it from meshing and then also keep it from draining. As mentioned in other comments the problem really seems to be related to the meshing. If only there was a way to prevent it from doing that. I would really like to force it to not mesh.