Ikea 5 button remote killing batteries

I’ve other zigbee devices that are not affected (aqara cube and motion sensor), only the IKEA 2 buttons are draining battery / unpairing, reason why I speculate it could be the handler.

It’s definitely an ikea-specific issue, and it’s being reported as a problem with other hubs, not just SmartThings. And SmartThings hubs with older firmware but the same DTH are not having the problem.

So it’s not just zigbee, it’s the way Ikea has implemented zigbee for those specific devices. :disappointed_relieved:

It’s not the first time Ikea has had this kind of standards issue, they pretty clearly test their devices with their own hub but no one else’s.

2 Likes

No repeaters as such but lots of Hue bulbs through Hue bridge, very little except sensors, some sockets and Ikea directly through ST. I have the drain issue with blinds, 2/5 button and Symfonisk remotes…

Maybe of interest; I got some USB 5v to 3v cables and, with the use of some rubber disks for dummy cr2032’s, have rigged a temporary USB powered solution for a couple of the 5 button remotes. Seems to work OK but nowhere near ideal;

The ones from IKEA that came with the blinds… But as other have posted, the buttons will hop from any powered Zigbee device and will be dead in a few days. This includes bulbs, plugs, etc.

I’m pretty sure we have figured out the problem… Now we just need IKEA to fix it.

Zigbee bulbs are “powered” devices and can act as repeaters.

The hue bridge forms its own mini network. Bulbs connected through the hue bridge will only act as repeaters for other devices connected to that hue bridge. Not for other zigbee devices connected directly to the smartthings hub.

See the community FAQ:

FAQ: Are Smart Bulbs Repeaters? (Updated 2019: the new answer is yes, but may be inconsistent)

4 Likes

You can add me to the list of people who have given up on the IKEA buttons. As they are they are “broken” in their current firmware state. I have ordered a few Aqara buttons and an Aqara cube to replace all of my Ikea buttons.

Next time Blind #7 dies (in 3 weeks) I will completely reset the blind and see if it fixes its battery issue, the other 6 blinds are working normally with no other Zigbee devices in my house.

One last thought… on the FAQ page [2021] Battery Power Switches and Buttons - #11 by JDRoberts

The FAQ is still posting these buttons as “compatible” with smart things. While that is technically true, we should make it clear to potential customers that they only really work with the IKEA hub and even then they can not be used to run scripts or drive other automations. If you dig into the “detailed” FAQ pages on the IKEA battery buttons you will find the bad news about the batteries… But it probably worth while updating the main FAQ page to warn potential customers.

2 Likes

Aqara buttons will probably have it’s own set of issues since they don’t use standard zigbee profiles…

Done, thanks for the suggestion. :sunglasses:

1 Like

Yes I know… out of the frying pan into the fire!
I will probably leave my blinds on Smartthings and run the aqara buttons off of my HUSBZB dongle on Home Assistant.

  1. My Ikea 5 button remote has been working since mid Feb, still reporting 74% (havent been game to disturb it by measuring actual battery).
    During this time I changed 2.4g channel to #1.
    Just removed the 2 Ikea repeaters, so thought it was time to test the Ikea 2 button rocker. Set up 2 using Scan Nearby, neither reported battery state in And. App or IDE. Set the third up using IKEA Button and it did report battery in both App and IDE. The only difference I could find in the IDE is that the first two not show Battery, everything else was same.
    Now - the first 2 lasted 3 days and the 3rd lasted 6 days !
    PS when I added one of the first 2 again, this time using IKEA Button method and it still did not report battery. Something very strange as all report the same firmware revision!?!?
    Ah-well back into the cupboard with all the others.

Ya same here, I removed all of my repeaters which means the buttons at the front of the house work… but barely and they would take a few pushes for the Smartthings hub to see them… It died after 5 days. It is clear that the repeaters are at play (since they die within 48 hours if paired to a repeater) But they are still dying without repeaters. But the buttons in the room with the hub last about 6 months. Still less than advertised but that is acceptable (ish)

Again, guessing here, but maybe they are trying to phone home with a status update (hi I was pushed up) and they need a response from the hub or repeater, (in IT lingo we call this a “handshake”). No response and they call again and again and again.

They are all in my junk drawer now.

So far the most viable theory floating around (but not fully confirmed yet) based on reports from multiple platforms is that for some reason these devices are responding with a long poll rather than a short poll. That would use up battery much more quickly.

The data for this is that there doesn’t seem to be more messages being sent, which is what would happen in the scenario you described. But longer messages could have the same affect.

Whatever it is, it’s weird. :thinking:

1 Like

You are lucky! All my 3 that died within 6 days is in the same room as the ST hub!

1 Like

I wanted to give short update on my findings with the ikea on/off buttons. I have 4 in my home and I have had the same problem with the battery drain, within 48 hours any new battery would be fully drained. So after having wasted like 8 batteries I gave up. A week ago I had to install a new IKEA light bulb and I couldn’t get my smartthings hub to link the new bulb. So I read somewhere that the hub being to close to a wifi router could cause this. I moved the hub to a different room in my home away from the router and voila, the hub saw the light bulb straight away.

Out of curiousity I then added a new battery to one of my on/off buttons and paired it again. This on/off button is now online for 72 hours and still reporting 100% battery. I have now added the other 3 buttons again and will keep monitoring them. So far so good, cross my fingers!

1 Like

They do, but when they stick, they do run for years without any issue.

There is another rumor that this only is an issue on V2 hubs… Do you know if this problem exists with V3 hubs too?

1 Like

Out of curiosity, what ZigBee channel are people on?

I use 18 and 19.

I use 11 zigbee and 11 WiFi. These two are about as far apart as you can get. :sunglasses:

https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html