IFTTT (and other External Services) Authorization Issues

There’s a known issue affecting multiple 3rd-Party services (including SmartTiles installs). Hopefully details will be posted soon here and on http://status.SmartThings.com

I believe this is also affecting SmartRules installations (per @obycode).

Appreciate updates when available, @slagle, thanks.

Yes, it’s affecting SmartRules too.

Seems like they would at least update that page to show a problem…

1 Like

Ya think? :confounded:

It’s a shame that webpage isn’t updated consistently. I think they have some internal criteria to decide what makes an issue of sufficiently high impact to cross a threshold or fit into one of the categories or whatever … but this is a “reverse cry-wolf” scenario. If the page is seldom updated, then Customers can only assume that a malfunctioning platform is considered “normal”.

Identified - Some users’ Routines are not working as expected. SmartThings is working to resolve the issue and will update accordingly.
Jan 12, 19:55 EST

1 Like

Finally updated. 8+ hours later.

1 Like

Unfortunately the incident described doesn’t match all the problem(s) we are experiencing… but, it’s a start… a late start, but … a start.

1 Like

That was my reaction when I got the e-mail.

Finally!! … Wait, that’s not my problem…

Oh well, I guess authorization issues aren’t technically a problem with the “platform”… :confused:

Actually, they are

SmartThings is not just a hub, set of devices, mobile app… it is a platform that runs all of that as well as 3rd-Party / Community Developed applications and device integrations.

When those integrations are broken due to a bug or unannounced change, it is a failure of “the Platform”.

And the Status website is an opportunity to avoid spawning dozen Topics and who knows how many Tech Support tickets…

1 Like

Also being tracked in the Known
Issues section of the community-created wiki:

http://thingsthataresmart.wiki/index.php?title=Bug:External_Integrations_fail(Echo,_Harmony,_IFTTT,_SmartTiles)

We’re dealing with two issues here.

  1. Routines were not working yesterday. That’s what caused the incident to post on status.smartthings.com. As of a few minutes ago, the known issue on status.smartthings.com has revered back to “All Systems Operational” and Routines seem to be working properly now.

  2. Third party integrations are still not working. This means IFTTT, Smart Rules, etc. They simply cannot connect. This issue has not been resolved despite the fact that the status.smartthings.com page shows “All Systems Operational” and no mention of this problem has ever appeared on that page.

1 Like

IFTTT still isn’t letting me connect. Is it working for others?

Not sure. Echo is working half the time. This morning I said “Alexa turn on office lights” she said ok and nothing happened. So I used the app to turn the one on over my desk. About 8 minutes later the rest just turned on. So there are still problems.

Not for me either. Can’t connect with IFTTT. Can’t connect with Smart Rules. Can’t add Rules Engine app.

Haven’t been able to connect to ifttt channel for 2 days. Still can’t :frowning:

Interesting, so while it says that it’s not connected, I created a new recipe and it seems to have worked… But my old ones don’t and when I try to reconnect with SmartThings in IFTTT it errors out:

So are most people’s IFTTT problems recent (EDIT: doh, just noticed this was from 1/16 and not 1/17!)? I’m a ST newbie (since Christmas). About 3 weeks ago I connected it to an IFTTT account. I was able to connect (still actually shows I’m connected!), choose my hub, and authorize my devices. However when I try to create an Applet in IFTTT with Smartthings, none of my devices show. Not sure if that’s due to this recent bug or something else…

Newbie here also. I tried to connect with IFTTT and it gives me an error. Anyone know what is going on?

There’s a new error that just appeared a few days ago. :disappointed_relieved: Report your problem to support, they are still investigating.

https://support.smartthings.com/hc/en-us

Here’s the current active discussion on that problem:

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.