IDE Simulator Works with device; App does not


(Jed) #1

I created a device with two relays on it. When I send the status from the device, the IDE simulator shows the correct values (that is, I have it hooked to the actual device, not a virtual one).

But once I am using it outside the IDE, with the SmartThings android app, the two relays are both updated with whatever string I sent, when that string is specific to a single relay.

Crazier Still; If I have the IDE and the app open and connected, the IDE updates correctly, but the app does not.

I have tried exiting the app, logging in again, etc. Still inconsistent.

Any ideas?


(Brian Steere) #2

Did you try clearing the Android application’s cache? I’ve found that will sometimes force it back into a proper state of things. Though I would think logging in again would work.


(Jed) #3

Well, the app updates when I change tile properties (I modified an 8-channel version of the code) , and it’s updating the tile States… Just incorrectly. So I don’t think it’s a cache issue. But I’ll try.


(Jed) #4

Just tried the cache clear, and it did not help.

I also verified looking at the messages received in the IDE tool and watching both the app and the IDE update at the same time. The IDE correctly updates the tiles, but the Mobile app tiles act as if both tiles are being updated to the same value.

That is…

If I perform an action and the device sends the “relay1on” string back, the IDE only updates the relay1 tile.

The mobile app is updating both the relay1 and relay2 tiles.

I adapted this from the 8-way-relay board code, only commenting out relays 3-8. However, when I first set it up, I had not removed that code, and when I tried out the mobile app things were wonky, and appear to have been consistent with this.

Anyone have any ideas?