I need a suggestion

Today, my colleague suggest me to upgrade the ST app on my Galaxy A10.
It looks different with the ST app on the iPhone X.
After I upgrade the app to the last version:,the ST hub is always in offline status–althought I get the notification that the sub is connnected in the notification bar.
I have to uninstall the App, and install the version:, it’s same with the the iPhone X.
Now the ST hub is showed as online status. but I can not find the edgedrver info in the hub window. I reinstalled all the drivers, but I still can’t see the installation information in the Hub.
I suspect that the driver is installed on the wrong Hub (we have two ST Hubs), but when I confirm the Hub ID, I find that the Hub ID is not in the previous format:

They are different from the previous Hub ID format.
I tried to install my edgedriver with this Hub ID. Unfortunately, the CLI reported an error(it is forbidden!).
My experience shows that the APP version, edgedrriver version and ST Hub firmware version have matching problems.
Please tell me a stable matching version combination to reduce these problems.
I need a suggestion,thanks!

On an Android phone, the installed drivers tab is located on the 3-dot menu on the tab for managing your hub(s). Here is what it looks like:

That format is referred to as the eui or hubEui in the REST API, and also appears as the zigbeeEui, but was known as the ‘Hub ID’ in the IDE and it is still usually what ST staff are expecting if they ask for a hub’s ID.

Not so much was made of the UUID form of ID for things in the IDE, it mainly featuring in the URL (so open an individual hub page and look in the address bar), but it is to the fore in the REST API. For hubs it is the deviceId, id, or hubId depending on the context.

The serialNumber is also available.

Where did you get that apk from, the one on apkmirror is not real it’s a smartthings framework apk. Latest release is

@orangebucket is correct, one is the Hub EUI and the other one is the device ID of the Hub which is the one that identifies it among other devices in your account.
You can omit the parameter of the Hub ID, the CLI will ask you to select a Hub. If it doesn’t, you might have accidentally fixed the selection to a specific Hub, to clear this, you can use the command smartthings config:reset.

Version “” is on your iOS device, right?

Must be android. Latest iOS is

Mmm this is strange, I haven’t heard of a new app update for Android, only iOS. I tried reinstalling the app and I still get the 91 version.

You are correct. There is a bogus apk on apkmirror which maybe OP got hold of.

Thanks a lot!
In the fitst screenshot of yours, I can not find the tab “Driver” in the popup menu.
It’s only appear when I uninstall all drivers before, but now it is not displayed, even if I have installed all the drivers.

I remember that @nayelyz told me a long time ago that it was really rare to set and modify the Hub ID. I forgot it.

Because of my account, I can’t install the ST app directly through Google Play.
I tried to install apps directly through the Galaxy Store, but I gave up because the download speed was too slow.
Here is the url I download the ST app:

Your help always gives me great inspiration!
The ST App version is on iOS device, The ST App with version come from our iOS App Development Engineer,
I thought he gave me the same version he used.