I can't add lyric round thermostat 2nd generation with ST


(KC ) #1

I purchased homekit enabled lyric round thermostat 2nd generation with ST. They said thermostat should work with ST. Lyric app works fine with thermostat and i used same credential on lyric app and works fine. However anytime i add this thermostat to ST, i can enter same credential email address and password then second page where information allowed then immediately connection could not be established error message. It is very instant where it did not even tried connecting. I contacted tech support from ST. They suggested that i should create new credential and retried. I have created new credential and tried. Exact same result. From this forum someone mentioned that making sure no space after email address and i have checked that also exact same result. I have ran out of options to try and i am to the point where no solution approach. Can someone help with this issue?


(Alexander Ng) #2

I was the one who posted the space issue. Make sure there isn’t a space at the end of your email and password. You’ll see your cursor blinking on either the email or password I can’t remember and you’ll see that extra space, just backspace to get rid of the extra space and hit ok


(KC ) #3

I appreciate the reply and i tried your suggestion this morning again and again. Both occasions, connection can not be established error right away after 2nd page with consent. Like i mentioned in original post error message comes up so fast like app did not even tried connection. Tech support from ST wants me to call them and try while they are on the phone so that they can see if problem is happening with ST side or Honeywell side. I am not sure what they can do at that point. I might give them a call.


(Alexander Ng) #4

I called Honeywell and the tech there told me about the space issue. Are you getting “authentication failed” message? What message are you getting?


(KC ) #5

I think my situation is different than yours. I appreciate your help though.


(Alexander Ng) #6

This is different. What does your screen look like when you try to pair to ST with your userid and password, don’t show your userid and password on a screen print and how are you getting to that screen through Marketplace or Add a Thing?


(KC ) #7

That is the thing. There was no pair option. I set my thermostat with lyric app and in ST “add a thing” then thermostat then lyric round thermostat then it ask input credential for Honeywell.



After this process immediately i get error message that I shared with you in earlier post. It is instant.


(Alexander Ng) #8

You are doing everything correctly! It’s like it not going through at all. Call Honeywell Lyric tech support,
Lyric Customer Support 1-800-633-3991 they are very good. I called them several times and they are very helpful. They might have you remove the device and readd it. I’ve had it installed about over a month now, no problems. I got my Lyric Round 2nd gen installed for $50 from my utility company National Grid. BTW you have the Lyric connected through the C wire and not running on the battery?


(KC ) #9

update
I used live chat option with ST. After long conversation over the chat I found out that ST is pulling account information from https://www.mytotalconnectcomfort.com/portal
To match credential in ST.
While adding myself in this website i came to find out my thermostat was already registered with another account previously.
In order to register, this thermostat must deregister from previous registered account first. I have no idea what that account was. I purchased this thermostat from Amazon. This amazon seller advertised this as new but I found out otherwise. I am returning this thermostat and ordered another one from different vendor. I hope I get truely new product this time.

Once I receive, i will update the progress.

Yes, I have connected c-wire.


(Alexander Ng) #10

I wouldn’t have thought of that being registered already from another user. Glad that now you know what caused it. Now when you pair the new device when you get it you’ll see the space now and won’t have to swear at it again, lol


(KC ) #11

Update

I got my new lyric round thermostat and tried installation and failed again. I got same message " registration has failed the device has been registered under different account…" I could not believe 3 thermostats i have tried all failed.
In the next morning, I finally called Lyric support over the phone and explained the problem and technician said that lyric round thermostat does not work with totalcomofort .com. i was told differently from technician from ST. He also asked me mac id and mac crc from back of my new unit and he would escalate to engineering to resolve the issue. And he asked me to take screenshots of how I integrate in the ST app. I emailed the pictures and same night , wala! Successful. Yay! Finally. I hope this helps someone with similar situation…


(KC ) #12

After working with tech support from honeywell everything is working fine. Thank you very much.


(Alexander Ng) #13

Very good! Honeywell has been trying to improve the unit and the app’s response time. I’ve received 2 emails from Honeywell in the past several weeks informing me of the improvements. Honeywell didn’t say exactly what the updates were but mentions just better response time