I Can No Longer Open And Reconfigure My Custom SmartApp

My custom SmartApp has worked fine for a couple years. Since the latest update I can no longer open the configuration settings and modify them from the menu in the app. I know I did this as recently as a week ago, just before the Aug 08 update.

It should not be reliant on groovy bits in any form. I’m just trying to understand how to troubleshoot at this point.

I can…

  • Install a new instance of my app and configure it as I always had before, but once i save, i cannot re-open it
  • Go to the new Advanced Web App and view all the existing settings for the existing apps
  • See all the existing apps I’ve installed in the list in the ST android app
  • Developer tools and all that are on and enabled in my ST android app
  • When I delete a newly created webapp as a test i see the lifecycle event to remove it

I cannot…

  • See any error in the app when i try to open or click on an app
  • See any error or diagnostic logs in the workspace console log
  • See any logs that I used to receive in my node web interface around lifecycle events

I didn’t see any notes around things changing here. It will be pretty disappointing if we can no longer configure these apps in SmartThings?

Additionally I can edit the app in the new ‘Advanced Web App’ just like I used to be able to in the ST app itself so it would seem that my config is not completely broken =(

I noticed late last night that nothing happened when I tapped on my installed app and I didn’t have a chance to investigate the issue further. Sounds like I probably won’t find out anything useful if I do. I did just try creating a new instance and as you say that part is working.

So that is a ‘me too’.

1 Like

Hi @lanfear let me check it with the team :saluting_face:

Is your device and android? and if it is true Can share with me the version of SmartThings?

Happy to help, thanks for looking into it. Here are screenshots of my environment. Let me know if this is not the version info you need. And yes, Android as mentioned above.


Thanks for the information I will inform the team :saluting_face:

@lanfear we will need more information to investigate

first, can you enable support access?

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM.
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

please replicated the issue, and share with us the next information

  • time/date when it happened as your timezone
  • the name of your SmartApp

Thanks for taking a look.

I enabled data access and replicated the issue at approximately 9:01pm EST by navigating to the list of smart apps and clicking on the first 3 apps each of which is an instance of the app I maintain. In each case ‘nothing’ happened.

From there I did nothing else to minimize other noise.

If you want an extra data point, I tried to open ‘Anidea Bucket’ at 7:55am BST (that’s 06:55Z).

1 Like

@lanfear thanks for the information, unfortunately, we check the email address that you have linked with Community and we don’t have access support, Are you using another email address for SmartThings?

also please Can share with me the names of the SmartApp that are you clicking?

@orangebucket Thanks for the information :raised_hands:

Wow, didn’t realize my linked account email was so stale. It’s updated now, so maybe it will sync up? Otherwise some sort of DM if possible I can get you the proper value. Do I need to go in and toggle the settings again?

EDIT: I re-toggled data-sharing after my linked account updates, and repeated the same steps as my previous post at ~12:37PM EST.

I expect the data you got from @orangebucket will be roughly similar.

The names of the 3 apps I clicked/touched to open in SmartThings were named:

1F - Bathroom Main
1F - Dining Room
1F - Family Room

The ‘Automation’ backing each of those installed application instances above is named

jmd-automationrule

in the developer workspace.

Hey, I noticed today that this is fixed!! Thank you. It had gone on for a little while so I had gotten used to configuring things in the beta web app and hadn’t checked in a little while.

Anyway, thanks for the fix, and good work on the app overall. Appreciate the involvement in the community as well.

SOLUTION: this was a bug that has been fixed in the latest version of the Android app.

1 Like