HW-Q930B execute data empty

I’m trying to integrate my Q930B into my Home Assistant setup. I’ve tried a number of ready-made integrations, however all of them fails to control the advanced features (e.g. Night Mode, Bass Enhancement) which I wanted to automate (e.g. turning on Night Mode at night, which, mindboggingly, is NOT possible through SmartThings apps…).

After some digging, I realised that the issue was that for some reason, my soundbar simply does not populate the data field of the main/execute endpoint:

According to a post on this very forum, this field should be populated with a bunch of information:

{
    "data": {
        "value": {
            "payload": {
                "rt": ["x.com.samsung.networkaudio.advancedaudio"],
                "if": ["oic.if.rw", "oic.if.baseline"],
                "x.com.samsung.networkaudio.voiceamplifier": 1,
                "x.com.samsung.networkaudio.bassboost": 0,
                "x.com.samsung.networkaudio.nightmode": 0
            }
        },
        "data": {
            "href": "/sec/networkaudio/advancedaudio"
        },
        "timestamp": "2022-12-08T14:10:05.796Z"
    }
}

I’ve tried resetting the soundbar, registering it to SmartThings through a different device, to no avail.

Sending the various networkaudio commands also works flawlessly. I get both the COMPLETED status as well as the state changing on the soundbar. However, the main/execute/data field stays empty.

Is my device faulty, or is this a known issue with the Q930B?

Also some screenshots of the API responding to the set command, but still returning an empty data: