SmartThings Community

Hue Dimmer Switch Connected to ST


(Scott G) #62

Someone confirmed that’s how Wink was working with the Lutron Connected Bulb Remote by using a sniffer. The Hue remote is almost identical to the Lutron one as far as zigbee capabilities, so it would make sense. I could be wrong.


(Michael Charkowski) #63

Just wanted to put my 2c in that I’m using the above code for the Philips dimmer switch direct to a v2 hub and it’s working great. Thanks to Sticks18 for the phenomenal work. I did have a couple occurrences of the “red light” that came and went, but after deleting the device and recconnecting a few times, it went away on both of mine (I have 2, one for each bedside in my bedroom).

I’ve been using them with button controller, smart lighting, etc. and they’ve been great. Also love the fact that this thing can be used to reset hue bulbs. While I will probably add a Hue Bridge at some point in the future when I find a good deal on it, it’s great that we don’t need one.


(Scott G) #64

So they’ve been staying connected to your hub consistently now? Maybe ST did something on the backend or maybe we need to do a full reset of the device, delete from ST and rejoin.

When I first got it working, it stayed connected for 2-3 days for me before it started giving me the red light. Last couple times I tried, it only lasted 10-15 minutes.


(Michael Charkowski) #65

My first one’s been connected solid for at least 2 weeks now. Got the wife’s one in on Monday and it’s been good after one red light hiccup right after the first add. They seemed to have the occasional case of not communicating well with the hub, missed button presses, etc. (my ST hub is in my basement and these are on the 2nd floor with no repeaters on the first floor), but I added some ZWave dimmers to the room and it seems to have made the signal reliability much better. I’m using all four buttons mapped to different SmartApps and everything’s been really good.


(Mark Povolo) #66

I really want to use this switch, however, I have been through two different remotes, setup 3-4 times each and they work initially but after about 3 hours they stop working and I need to remove and re-add the device.
Any ideas would be great

thanks


(Scott G) #67

You are a lucky man! I tried again over the weekend, and while it seemed to stay connected longer, I still got the dreaded red light the next day. I tried pairing it much closer to the hub and using it closer. Didn’t seem to make a difference for me. When did you purchase yours? I wonder if they updated the firmware at some point.


(Mark Povolo) #68

Just purchased mine of the past week


(Michael Charkowski) #69

I ordered both of mine in December from Sears. You may be right about the firmware, but you need a hue bridge to update it. Which really sucks if that is your problem.


(Mark Povolo) #70

I have a hue bridge but just returned my remote. You think if I were to have connected it to Hue, tried the update, my success would be better. I assume you didn’t update the firmware, and given you got yours in Dec I also assume then that if anything my firmware is newer.

thx


(Mark Povolo) #71

Ok, picked up another remote. Linked it first to the hub, no SW updates it seems. Linked it to ST, 1 hour later disconnected again.

Any ideas what to try


#72

Hey there,

Does the hue dimmer update its FW via a Hue Hub? How do I do that?

Thanks a lot


(Mark Povolo) #73

I was trying to figure out the same on switch SW upgrade.


(Mark Povolo) #74

Has anyone tried this recently after the ST hub update. Was hoping it would work and keep the connection. I tried, same story. An hour later the remote lost connection

thanks


#75

I think there is a shared problem between the hue tap, dimmer and Swannone keyFob! They seem to connect for a while and then disconnect itself from the hub, which then requires re-pairing!

Further reading below may help those in the know how to brainstorm further ideas, to get these stubborn devices to stay connected!

There was some super helpful, knowledgeable guys helping out on the thread

Maybe solving one device will help fix the others!

The link below is the Swannone keyFob thread, and lists what was tried to try and get it working, all of which failed! Unfortunately!


#76

I got mine today from amazon in the UK - getting it to connect, reset, assign, reset etc was a bit of a hassle but it didnt disconnect so far - I assume there will be a specific message in the log to look out for?

I use a combination of the SmartLighting for button 1+4 and control buttons 2+3 for dim settings via RuleMachine …


(Scott G) #77

No message. Just after some period of inactivity with the remote, a button press won’t flash green. There will be a small delay, then it will show red light for about a second. That will be the clue that the remote has lost its connection to ST. The only way to fix it that I’ve found is to reset the remote and pair it again in ST (you don’t have to delete it from ST or anything, it will rejoin as the old device).


#78

well I had it one time that the remote didnt take any inputs and did blink red - but after a few seconds later it was working fine again - not sure if this is what you are experiencing …


#79

yup - just happened to me as well - didnt sync back and required to press the setup - quite annoying … any options to circumvent it - or are there other switches like this - I do like the form factor - that work?


(Scott G) #80

Nothing quite like this unfortunately. A solution hasn’t been found yet to keep it connected, and it’s very frustrating because these would be awesome. The Lutron Connected Bulb remote is very similar form factor, but I’m not sure it’s available in UK and it can only directly control zigbee bulbs, not send its commands through the ST Hub to work with other devices.


#81

yep I agree - I already had additional ones on the way until this one here disconnected so I cancelled the order … I assume adding a HUE bridge into this doesnt solve the issue either as I assume it will send information to the bridge only and the bridge wont forward anything to the ST ?