Hue Devices Still Executing in Cloud?


(Chris Donovan) #1

Hey, I just got the beta update that is supposed to allow Hue devices to run locally, but I still see the Hue Bridge (and all Hue devices) are set to cloud execution. Do I need to do anything specific in order to set them to run local? I am going to reboot the Hue Bridge as soon as I get home from work.


(Tim Slagle) #2

Let’s start there and see what happens. How are you verifying cloud vs. local execution? From the IDE?


(Chris Donovan) #3

Yup, went to My Devices in the IDE to check. If there are other, more accurate ways to infer device execution location, I can check as well. But either way, will do a reboot of the Hue stuff as soon as I have access (I don’t think I can reboot the Bridge remotely, right?)


(jkp) #4

My Hue devices are showing in the local devices list and in My Devices as Local:
https://graph.api.smartthings.com/localDevice/list


(Jason "The Enabler" as deemed so by @Smart) #5

My bridge and bulbs are all showing local.


(Chris Donovan) #6

And you guys didn’t have to do anything for them to show up that way? Here is my local device list right now (all these are either switches or sensors, no Hue devices):

I should be able to reboot the bridge in about 30 minutes and will report back after that.


(vlad) #7

I think your issue is that you are using self published Hue DTHs. AFAIK the auto migration only would have worked for the officially published ones. You will have to go into each device individually to change the Device Type Handler to the official ST one and then the devices should switch to Local.


(Chris Donovan) #8

Rebooting didn’t help, so I’m pretty sure that @vlad’s suggestion is valid.I have been using the Hue (re)Connect smart app instead of the official St integration. I’ll go ahead and switch over the device handlers and report back.


(the rooms manager guy) #9

my hub is still on 18.x but i have these verification tasks assigned to me … is that expected?

Firmware Version 000.018.00022

thanks!


(Chris) #10

Should the devices be LAN Hue XXXX or Hue XXXX - all of my Hue devices have LAN in front of them.


(Tom Manley) #11

LAN Hue XXXX are the correct DTHs.


(Chris) #12

I’m still seeing all HUE bulbs as cloud processing, which is why I was asking about the type.


(jkp) #13

There are a few others reporting this same issue. Be sure to post on centercode too.


(Tom Manley) #14

We have reproduced the problem where devices are running in the cloud that should be running locally and are actively debugging it. You can fix the problem in the meantime by editing the device in graph and then clicking Update without changing anything. The goal was for this to happen automatically and it worked correctly when we released 0.19.12 but not when we released 0.19.13.

At this point I think we have enough instances of the problem for our investigation so you don’t need to file a BUG report if you haven’t already done so.


Hub Firmware Beta 19.13 Release Notes