Hue BulbDiscovery Error


(Rik Taylor) #1

Pulling my hair out with this one. Everytime I go to add any new bulbs it says “Failed to Save Page Bulbdiscovery”. I have tried to fix it by doing the following

Deleting the hue hub via IDE and then re-adding in the app
Removing all the bulbs and starting again
Re-booting both Hue and Smartthings several times
Re-booting the router
Changing the IP address of the Hue box

None of the above have worked, I’ve contacted support but as its the weekend I’m guessing they aren’t working. Has anyone found a fix for this?


(Tony - SmartThings Unpublished Contributor ) #2

Don’t know how many bulbs you are trying to install at once, but if you have a bunch then try installing just a few - say 5 or less. If that works, then you have likely been experiencing ST’s max install time out.


(Rik Taylor) #3

I am trying to install 9 but have tried them individually as well to no avail.


(Rik Taylor) #4

UPDATE:

I have no added 3 of the hue bulbs but the problem I have isolated to my Hue Phoenix dowlighters which are where the error is coming from.

I have raised it with support but I’m sure others have got the phoenix lights to work


(Rik Taylor) #5

ST support have told me that the Hue Phoenix bulbs are not supported as standard and that I will need a Custom Device Handler to get them connected.

Can anyone point me in the right direction of where to start.


(Convinced ST will never be unbroken…) #6

SmartThings advertises heavily that they support Philips Hue. Why the heck can’t they do it?


(Rik Taylor) #7

Apparently its still in Lab stage so its hit and miss support. In this case miss


(Convinced ST will never be unbroken…) #8

It’s been in “lab stage” for three years. They need to get off their paralyzed butts and finish something. ANYTHING. FCS!


(Tony - SmartThings Unpublished Contributor ) #9

Use the Hue API Debug tool to determine the “type” of those lights. Once you know of that, you can modify the service manager that you are using (and/or let me know and I’ll add it to my custom service manager).


(Rik Taylor) #10

Thanks for the tip, I have managed to login to the Hue API but not sure how to get the type. I think its a colour temperature type though.

Would really appreciate if you could update your service manager and then tell me how to use it!

Would really make my day if you could help as I have been tearing my hair out all weekend


(Rik Taylor) #11

Made a bit more progress now - installed your service manager without any problems, it recognised the normal hue bulbs but not the phoenix ones, however it did import the scenes with phoenix lights in so I can control via smartthings as a switch not a dimmer. It would be great if I could get it to recognise them as lights though.

UPDATE
Can get it to turn lights on using lighting director, however there appears to be no off switch with the scenes so I can’t turn them off once on. Getting closer, thanks for your help


(Tony - SmartThings Unpublished Contributor ) #12

Scenes use a momentary device type - it should turn off automatically.


(Tony - SmartThings Unpublished Contributor ) #13

With regard to finding the type of the Phoenix Lights - perform a GET and look for the light. Each light will have a list of data including the type.


(Rik Taylor) #14

I went to add the lights again and this time it recognised them. I can control them fully now, the only issues I have notice is that they turn on and then flicker slightly (odd but I can live with it). For some reason they are not reporting status but not sure why.

Tried to get and look command but could not get it to work.