Hue Bulb Factory Reset: SOLVED if your Hue Bulb is on a ZLL Channel

OK everyone – I figured this out finally after some digging and risk taking. I have figured out a relatively simple way to reset a Hue bulb to factory fresh just using a Web Browser. I am going to describe this step by step so if you are an advanced user, this guide will likely not be very useful to you… but for those that are new or “regular users”, this may solve quite a lot of frustration. This technique works as of this writing on Easter Sunday 2017 so if you are reading this in the future, YMMV.

Problem this solves: If you acquire a hue bulb and you need it to behave as if it were factory fresh but for some reason, your Hue App can’t find the device. This can happen if the bulb has either been previously paired with another hub, or it came as part of a “bundle” paired to another device or worst yet, if you inadvertently tried to pair it with Smartthings hub first.

Step 1 - Go to the Philips Get Started page on their Developer page. On that page, it will guide you through exactly what needs to happen to access your Hue Bridge and more importantly, get your Hue Bridge ID. This ID is not the ID you use on the App - it’s a special Hub Bridge ID needed to access the Hub. You will need to know the IP address of your Hue Hub. In my case, I just went to my router “attached devices” and found it there. My strong suggestion is to go through ALL of the examples on the Getting Started web page. It’s an interesting approach because in some cases, it will return an error – which is by design. Trust the process and do every example on that page.

Step 2 – Now you should have your Hub Bridge ID. It will look like this: iZWHR6lFLFK8GtqGxx7dM2j5gUOURlGJjZP6bfQlm (I changed some characters in mine to use as an example here). Open up a text editor, word document or whatever and make a copy of this Bridge ID, just in case you need to find it later on. You should still be logged into the CLIP API Debugger which you accessed in Step 1.

In my case, I had 4 Hue White Bulbs that my Hue App couldn’t find. I found a spare lamp and placed it directly next to the hue bridge and used it for each bulb reset. The reason I did it this way is because after you issue the command below, it finds the closest lamp on the bridge and issues this reset command. I just wanted to be 100% certain.

Step 3 – Issue the touchlink command to reset the bulb

You should still be logged into CLIP. Where is says URL:, enter the following URL where YOUR-BRIDGE-ID, is the long Hue Bridge ID you created in Step 2. The IP address in my case is but likely, your last number will be something different so use the IP address of the Hue Bridge you found in Step 1.

Then enter this in the Message Body

Click the Put button - You are telling the hub to issue the touchlink command to reset the nearest bulb.

Step 4 – pair the newly discovered bulb using the Hue App. Then you are all set. :sunglasses:

Lessons learned: Like a lot of people, I spent hours trying to find a solution to what I thought should be a simple thing to do. There are many methods out there and none of them worked for me except this one. Lampstealer didn’t work, the telnet into port 30000 process didn’t work. Someone had an app called iConnect Hue that used to work but it doesn’t now. So I learned that what works today, may not work tomorrow. I feel fairly certain this will work for a long time because we’re dealing with an API (Application Programming Interface), which tend to grow but usually don’t change parameters such as touchlink.

I hope this helps. I will be happy if someone finds this useful and saves them some time and frustration, a maybe a few relationships too. :innocent:


I’m glad you got it fixed!

First, where you say “hub ID,” did you mean “Hue bridge ID”? (Hue doesn’t make a hub. A hub and a bridge are technically different in this context, which is why the Phillips device is called a bridge.)

As far as the method, I may be mistaken, but my understanding is that the means you describe will only work if the hue bulbs are on one of the ZLL channels.

The problem, as described elsewhere in the forum, is that if you manage to get your bulbs attached directly to the SmartThings hub without first attaching them to the hue bridge, the bulbs will be set to the channel that your SmartThings hub uses. This channel is assigned randomly at the factory, and can be any of the ZHA channels.

The ZHA channels include the ZLL channels like 15 and 20, But also include additional channels like 14.

If your smartthings hub happen to be on zigbee channel 14, then most of the available methods for resetting a ZLL bulb will not work.

You can see which channel your own SmartThings hub uses by checking The zigbee information for your own hub in the IDE.

As was discussed in your other thread, the Lutron connected bulb remote is unusual in that it can reset a zigbee bulb on any of the ZHA channels. Not just the ZLL channels.

If someone can confirm that the method described in this thread will work with a non-ZLL channel, that would be very helpful. Otherwise, the information in the previous threads would still apply.

(I would also note that your first post says the method only needs a web browser. It only needs a web browser if you already have a Hue bridge attached to your router. That’s important because some of the people who have this problem never bought a Hue bridge at all – – but they can still have a Hue bulb that needs to be reset.)

1 Like

Yes, this may be. I did see your comments in the other thread about ZHA and ZLL. I wasn’t able to determine exactly which my bulbs were paired to. Using the above method did work for me but honestly, I stumbled onto it. I am hopeful that between what I wrote in this input, people will be able to reset their bulbs. I’ll probably still buy a Lutron to be 100% confident it will work. :slight_smile:

BTW, to reiterate, (to my knowledge) my bulbs were never really paired to my ST hub. When I looked at my Things, I saw the 4 generic Things, which told me they were in fact the 4 bulbs in question. After the process I described above, the ST app showed them as “Downstairs Light4, Downstairs Light5” etc. Now interestingly enough, one of the bulbs didn’t show up with the name I gave it in the Hue App. It was a general Hue White Bulb (or something). So I renamed it in ST and all is right in the world.

Again, I never deliberately paired the Hue bulbs to the ST hub.

Should I edit the title or body to say something like “for ZLL Channels, not sure if this works for ZHA paired bulbs”. That may make it more accurate and precise.

1 Like

If it listed the bulbs, they paired to the SmartThings hub. In your other thread, you said

“Added a thing” is the process for pairing a device to the SmartThings hub. They didn’t show up with names because they were ZLL bulbs initially And they shifted to the generic ZHA profile when you paired them to the smartthings hub through the Add a thing process. As was suggested in your other thread, you could have at that point changed the device type handler and controlled them through SmartThings.

If after you couldn’t get them connected to your Hue bridge initially you had then just opened your SmartThings app and checked the things list, you would not have seen the bulbs there and they would not have paired to your SmartThings hub.

But once you hit the “add a thing” option in the SmartThings mobile app, you start the pairing process for any nearby devices which are in pairing mode.

That’s why the zigbee channel for your SmartThings hub matters.

edited to update I see from your other thread that your own smartthings hub is on channel 24. That’s a ZLL channel, so you got lucky. (Lucky is good. :sunglasses:)

If someone else has the same problem, but their hub happens to have been on a non ZLL channel like zigbee channel 14, the method described in this thread probably will not work and it is likely that they will still have to buy a device like the Lutron connected bulb remote or the Dresden device in order to force a reset on their Hue bulb.

So the method described in this thread is a good method, it’s just likely that it will only work on the ZLL channels, because it relies on a Hue bridge which only transmits on the ZLL channels.

if anyone can confirm that it works for a bulb which has been set to a non-ZLL channel, do let us know.

Makes sense. Now that I think about it, I am not certain if I pressed add a Thing or went to my Things list. Apparently I pressed Add a Thing. My mistake. People, don’t do this! :smiling_imp:

1 Like

Thank you, your write up worked perfect!

1 Like

Glad I could help at least 1 person :slight_smile:

Hey, This does work! Took Hue Bulb initially paired on Smartthings off, and added to Hue Bridge.

Thanks a lot!!


Hi, i tried to reset the philips hue bulb that i have (philips Lux), but i don’t understand if it is in reset.
the bulb stays on, and nothing happens.
What should be the indication?


I think how you would know is your app will see this as a brand new factory fresh bulb ready for pairing into Phillips (not SmartThings).

Hi Thanks, now the put code works, and the light flashes after the code send a few times

Today it still works. Thanks!

1 Like

Excellent. The gift that keeps on giving…

I want to give a SHOUTOUT to ZONOMO for this solution. It works!

I have a Hue Lightstrip that I added to a ceiling fixture. To do this, I removed the plastic cover so that it could fit in the fixture, without realizing that I might need the “serial number” (AKA DeviceID) later. I’ve been trying to move this to a new hub, without success. I interrogated the hub, and captured the “uniqueid”, but you can’t use this field to search for a connection. Multiple inquiries to Philips Hue for how to connect this lightstrip to a new hub went unaswered.

This worked in about 10 minutes.
I’ll repeat the steps outlined by ZONOMO for clarity:

  1. Get the IP address. I did this from my main router. The hub clearly identifies itself in the device ID list kept by the router.

  2. Launch a web browser to (obviously, replace “” with whatever your local IP address is).

  3. You will get the CLIP API Debugger screen shown above. Enter:
    URL: /api
    Message Body: {“devicetype”:“my_hue_app#iphone peter”}
    (It doesn’t matter if you don’t have an iphone and your name is not peter. This is just a placeholder so you can get access to the hub - you won’t use the name again. I’ve just copied this from the Hue website.)
    PUSH THE LINK BUTTON ON THE HUB (the big button in center of the hub. This authorizes the next step)
    WITHIN 30 seconds of pushing the link button on the hub, press “POST” on the CLIP API Debugger.
    You will get a message saying username: 1028d66426293e821ecfd9ef1a0731df. The text is randomly created. COPY THIS. You will use it to access the hub in all future steps.
    The Hue website that describes this in more detail: (also noted above).

  4. Turn off electrical power to all HUE lights except the one you are trying to reach. That way only it can respond.

  5. Return to the CLIP API Debugger:
    URL: /api/1028d66426293e821ecfd9ef1a0731df/config
    (again, the ID is the random sequence generated. This is the example from the Hue website)
    Message Body: {“touchlink”:true}
    Press the “Put” button.
    The light will blink when the Hub sees it, and it will appear in your Hue app. I did a search right after, but I don’t know if that step was necessary.

Again, this works! I would have saved hours of work if I had found this posting a few days ago.


1 Like

You’re very welcome Steven. Glad it helped.

Worked first time Thank you so much - very easy if you read the instructions…

1 Like

And if you’re lucky enough to have a smartthings hub running on one of the channels which is also used by ZLL. :wink: As we’ve already discussed up thread, but I just wanted to call it out again.

If, say, your smartthings hub is on zigbee channel 14, you won’t be able to use this method no matter what you try, because “when the hub sees it” in step 5 will never happen.

So easy for some, impossible for others.

Also, I know no one cares about this but me, but the Hue device is a bridge, not a hub. There is no “hue hub.”


I wrote this up and put it in the wiki with a little more detail and device specific.