Hue Bulb Factory Reset: SOLVED if your Hue Bulb is on a ZLL Channel

I have a Hue filament bulb with the following facts.

  1. Can connect to a Smartthings hub directly. Hub is on Channel 24.
  2. Cannot connect to Hue bridge. Does blink once if I search with serial number but then nothing happens.
  3. Can connect to the Hue bluetooth app and everything works. Tried factory resetting there but doesn’t help. Cannot connect to Hue bridge through the option in this app either.
  4. OP’s method here doesn’t work. Hue bridge is on Channel 25 if that matters.
  5. Hue dimmer switch reset method doesn’t work.

What might be some possibilities here? Next step is to buy a CC2531 zigbee2mqtt controller and issue the touchlink command.

Some additional info: I experimented on one of my working Hue bulbs. Deleted it from Hue bridge and added it to Smartthings Hub. While on Smartthings both the dimmer switch and OP’s method worked to reset the bulb.
I guess the only thing I haven’t try is the method in your other thread. But what puzzles me is the different behavior of the two bulbs after being added to the same Smarthings hub. I also have another GU10 bulb that can neither connect to the bridge nor Smartthings. It also kind of blink when searched by serial number with the bridge.

If your hub is on channel 24 and the serial number method doesn’t work, I would contact Hue support. It may just be a defective device.