SmartThings Community

Hue Advanced (Connect)

hue
smartapp_lighting

#142

@claytonjn Having issues adding a new Hue bulb to ST. Its just a white bulb and i already have one on the system which works fine, am getting this message:

physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Hue Advanced Lux Light’ in namespace ‘claytonjn’ not found. @ line 510

Any ideas?


(Adam Davidson) #143

@Bjomesphat, I think I’ve got the same problem… none of my White Ambiance bulbs are updating their setting in ST with the Hue Advanced. neither E27, nor GU10. they’re both showing up as “Hue Advanced -CD- White Ambiance Light”, whereas my colour bulbs/spots which are showing up as “Hue Advanced -CD- Light/Group”, and my dimmer bulbs “Hue Advanced -CD- Lux Light,” are all working just fine.

could it maybe be an issue with that particular device handler?


(Clayton) #144

Everyone with issues: I have not forgotten about you!

My Grandmother passed away in January and I am trying to buy her house (it’s been in the family since they had it built 50 years ago). It’s not something we were planning for so its been pretty crazy getting our house ready to sell, and trying to work out the logistics because her house is significantly more expensive. On top of that, I was sick half of last month and just got back from traveling for work.

Because we’re showing our house now I removed a lot of my Hue products so I can’t test quite as thoroughly as before. Also, I don’t have any white ambiance bulbs so I can’t do any actual testing on those.

Things are starting to settle down a bit now so I’m going to work on fixing these issues ASAP. I may need some help debugging the issue with the white ambiance bulbs. If I can’t get it figured out quickly I’ll purchase one for testing.

I’m very sorry for my absence here recently. Like I said, I’ll try to get this stuff resolved ASAP. I want to get these issues figured out before our house sells because then we’ll be busy with moving.


#145

Sorry to hear about your loss, happy to help debugging when your ready.


(Dane) #146

I ended up adding this to smartthings too, only question i had was when i try to add a thing it always ask me to press button on hue hub, should i do that or ignore it after adding the Hue Advanced Connect app. Thanks.


(Clayton) #147

You have to completely remove all of your hue devices (lights, bridge) from SmartThings, then once you have the Hue Advanced (Connect) SmartApp and all of the Device Handlers added in the IDE you can go in the app into Marketplace>SmartApps>My Apps>Hue Advanced (Connect) then go through the steps. When prompted, you do have to press the button on the Hue bridge, and then go through the rest of the setup process just like you went through with the stock Hue (Connect).


(Dane) #148

Great thanks


(Dane) #149

Do have a question, if i install this and would like to use circadian lighting I still need to install the circadian child and co-ordinator or this app does it all. Thanks.


#150

Hi, is there a virtual hue switch to be able to control multiple hue bulb groups?


#151

Still unable to add new bulb, getting this error:

     08:02:58: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type 
'Hue Advanced -CD- Lux Light' in namespace 'claytonjn' not found. @ line 510

(Scott Shell) #152

Yesterday I noticed that all of my hue groups are now showing up as not available any longer.

Is anyone else having a similar experience or is it isolated to my system?

Oddly if I dismiss the error in the SmartThings app even though there is still a note in the app that the device is not available everything still works right (lights turn on and off) and everything is reported correctly in the app. There is merely an error within the app.


(James T) #153

@scottashell I had the exact same issue last week. Rebooting Hue bridge and ST hub didn’t work. I thought it might have been down to the ST app upgrade.
In the end I had to reboot my broadband router. This then fixed the issue.
Out of curiosity are you in the UK?


(Scott Shell) #154

I am not in the UK but I will try to reboot my router and see if that does the trick.


(James T) #155

Ok cool. If you was I wondered who your router is made by, which ISP etc but never mind. Good luck with the reboot


(Scott Shell) #156

I use an Eero mesh network router (three of them).


(Clayton) #157

Do you have the “Hue Advanced -CD- Lux Light” device handler installer?


(Benjy) #158

Hi, tried this but I don’t get my hue hub to show up when searching and the app eventually times out.

I may be missing something but is the point of this smartapp to find hue hubs and devices on smartthings without a smartthings hub? I don’t have a hub so thought this smartapp would let me link smartthings directly to hue hub/bulbs.

Thanks.


(Clayton) #159

How are you using SmartThings without a SmartThings hub??


(Benjy) #160

If you add devices through smartapps or by manually adding device handlers through the IDE you can manually refer to devices like logitech harmony which use oauth or insteon which use either oauth or ip based control.

Based on your response I assume the hue smartapp needs the smartthings hub to find the hue hub on the same network?


(Clayton) #161

Correct.

When I first got SmartThings you couldn’t even proceed into the app without registering a hub, so that must have changed since then.