Hue Advanced (Connect)

hue
smartapp_lighting

(Seth) #183

I just added this for the first time. During setup in the smart app phase I get all the way to the end and then it says an unexpected error has occurred.

I followed the directions from the github and I am not super experienced here.

Any help would be appreciated.

UPDATE: I just updated everything to make sure and everything is up to date. Smartapp did the same thing.

UPDATE 2: The github page states “you must remove the Hue (Connect) service manager”. I am not certain how to do this. I didn’t see anything on the IDE that looked like this. Is there something deeper I need to do?

So still no luck. @claytonjn Any idea what I can try?


#184

Anybody else’s Hue Hub showing up just as a question mark recently?


#185

Nobody else has a Hue Hub. We all have a Hue Bridge. :slightly_smiling_face:

Try restarting your SmartThings hub to see if your Hue Bridge comes back online.


#186

My hue bridge is working fine showing Online


(Stephan H.) #187

Saw the same issue with another custom device handler I use. The issue only occurred on android and was because the main attribute tile was missing a type: "lighting" section. The issue only popped up since the last Smartthings app update. Ask the author of the device handler to update the code accordingly and it will go away. Simple fix.


(Stephan H.) #188

If you are familiar with Ide, you can edit the dth yourself. Edit the hue advanced bridge device handler…line 30… as follows:
multiAttributeTile(name:"rich-control", type: "lighting"){

I no longer have this smartApp and handler so I can’t confirm this but it should work.


#189

Bridge…hub… they’re all just little white boxes taking up space in some part of my house.

Yep! That did the trick! Thanks for the helpful answer—I never would’ve thought of that myself.


(Stephan H.) #190

Glad to hear it.
@claytonjn see last few posts regarding android issue with DTH for the Hue Bridge.


(Ryan S.) #191

I’m attempting to add a room from the Hue Bridge, but Live Logging is showing a hibernate error that I don’t know how to resolve. There are two Rooms, one added fine, the second won’t add. Thoughts on how to clear this up?:

faf70665-23ea-4e51-95d2-ee65ce612559  9:23:52 PM: error org.hibernate.StaleObjectStateException: Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [physicalgraph.app.InstalledSmartAppData#e9cf17ce-b8f1-4db1-b5f4-adcf9d136b59]

EDIT I also tried to uninstall the SmartApp from my phone to reinstall to try again and got “An unexpected error occurred” and doesn’t uninstall. I can’t remove it from the IDE either, as says “This SmartApp can’t be deleted at this time because it is installed by one or more users.” :frowning:

EDIT 2 I had to remove all of the Hue devices from the IDE before I could uninstall Hue Advanced from the phone. After that I reinstalled and everything got added fine. I dunno… I guess just the old “try reinstalling” worked.


#192

Ok… can anyone suggest why I cannot get this smartapp/dh to find my bridge? The app just sits there spinning seeking a bridge.

I have done everything: remove hue bridge, uninstall super lan connect, remove authorization on hue api, etc

Can not for the life of me get it to find my bridge… (I have a similar issue with another hue smartapp/dh on the community). I’m at a loss at this point. Please help


(Jacob W) #193

This may take a bit of explaining so let me see if I can be concise… So I’ve been using a workaround to enable my 12 Hue Taps to control more than just the lights in the room. I’ve been using this trick in HomeKit but now I’m making the switch to ST completely if possible. I’m making a piston to do the trick that I’ve been using. I used the SmartApp “Hue Connect (Advanced)” to link my Hue bulbs to ST because of the group import feature. Basically, what I do is I use iConnectHue app to program a Hue Tap button to set the BRIGHTNESS % of a Hue Bloom that I keep out in the garage to a value between 1-99% and then have a trigger (now a piston) looking at this Hue Bloom and waiting to perform an action based on that percentage and then ending with a reset of the Hue Bloom to 100% thus allowing me to repeat the request if needed. It works like a charm with HomeKit because it has instantaneous awareness of a change in brightness to each Hue bulb. What I’m finding is that Hue Connect (Advanced) and maybe all Hue SmartApps in ST seem to “poll” the hub for changes every 5 minutes. If you change the bulb attributes using ST then of course WebCoRE will get an update almost instantaneously and thus trigger the piston but if the bulb is controlled by a non-ST source (such as a Hue Tap) then you have to wait the 5 minutes for ST to poll the Hue Bridge and then trigger the piston. This isn’t very useful. I’ve installed Pollster and the best it can do is poll every 1 minute. Still not great when I want to walk into my daughters room and hit the tap and have it open the window blinds and turn off the white noise and fade on the lights to wake her up. As it stands, I’m walking in there and waiting at least a minute for any of this to happen. Any advice on how to address this? Am I doing something wrong with my piston? Here’s a copy of my (incomplete) piston so far. It’s a great trick when it works because essentially every smarthome platform can set a brightness % for a hue bulb essentially allowing any platform to control a piston (i.e. Hue Tap, Flic, Alexa, possibilities are endless really). Thanks for any help. Sorry for the not so concise explanation.


#194

The one thing that caused a problem for me was having the Hue Bridge and the SmartThings Hub plugged into a network switch. When I plugged both directly in to my router the Bridge was found straight away. Very odd, but hope it helps.


#195

Both are right into my router, side by side. i dont think thats my issue. thanks for responding though

edit… idk what mirracle happened but it magiclly worked. I didn’t change anything loll :smiley:


(Christopher Hanudel) #196

Can anybody please help.

I am new to all of this and running in to some difficulty. I have followed the directions to install Hue Advanced (Connect) but every time i get a statement telling me “deviceNetworkId must be unique”.

I have deleted the Hue app from my iPhone, and deleted & reinstalled Hue Advanced hultiple time only to receive the same statement.

Below is a copy of the Error for the log.

Thank you for your help.
-Chris

grails.validation.ValidationException: Validation Error(s) occurred during save():

  • Field error in object ‘physicalgraph.device.Device’ on field ‘deviceNetworkId’: rejected value [0017887FE564]; codes

(Clayton) #197

Sorry for the late reply, been busy with the holidays and new year. The instructions on GitHub are saying that if you’ve set up Hue with SmartThings using the standard, built-in method you have to completely remove all of the devices before switching to Hue Advanced. So in the IDE under My Locations>smartapps (for proper location if you have multiple) you should not see any Hue SmartApps prior to setting up Hue Advanced.


(Clayton) #198

Thank you, I made this update a number of days ago but didn’t get a chance to post on here for anyone without update notifications turned on.


(Clayton) #199

Polling happens every 5 minutes but the SmartApp is supposed to also get immediate status updates. The polling is supposed to be a fallback. Unfortunately, I implemented this update after switching off the SmartThings platform (almost a year ago) so I don’t have any personal experience with this. The Hue “sensors” (motion, dimmer, tap) are available in the API now, so they could be integrated directly, although I’m not sure they would update any quicker. I would like to add sensor support to Hue Advanced but I have no idea when I’ll have the free time to devote to that.


(Clayton) #200

In the IDE, go to the My Devices page. In the list of devices, in the Device Network Id column do you have something with ID 0017887FE564? (That appears to be the mac address of your Hue bridge). If you do see that ID, you have to remove the device before setting up Hue Advanced. If you don’t see that ID, you have to contact SmartThings support because for some reason the platform thinks that it’s still there.


(ilker Aktuna) #201

Philips has introduced a new Hue feature called Entertainment. It seems to have an extended API for developers.
Would it be possible to add fancy features with this ? It is introduced to be faster. Maybe better color handling ?


(Seth) #202

I appreciate the response. So I had been getting an error when going through the set up. I am not sure what may be the issue. I had no other hue smart apps.

What do you need from me to help diagnose?