Hub stays offline after Internet outage. Requires reboot (AT&T UVerse)

Hi Adrian, Thanks for your reply. I tried the fix you recommended last night. Also ST sent me a notification below specifically addressing our issue.


Between 4:00 pm UTC (4/21) and 7:00 pm UTC (4/21), we will be automatically updating your Hub to the latest firmware. The update is expected to take less than 10 minutes, during which time your Hub will temporarily go offline.

The firmware update includes a fix to address some Hubs staying offline until a reboot, improvements to ZigBee device pairing, improvements to LAN-based device connectivity, and fixes to address issues with SmartApp execution when using a large number of devices.

Thank you,
SmartThings Support


1 Like

Looks like the update fixed the issue on my Arris NVG599

1 Like

That’s great. I’ll have to do further testing when I get home, but I believe that changing the settings in my AT&T modem also fixed a problem I was having with my TV and harmony remote so I’ll probably leave that setting on the modem. Hopefully everything stays fixed now.

Just noticed my Hub has been offline since 4/20. Same AT&T UVerse issue everyone has been seeing. I’m assuming I missed the firmware update. Will I get the update once my Hub gets back online? Or do I have to wait for the next update? Anyway to manually get the firmware update?

This fix worked for me. no disconnects after disabling broadband status notification

Well the update hasn’t fixed my problem. Anytime my router reboots, which happens on occasion, the hub goes offline and stays that way until I reboot it. Its the only device in my home that happens to. There has to be an issue with the way the ST hub tries to recover from loss of it’s IP address. If even a cheap Chinese wifi cam can recover from a router reboot certainly this hub should.

If you have uveRse see the above posts on how to fix

Nope Time Warner. However, the experiment I did today did not involve an internet outage. I did a router reboot on purpose as an experiment. As I expected the hub started flashing blue and stayed that way. All the other devices in my home both wired and wireless all came back up but not the ST Hub.

I am not the only one!!!

This has nothing to do with UVerse or losing internet connection. This only happen when router reboot or lose power.

I’m hitting it, but I’m using Charter. My issue only started about a month ago.

My started right after the 4/21/16 (Hub V2) update.

I"m using Uverse and enabled the settings to disable Broadband status and router behind router. On Tuesday we had a big storm roll through and lost power for about 30 minutes. The smartthings hub wouldn’t come back online (solid blue light) until I forced it to reset using the push socket in the back of the unit. Everything else in my network seemed to recover post power outage - Sonos, wireless access points, etc. Any other Uverse settings that would be helpful?

One thing I find interesting is that I use Life360 integration to set modes and disable the ADT alarm, etc., etc. - When I returned home, even though the hub was in the offline mode, Life360 had triggered a mode change in Smartthings and turned off the alarm, etc.

One thing that seems like would be succesful if the hub detected it was offline it would go into a reboot cycle by itself say every 30 minutes or hour, which I suspect would correct the issue.

Use a UPS to power the router and the hub :wink: that’s what I do, at least. Internet works during power failures. For hours ;))

Hitting this using Wave Broadband when I reset my cable modem. I used to have crontab to reset the cable modem, had to disable it.

Waiting for a fix.

Hit this yesterday after the infrastructure update, my hub is still offline.

I am familiar with IPTables, can you share what specific command did you execute in your router?

I am having a similar problem and I would like to see if the same will fix it in my case.
I have a Motorola Cable modem.

I fixed this problem for the ASUS routers. You need to disable “Enable Internet Detect”