Hub stays offline after Internet outage. Requires reboot (AT&T UVerse)

I don’t really want to buy more hardware. I do have two switches coming off my router to supply several computers, stbs, blu-ray etc… I don’t necessarily have a need for another router, but I understand what you are saying. It very well may be the router, but AT&T gave me a new/different model router and it still fails (although it loses connection much less frequently). Every other device has no trouble getting re-connected after the connection goes down. I have assign ST a static IP.

Add me to this list. I have this same issue with my U-Verse and ST Hub. It disconnects nightly now and won’t come back without a reboot. I hope ST gets this resolved soon. Buying extra hardware to solve this is kind of self defeating, but, I appreciate the ideas as a work around. This issue makes it impossible for me to recommend the ST product to my friends that are not tech savvy at all. It is also killing my family buy-in on adopting this in my house!

Happened again this am, it would be nice to hear a update from ST.

Happens to me at will - if I reboot the cable modem (comcast) my V2 hub will go from green to blue while the modem is resyncing. Everything else comes back up fine. The V2 hub will stay “offline”/blue until I press that reset button or cycle power. Every. Time.

Not hard to reproduce. Really shocking still no fix, but given the rest of the burning platform, this fire is probably pretty low on the list.

Simple workaround for pretty much anyone who can go to a web page. GIVE US A LOCAL WEB/REST INTERFACE TO THE HUB.

The problem lies with UVerse. Every time the broadband connection is down, the UVerse router automatically hijacks DNS queries and reports any domain name as pointing to 192.168.1.254 (the router’s default IP). It does this so that if you open any web page, it will automatically display an error page hosted within the router informing you about the broadband down situation. If ST attempts to reconnect during the broadband down time and it has been long enough since the last DNS query for ST’s servers, it will ask the DNS server for a the IP for ST and receive 192.168.1.254 as a response. At this point, it will keep trying to connect to the wrong IP for as long as the DNS record is set to expire (TTL). I still have a web page that won’t open on my iPhone, keeps going to something like attdnserror.com (fake domain name that points to 192.168.1.254 within the UVerse home network)

Maybe a DNS flush before attempting to reconnect would fix this?! :smiley: :smiley: :smiley:

Or allow us to set a static IP and static DNS server on the hub?

Thank you,
Adrian

4 Likes

WOW! After months of this issue I read @ady624 post and a light bulb clicked on for me and I fixed this. In the settings for the ATT UVerse NVG589 called “Broadband Status Notification” if you turn this off the behavior described in @ady624 post above stops; e.g. the NVG589 doesn’t wipe out DNS on the ST hub.

Setting is under Diagnostics -> Event Notifications -> Broadband Status Notification. Just turn it off and save.

I tried this twice and my ST hub now back comes up almost instantly after the DSL connection is restored.

I’m so glad I ran across your post today!!

It’s not a fix for the ST hub but a very good workaround until ST fixes this.

Brad

5 Likes

Glad I could help. Again :slight_smile:

And thank you for the tip, I found the setting in my Pace 5268AC router under:

Settings > System Info > Event Notifications

Adrian

2 Likes

Thanks for the great tips! Configured it on my 3801HGV router. Will have to test it this evening.

1 Like

Thanks for the great tips! Configured it in my U-verse NVG599 Router
Diagnostics > Event Notifications
I un-checked “Broadband Status Notification” and saved. I tested it by unplugging the router. The ST hub light turned Blue as the u-verse Router rebooted, and as soon as service was restored my ST hub was back on-line and the light on the front of the ST hub turned Green… It works !!! … Thanks !!!

1 Like

I have the same issue, I just tried your recommendation. Let me see if it works. Thanks

I have ATT internet, and ST v2 Hub. for the last two weeks, I am having the same problem 1-3 time per day. I have to unplug the power and push the reset button for 10 seconds until the light turns red. This all done from a ladder as my hub is mounted 9 feet up a wall. Since it is taking so long to get this fixed, is the issue beyond the scope of software?

Lourens, try logging into your AT&T router and disable the Broadband notifications, see the comments immediately above.

:slight_smile:

1 Like

I’ve only had my hub for a couple of weeks. After dealing with the U-Verse problem every day from day 2 on, I logged into my gateway and set the IP for the device so it was no longer DHCP. It’s been working for the last 7 days since then.

Does anyone know if the new firmware release on the 21st will address this issue for U-Verse customers?

Thanks for this. I’ve just changed my settings. :slight_smile:

1 Like

I’ve also changed mine, let’s hope that it works. ARRIS NVG599

Not really, according to @slagle Try modifying your router’s settings and disable the Broadband Status Notification as described above.

1 Like

It does work, thanks

1 Like

Hi Adrian, Thanks for your reply. I tried the fix you recommended last night. Also ST sent me a notification below specifically addressing our issue.

=============
Hello,

Between 4:00 pm UTC (4/21) and 7:00 pm UTC (4/21), we will be automatically updating your Hub to the latest firmware. The update is expected to take less than 10 minutes, during which time your Hub will temporarily go offline.

The firmware update includes a fix to address some Hubs staying offline until a reboot, improvements to ZigBee device pairing, improvements to LAN-based device connectivity, and fixes to address issues with SmartApp execution when using a large number of devices.

Thank you,
SmartThings Support

=============
Lourens

1 Like

Looks like the update fixed the issue on my Arris NVG599

1 Like

That’s great. I’ll have to do further testing when I get home, but I believe that changing the settings in my AT&T modem also fixed a problem I was having with my TV and harmony remote so I’ll probably leave that setting on the modem. Hopefully everything stays fixed now.