Hub status switches feverishly between offline and active for weeks after update is pushed

I have the hub version 2 and every time an update is pushed my hub switches between offline and active according to the app but in both states it does not interface with either the app or connected devices. I have done all the things recommended on the connectivity support page but still doesn’t fix it. If i completely power down and reboot the hub it will work maybe until the next morning. I am not sure what to do.

There’s an update scheduled for tomorrow that may address this issue. I have a similar issue which started I think about 2 hub updates ago. Mine’s not switching feverishly though. It does it once and seems to affect only the presence detector in my case.

Still not working after this most recent update. Like I said, it seems to be the update that causes the problem. If we go more and a couple weeks without one the hub settles done and is stable but not until then.

I am running:
ARRIS SURFboard SB6141 DOCSIS 3.0 Cable Modem (
ASUS RT-N66U Dual-Band Wireless-N900 Gigabit Router (
A vonage box
Smartthings hub V2

The internet runs from the cable to the modem then the router and splits to connect both the vonage and the Smartthings Hub V2. Up to a week ago I had the vonage box between the router and the modem but it is not that way now and the last update should be going through fine as far as I know. Is there some setting that might affect the update going through but not the regular ST function?

No longer an issue for some reason and I changed nothing.