Hub showing Z-wave as "Non-functional" in IDE


(Hendre) #1

What could be causing the Z-Wave module state of the Hub (V2) showing as non-functional?

I had to replace my previous V2 hub because of many issues, one of which was the hub often going into this state.

What could be causing this and how do I get rid of it? I’ve tried the “Enable Z-wave module” function in the hub utilities, but that did not help. After a reboot (executed from the Hub-utilities in the IDE), the Z-wave module state changed to “Functional”.

The strange thing is that despite this state of the Z-wave showing as non-functional, I’m still able to control z-wave devices.

With the tedious process of a hub-replacement still fresh in my mind, it horrifies me to see the same message on my new hub this morning.


(Hendre) #2

I got home today with my home devices in a chaotic state. What should be on, is off and vise verse.
The hub was once again the culprit, showing Z-wave as non-functional. Turning z-wave in the Hub-utilities off and on, did not make a difference, neither did a reboot via the utilities.
I’ve now turned the hub off completely (took out the batteries as well) and waiting a few minutes before turning it on again.
In the past, this had solved the problem, but this is starting to get to me.
Am I the only one experiencing this issue?


(Bill S.) #3

I would suggest contacting support regarding the issue. What you are seeing is not normal. Make sure that you give them permission to look at your account in the email you send them (saves time and a round of emails back and forth).


(Ken) #4

You’re not the only one - I’m having the same issue though my devices appear to be working fine for the moment. I’ve got a couple of Zigbee bulbs that are acting weird and one Zwave bulb that won’t shut off (but I suspect that has more to do with the fact that it’s further away.)


(Hendre) #5

I’ve had the issue twice since my initial post. I don’t have much hope of Support sorting out the issue. They take at least 2 days to get back with generalised suggestions like “Do a Z-wave repair”. Very frustrating and the turnaround time from Support is pathetic. They have obviously not yet realised that if one’s hub is down, you’re stuffed, waking up to cold showers and other similar unpleasant experiences.
The only way I can get it functioning again is to completely shut the hub down for a few minutes.


(Ken) #6

I haven’t yet had an opportunity to call support, not thrilled to hear they’re not very responsive. I’ve done several Z-wave repairs with no luck but haven’t had a chance to shut down the hub. (We had a tornado hit our house, so I’ve had other things to contend with.)


(Hendre) #7

Sorry to hear that. Wishing you all the best.
I contacted support via email. My last email in response went out on Thursday. Still have not heard from them. (Monday evening).
My hub has fortunately been doing fine for the past 24 hours.


(Ken) #8

Interesting - I took my hub down this morning and cleaned the battery contacts in it. Let it sit out for a while and now it shows “Functional” under Zwave. We’ll see how long that lasts!