Hub Firmware Release Notes - OTA - 16.9 - V2

you can do quite a lot with the homekit apps and ifttt but I am still looking into it …

I do have mainly Osram bulbs in my setup and they all work fine - did you upgrade them via the Osram hub at all? they all report this version 01020412

With the standard disclaimers of I can only comment on what I know and this is not an official statement, etc…

There will be no migration tool from V1 to V2. It’s possible there will eventually be a tool from V2 to V2 (in case of hub replacements). If that happens, it is also possible (but less likely) there will be one from V2 to … whatever comes next.

V1 isn’t EOL until it no longer connects to our platform. That may happen someday, but it hasn’t happened yet. That said, I wouldn’t expect updates for it unless it was something serious and/or security related.


Biggest problem with homekit is that unless Apple get their cut then the connecting device do not get a look in. This’ll mean you’ll have to buy everything again and also a premium for the privilege of talking to siri.
I may love my apple kit but not enough to replace my 200+ devices in smartthings right now.

Please, please email support. Reference my ticket #286581.

The latest firmware update is junk and did more harm than good, and more people need to complain and let them know.

1 Like

I kind of what to go buy an Osram bulb just so I can complain too!

1 Like

Thank you for addressing this with the information you have. It shows a lot of integrity to speak up. :clap:

1 Like

Thank you for that statement. It makes it easier to decide what my upgrade path should look like! :clap:

I doubt this will be too helpful, but I have six Osram Lightify soft white bulbs and three RGBW bulbs. I have not had any of the on/off or loss of connectivity problems experienced by several users. I do not own any of the adjusting color temperature ones. Also, I have not updated the firmware on any of my bulbs.

All of my like bulbs are at the same firmware revision.
Osram soft white: 0x01020156
Osram RGBW: 0x01020325

I also have three iris outlets in a group and they have worked without issue for me as well.

I mostly own only ZigBee devices and have many GE ZigBee switches throughout the house.

I agree the update was trash and more people need to complain. They should also complain on sales sites such as Amazon. Got to impact bottom line. The original ST management team would have been on this. Since Samsung has come along it is all trash. I have posted my complaints on other threads so I won’t go into detail on the problems. Support hasn’t even responded other than to say reboot.
My other issue is if they know they have a problem just tell us and give us an idea of when it will be fixed. These morons who think saying nothing is good need to go back to PR 101. Be honest with your customers.

Already did a week ago. Ticket # 290332

I just ran some tests on the zigbee SmartPlugs that don’t respond. The on/off commands don’t even show up in live logs in the ide. Something is going on here.

…and it’s driving me crazy.


Me too. Mostly because my system worked great before the update. I’m not used to the albeit minor instability as of late.

1 Like

This morning 2 Zigbee SmartPlugs failed to turn on as part of a group of devices being controlled together. One of the plugs was less than 5 feet from the hub so it’s not the mesh.

Edit: Some additional info. When I look at event history for these failures I see APP_COMMAND as the Source. The successful actions have a DEVICE as the Source.

Fix this already!

Well, that’s a bit depressing. I’m also really concerned that there “may be” a replacement hub tool. I’m an IT Director who has been “doing IT” for over 21 years. I’ve seen my share of devices like the ST hub break for various reasons - power surge, bad power adapter, internal board with manufacturing flaw, dropped, etc. This tool is not for hypothetical scenarios.

The bigger problem that I have here is that the inability to produce this tool points to potential issues with the ST infrastructure itself. Yes, great strides have been made in terms of stability. But, if ST engineers can’t produce this tool there can only be two reasons why - no resources can be dedicated to it (for various reasons) OR there is a “foundational issue” with the ST environment (back end and front end) that prevents it from happening. It is that second possibility that makes me question my long term commitment to the platform. And, for those that know me around here, I have been a huge champion of ST, recommending to numerous friends, etc.

This is essential (as a backup tool).

V2 to V3 should be on the table (with no disclaimers) - a migration tool for your client base is generally a good thing.

1 Like

That’s true. But at this point there isn’t even a V3 table for a migration tool to be on.

1 Like

I believe it is primarily a question of resources. I don’t have enough technical knowledge to know exactly how the device pairing issues might be solved, but I’m not aware of any other issues that would prevent us from building the tool.


If it’s radically different (i.e. true local processing, or something else truly beneficial), I understand (and it’s worth the pain of resetting up).

Not what I meant. I’m not aware of any actual plans for V3. So planning a migration tool would be somewhat premature.


so does anyone have sensors stuck without an update. I just ordered from amazon a few weeks ago, the hub updated after install and so did 2 motion sensors and 1 multi purpose sensor. However one of the multi-purpose sensors is not updating. The IDE says
" Current Version: 0x11015310
Target Version: 0x1F015310 "
And this sensor goes offline every night - i suspect thats when it tries to update, but fails and goes offline? Then I do the battery jiggle dance on the sensor to get it to rejoin and it comes back up and joins, but never updates to latest firmware.
Any way to force an update?