Hub Firmware Release Notes - OTA - 16.9 - V2

Not sure if this is the same. I lost a zwave switch after the update. Didn’t know until last night. Have to many I guess. I was able to get it to rejoin just the normal way.

My hub updated to 16.9 and seems to be working fine. It did reboot a bunch of times later that night, and seems to reboot once a day since, but I never really looked that close at the logs to see if rebooting once a day was normal for it.

Now the question is, do I enable ZigBee OTA Updates?
I have 4 ST Multi Sensors, 3 ST Arrival/Presence Sensors, 1 ST Moisture Sensor, 5 Iris Smart Plugs, 1 Iris Smart Button, 1 Lightify RGBW Bulb, and 1 Lightify Dimmable Bulb. The Lightify bulbs are connected directly to ST.

It will only update the smartthings ones. Not the others. And the multi sensors and motion I believe are the only ones that have an update.

Whilst on the z-wave topic, does anyone get their z-wave repair to actually complete.
When I click on Repair Z-Wave Network and then Start Z-Wave Network Repair all I get is:-
The notorious spinning blue circle
Z-Wave Network Repair started and the blue spinning circle.
I never get a completion message so I have no idea if it actually does anything or not.

When I try from the ide I get the following.

Anyone else getting this?

The app has pretty much never reported ANYTHING for me, I do get success with the IDE, sometimes have to run it more than once, but since I removed my IRIS Plug z-wave repeaters this issue has gone away as well.

I’ve always got this when using the app. No actual feedback when it finishes.
Doing it through the IDE is much better.

The only failures that I see in the IDE are for a joined, but off line devices…

Your z-wave repair finished, you just have 3 devices that failed. Can you check if they exist anymore? If they do exist, are they powered? If they don’t exist there is a way to get rid of them, I can’t remember what it is, but @JDRoberts pointed me in the right direction about 6 months ago.

Thanks for the reply.
I just realised what was inside the brackets meant.
I have no device with a Network ID of 1D.
I think it was a Fibaro Dimmer that I now have as a spare and not integrated. (Well thats all I can think of anyway).

Try this thread:

1 Like

After going through all (literally) of my code for all (literally) of dth and app and custom whatever’s I couldn’t find any issues. I ran everything I could with Kali Linux, if there’s any problems the tools that has will find it. I spent 18 hours total and didnt find any significant issues.

I did get random reboots, offline, zigbee, Osram, smartsense issues fixed.

From the hub:
Remove lan cable
Remove batteries and power cable
Leave disconnected 30 minutes

Perform tcp dump on router
Unplug Osram products until you plug hub back in
Remove batteries from smartsense sensors press pair button
for 5 seconds (drains juice from caps like on mb cmos clear)

If using CoRE rebuild pistons 2x after coming back online

No issues and super smooth sailing since with a bit more zip

1 Like

You can add me to the list of people with the motion sensor issue, funny thing is the iris motion sensor blinks green on motion. However the smartthings is reporting motion but the sensor is not blinking green?? wonder if there is some issue with understanding the data received by the new firmware

Thanks for the info.
I took 2 or 3 attempts of providing / deleting a ‘trash’ device with the network id for it to not report it on the network anymore.
Only problem is, now when I do a z-wave network repair I get no response back on the ide.
Oh well, no worries. Things are working OK. (At the moment :wink: ).

1 Like

That’s actually normal from my experience. In the case of “failed to update mesh info” the workaround is to exclude, and add new device. Pain if you have smart app dependencies. The iOS app never reports completion, or any status updates, no version ever has. The IDE may take 10-45 minutes depending on how many devices (it walks through each one) plus how many times the zwave module reboots itself. “Err 101: ZW module not responding”

Hi @Aaron and @tpmanley,

Tom, thanks for the reply on the other thread. All seems OK with zigbee devices today, but look what’s now happening to ALL my zwave switches (70+ of them):

Ticket #287314 - All zwave devices freaking out with indicatorStatus messages flooding the event log.

When I mean every zwave switch, I mean EVERY. It’s been going on since yesterday, and I just noticed today after my hub rebooted for no reason…

I just discovered today that my Aeon Heavy Duty Switch has gone missing. Not sure how long it’s been missing, but I can’t find it in my device list anymore. My water heater is crying :wink: And I am not even in the same state as my home ;(

Yea, I had that too, I went back to my custom dth for switche’s and dimmers, that fixed it.

oh yay… I wish there was a mass change tool for something like that, but I’m not holding my breath. I’d be dead by now if I did that for the migration tool…


Same problem here, network repair is failing to communicate/update with a powered Thermostat not 20 ft from it and the CLOSEST Z-Wave device in the entire house. Now I can’t control it. I’m trying to add a new Utilitech Z-Wave Water Sensor and it won’t pair, I’ve tried rebooting the hub, when I tried to repair it I lost communication with the Thermostat. So now I’m down one thermostat and can’t pair new devices.

AFAIK this firmware update is trash and should be recalled. I want an option to NOT upgrade and have my things working again. FRUSTRATION!

@slagle please push it up the chain and help us get the old firmware back.

1 Like

I was away from home when the update happened… luckily I had no problems… at first. ST was nice enough to wait until I got home.

All of my ST motion detectors locked up on me after getting firmware updates. Battery pulls fixed them for a bit. But throughout the day, I keep having at least one either lock up, or continually report motion. Battery pulls have fixed them so far. Just got to work and looked at everything and I have one sensor stuck on motion and one continually reporting motion again. Also lost 3 light bulbs last night that I was able to power cycle to get back playing nice again.

This is really a high maintenance update…