Hub Firmware Release Notes - OTA - 16.9 - V2

So far the only Z-Wave device that I have seen with a way to upgrade firmware was the Aeon Multisensor and it uses a USB cable. There may be other manufacturer specific methods that need a specific hardware device to send the firmware.

Z-Wave Plus built a standard method to do the upgrade.

1 Like

@slagle - I do not believe this was mentioned anywhere in the thread. I noticed the App Engine was also upgraded from 1.4 to 1.5.1. I believe that is what runs local smartapps, if so, what were the changes?

2 Likes

The main thing is that the version of the SmartApps/DTHs running locally in AppEngine was updated to match upstream. For public devices this is the delta. Obviously, not all of the devices in public are supported locally (notably, we do not currently support LAN devices in AppEngine).

So OTA is only for ST products, correct?

Yes, to start with, but we’ve been told it’ll expand to other devices later.

1 Like

Anyone else get a load of false alarms on their motion sensor during an OTA firmware upgrade of a sensor?
Until now I’ve not had any problems but last night I had one sensor repeatedly detect motion for 7 hours while it was upgrading.

It even continued after I removed it and placed it in a cardboard box so I know it wasn’t actually seeing anything!!

1 Like

I’m glad it’s not just me! Thought I had a glitch!

Mine went mental for a while, setting off SHM and some other monitoring I have. Annoying when you are at work and I can normally safely ingore 1 warning but after about the 5th I had to check all my cameras that I wasn’t being robbed!

Kraeg

2 Likes

After a night of my lounge lights going on and off thanks to an ST motion sensor deciding it was seeing motion, I decided to reset it.
Went straight into a firmware update but now not detecting motion.
Firmware update finished and still not working.
Full reset done. Still the same.
EDIT: Email sent to support. Ticket number 285190.

1 Like

I had something similar occur once. When you hit refresh does it still update the temperature, but just not report motion? If so, then my fix was to switch off all nearby zigbee repeaters and perform a reset. Otherwise I wonder if it’s bricked due to the reset in the middle of a firmware upgrade!

Yes, I was kept up with the sirens baring again and again. The false motions started exactly after the firmware upgrade message started and stopped exactly after it said it completed over a 7 hour period. Really not good, @Aaron could this be fed back as a known issue to be looked at in future upgrades to stop driving people crazy!

I did not have an issue with the motion sensors but I do know that someone on the beta had the issue with motion sensors going off during the upgrade process.

1 Like

Of my 22 smartthings motion sensors I have had two behave like this now.

I had one motion sensor quit on me. I lucked out, a simple battery pull brought it back to life. I only noticed this by luck though. I have a couple more remote sensors I don’t usually walk by that I need to test this weekend.

I only have around 10 sensors; but mine was two of them as well (annoying that one of them is connected to SHM)

Support have suggested I remove all smartapps and remove and rediscover it whilst sitting next to the hub.
Tried it but no joy I’m afraid.
Comes back permanently detecting motion.
As a matter of interest it did a firmware update yesterday so not sure why it did it again today unless the firmware update yesterday didn’t take.
Waiting for support to get back to me.

I had this as well.

I am unable to add any new device tot the hubafter the update. Tried to add a Smartthings Motion Sensor and GE switch.
Also, a couple of motion sensors showing wierd behavior - detecting motion when no one is around.
Worked with Support yesterday they think it’s my hub hardware.

So is this an issue with updating the ST Sensors firmware? Or updating the Hub?
Wondering if I should leave OTA turned off for now.

My hub updated to 16.9 around 3pm EST, and then rebooted 7 times from around 9:45-11:15pm EST What’s up with that?

We are not receiving widespread reports of Hub or sensor issues from the firmware update. It sounds like many of these are incidental cases; probably related to the Hub and sensors rebooting and Zigbee networks rebuilding, but not explicitly the firmware update itself.

Some steps to try for sensor issues:

  1. Enable Insecure Rejoin for Zigbee networks
  2. Reconnect the sensor by putting the Hub in join mode and power cycle the sensor
  3. Do the same as above for repeaters
  4. For Motion sensors, briefly cover them. This is the time of year people start turning on heating - which can trigger false-positive events. (side note - one of my most brilliant experiences on the support desk was correlating false-positive motion events with a thermostat turning on and off_)

For Hub update issues… the update servers were running a bit slow yesterday. I think we go everyone, but that might explain why it too ka bit of time for the update to fully download. Unplug the Hub for five minutes (until you get a Hub offline notice) and plug it back in to force a new server connection

As always, please feel free to contact Support and we can dig into your logs, etc.

3 Likes

@Aaron I put my garage one into a shoe box and it still continued reporting motion on and off for the whole duration of the firmware update. I had no choice but to exclude it from SHM. After the update completed it was perfect.

1 Like