Hub Firmware Release Notes - 27.6

Openhab2 device handler is broken by this update. Openhab still receives updates from SmartThings, but commands sent from openhab to the ST hub time out.

Openhab reports a timeout, while ST reports “error received a request with an unknown path: HTTP/1.1 200 OK”

1 Like

This firmware has adversely affected all my Fibaro Dimmer 2’s, they are now all unresponsive but showing online in the IDE, just me?

This update broke the MQTT Bridge. Device updates are being sent as before but the hub no longer accepts/processes commands.

2 Likes

All of my ST_Anything ESP 8266 devices have broken as of 18.21BST last night. I wish Samsung wouldn’t keep doing this, super frustrating. Here.

We are aware of the issue and some engineers with knowledge of that portion of the system are currently digging to figure out the root cause

4 Likes

Thanks everyone for bringing up the issue of not being able to receive LAN traffic on port 39500. We have identified the root cause and are working on getting out a fix as soon as possible.

In the interim, a temporary fix is to pull the Ethernet cable from the back of the hub, leaving it unplugged for about 30 seconds (long enough for the status LED to turn either blinking or solid blue), then plugging the cable back in. For V3 hubs on Wi-Fi a reboot of your router/AP should do the trick. This will force a disconnect/reconnect to the SmartThings cloud and you should be able to receive LAN traffic on port 39500.

If you power cycle your hub, the issue may reappear. Performing the steps above should get it back in working order.

My apologies for the inconvenience and thank you all for your patience while we work through this issue.

Barry

7 Likes

I just logged a similar support request as the status of my Wemo plug also no longer is accurate - when its on its says off yet I can turn on the device so I know its connected. When I turn it on or off I sometimes get a spinning turningon or turningoff then never resolves .

The Wemo integration does use port 39500 to post back status updates. If you follow the steps I posted above you should start receiving Wemo events again.

2 Likes

Hi Barry thanks for the suggestion - I have V2 Hub and that didnt work for me - I disconnected made sure the Hub registered offline and then connected it back to the LAN and same result - Wemo device is active and the device status shows Off

support says do the hokey pokey

To clear the cache for the SmartThings application, on Android devices.

  1. Go to your phone settings.
  2. Tap App/Applications
  3. Navigate to SmartThings
  4. Tap Storage
  5. Tap Clear Cache

@BarryA, @BroderickCarlin

Thank you for the quick response. I will give your workaround a try when I get home tonight and will report back my findings.

2 Likes

Is it working now?

Nope neither worked for me - unplugging the LAN or clearing the CACHE - Wemo plug is active and both mobile devices versions show OFF

I pulled logs from your hub and didn’t see any attempts of your Wemo switch posting status to 39500. Can actuate the Wemo device from either the Wemo app or the physical button on the switch itself? That should get events hitting 39500 and hopefully an updated status in the SmartThings app.

Ok Barry that worked - I assume you requested that I actuate the Wemo device (plug). I did that and it didnt work at first - then I removed the device and then added it again. I saw the ST determining device status - I then turned on the Wemo plug with the Wemo app and the ST application correctly updated -

@BarryA, @BroderickCarlin

I was able to perform the workaround listed above and now ST_Anything is able to send data to SmartThings once again on port 39500. Thank you for the temporary solution. I like forward to the permanent solution in the future.

1 Like

FYI @BarryA, ever since I got this update I’ve stopped receiving the constant “Master Bedroom Fan [80]: Not responding” hub event log that I was getting with 27.5, and that I submitted a Centercode bug report for. This is a really good thing, so let’s hope this is permanent.

2 Likes

EDIT: I figured something out to get it to work. I temporarily plugged the hub into another router that got it a different local IP address, then I unplugged it and put it back to the original router and IP. This seems to have forced the TCP stack in the hub to reset

PREVIOUSLY: Barry can you check my hub. I did this procedure twice (30, then 60 seconds), and still no go. I’m using Dan’s ESP32Wifi ST_Anything. I also only saw a blinking blue LED, never solid.

I also tried clearing the cache, re-saving the device definition and driver in the IDE, cleared cache in the app, saved the settings in the ST_Anything app – no dice.

Thanks in advance.

3 Likes

I’m also affected with my ST_Anything ESP 8266 devices. The 30s unplug workaround was successful for all my devices. Please fix this, thanks.

I tried the 30 second unplug workaround and it’s still not working. Any other advice?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.