Hub Firmware Release Notes - 27.6

Hi There,

I have a V2 Hub updated to 000.027.00006

Currently all my Zigbee devices seem to be down/Offline. Is there an outage? or is it related to the firmware update? I have tried rebooting the hub with no change. Thanks


I am also having the same issue as described here. I have several sensors that are no longer working since the firmware update. Is it possible to change back to an earlier firmware version or prevent these firmware updates in the future?


I’m having the same issue as everyone else. All my sensors are not updating their status since the update.

Is there a way to roll my firmware back?

@Automated_House: Thanks for the confirmation. Are there any plans for future updates for the WiFi hub as well? Why do all the other hubs receive updates, but this specific hub not? Any reasons for that?

This firmware update has broken status updates and motion reporting from my connected WeMo motion sensors.

This integration no longer works for me after the firmware update. It worked up until the firmware update.

The Raspberry Pi can see all of the activity, but ST is showing nothing.


I post unsolicited messages to port 39500 on a V2 hub from Tasker on Android. They are still being received and processed by my own custom DTH which uses the MAC address of the Android device as the DNI. That might suggest the problem either isn’t 27.6 or has a narrower focus.

1 Like

Having the same issue since yesterday’s update (2:03 PM CST), sensors are ACTIVE but the child devices don’t report any readings and recreating one doesn’t also create the child device. One of the sensors is reporting luminance in my living room and dims the light automatically, which is broken right know.

Thanks for the info, @orangebucket. Can you please share with me (via PM) an example of the exact command you are issuing via Tasker? That would allow me to compare your syntax to mine to see if the formatting is different.

1 Like

Openhab2 device handler is broken by this update. Openhab still receives updates from SmartThings, but commands sent from openhab to the ST hub time out.

Openhab reports a timeout, while ST reports “error received a request with an unknown path: HTTP/1.1 200 OK”

1 Like

This firmware has adversely affected all my Fibaro Dimmer 2’s, they are now all unresponsive but showing online in the IDE, just me?

This update broke the MQTT Bridge. Device updates are being sent as before but the hub no longer accepts/processes commands.


All of my ST_Anything ESP 8266 devices have broken as of 18.21BST last night. I wish Samsung wouldn’t keep doing this, super frustrating. Here.

We are aware of the issue and some engineers with knowledge of that portion of the system are currently digging to figure out the root cause


Thanks everyone for bringing up the issue of not being able to receive LAN traffic on port 39500. We have identified the root cause and are working on getting out a fix as soon as possible.

In the interim, a temporary fix is to pull the Ethernet cable from the back of the hub, leaving it unplugged for about 30 seconds (long enough for the status LED to turn either blinking or solid blue), then plugging the cable back in. For V3 hubs on Wi-Fi a reboot of your router/AP should do the trick. This will force a disconnect/reconnect to the SmartThings cloud and you should be able to receive LAN traffic on port 39500.

If you power cycle your hub, the issue may reappear. Performing the steps above should get it back in working order.

My apologies for the inconvenience and thank you all for your patience while we work through this issue.



I just logged a similar support request as the status of my Wemo plug also no longer is accurate - when its on its says off yet I can turn on the device so I know its connected. When I turn it on or off I sometimes get a spinning turningon or turningoff then never resolves .

The Wemo integration does use port 39500 to post back status updates. If you follow the steps I posted above you should start receiving Wemo events again.


Hi Barry thanks for the suggestion - I have V2 Hub and that didnt work for me - I disconnected made sure the Hub registered offline and then connected it back to the LAN and same result - Wemo device is active and the device status shows Off

support says do the hokey pokey

To clear the cache for the SmartThings application, on Android devices.

  1. Go to your phone settings.
  2. Tap App/Applications
  3. Navigate to SmartThings
  4. Tap Storage
  5. Tap Clear Cache

@BarryA, @BroderickCarlin

Thank you for the quick response. I will give your workaround a try when I get home tonight and will report back my findings.